Sign in with
Sign up | Sign in
Your question
Closed

Windows Installer Service - Complex Error

Last response: in Windows Vista
Share
July 18, 2012 10:09:04 PM

I am trying to install the program for my brand new headset. But I got the Windows Installer Service could not be accessed issue keeps poping up!!!!! I have spent numerous amount of hours today researching and trying to fix it. I am so stressed out I want blow my house down. Most of the solutions were through Microsofts website such as going into services/cmdand registry. So I began at the 'services' when I opened up the services through the start>program( sorry I dont know jack about programming at all ) and there was an easy step to fix it. But then another roadblock came and I couldn't resolve it. I dont know what it was but after I opened services after I restarted my computer... IT WAS GONE !!! I dont know where it went or why. I am not sure if my systemMechanic deleted it. Because before it existed on Services the solution was as easy as going to services and starting it. But i couldn't even right click it!!! it said the on status that it was failed or something I dont remember thats how stressed and input i put into my head... I tried as many microsoft forum solutions but none of them worked. The MSIServer failed on me on the CMD option and the Service name is not valid. Google couldn't even help me going from a problem to another problem to another i Just couldnt go so into depth the with problem that I found nothing relative!!!!!!!!

http://support.microsoft.com/kb/2642495

Solution 3 & 4 3 I cant find the service anymore and 4 i might aswell do a system restore but I downloaded Steam 2 days ago and I don't want to lose it as i have two games there. And I have no clue not even a pinch on how the back up files.. any of that.

Please I need help, I don't understand why I am having such a big problem with this. But i realized when I first plugged in the usb into the PC it was downloading something and said the content is ready for use and whatever whatever...... but I can't download the program onto my computer and im not even sure if the headset works. Update the headset does work but I can't get to configure all my options because I the program isn't downloaded.

I spent time looking for options so then i decided to download a patch for Windows Vista x64 4.5, so I downloaded. Then a problem comes up saying the update does not apply to your system. So I'm guessing the download failed. I don't know... then I went to control panel > windows update and it says Check for updates for your computer > I click check and it says Windows Update cannot currently heck for updates, the service is not running you may need to restart your computer. I restarted it several of times and it doesn't work. Like I have so many lose ends I don't even know where to start. Like i have no background experience in this. I don't know the steps to programming like once a program/update is finishing, i should registry it then update then re-register. Like I dont know any of this I am stuck on a dead end and I need some help...........


So now I'm stuck to the obvious solution learn how to back my files up and start clean. Which is time consuming and I hope that I do it right. But I'm wondering if there's another option as it seems that my Windows Update is stuck on the red X and I can't seem to do anything about it. I was thinking of downloading something hopefully you guys can steer me here on where to start now and I greatly appreciate it. Because I have a feeling since its not a service anymore and I need to download it again, register it and then what ?

oh yea I tried a notepad trick to have it update itself I think thats the word, but when the file was on desktop for some reason I couldn't run it as administrator only take ownership


AHHHHHHHHHHHHHHHHHHHHHHHHHHHH@@@@@@!!!!!!!!!! i can't even play my games because I get the error after extractions are complete the same ******* *** happens !!!!!!!!!!

Best solution

July 19, 2012 2:20:39 PM

You can try a Repair setup of Vista, that will leave your files in place and should clear up the installer issues. http://www.bleepingcomputer.com/tutorials/repair-window...
Share
July 19, 2012 6:27:07 PM

Best answer selected by hconduc.
Score
0
July 21, 2012 5:23:34 PM

This topic has been closed by Area51reopened
Score
0
!