Sign in with
Sign up | Sign in
Your question

Hard drive not showing correct gig capacity

Last response: in Storage
Share
July 4, 2009 7:12:47 AM

I need help, I have been trying to fix this all day. I have one single 74 gig WD SATA HD Raptor that has had ubuntu on it for the last 4 months. Today I was going to put windows back on because of all the recent games that came out when i noticed windows showing 32 gigs total for HD when I was going to reformat to NTFS.

I have a new motherboard with the latest bios an asus m3n78-em, thats only 1 month old.

The only way I can get my computer to show the 74 gigs is if i go back and try to install ubuntu, then the linux partitioner sees all 74 gigs. But, I reinstalled ubuntu and now when i boot into grub I get an error 18 message.

I have tried to run 1's and 0's using the WD diagnostics, but even that cd only shows 32 gigs.

What gives, ,what am I missing here??
a b G Storage
July 4, 2009 10:09:17 AM

Sounds like when you installed Linux, you partitioned it into two halves. And because the media descriptor byte of the second partition says "Linux", it's invisible to Windows.

You may need something like Partition Magic or a shareware equivalent.
a c 127 G Storage
July 4, 2009 1:20:00 PM

Just boot from windows cd, delete the partitions and create a new large 74GB one. Problem solved? You will loose all data on the linux partition though.
Related resources
July 4, 2009 10:01:25 PM

I am at a loss here. If i boot from the windows cd and go to create partitions it only shows a 32.8 gig drive, not the 74 gig drive. So i can only partition 32 gigs of space. Partition magic only shows 32 gigs, and 'ultimate boot cd' only shows 32 gigs.

I reinstalled ubuntu and its showed the entire 74 gigs. But, when i go into the bios after installing ubuntu with the 74 gigs, the bios states that it is a 32 gig drive.

Arrgghh I cant figure this out, ubuntu is the only thing that recognizes all 74 gigs.
July 4, 2009 10:40:06 PM

Hard Disk Summary
Hard Disk Number,0
Interface,S-ATA
Disk Controller,Standard Dual Channel PCI IDE Controller (ATA)
Disk Location,"0, Device: 0"
Hard Disk Model ID,WDC WD740GD-00FLC0
Hard Disk Revision,33.08F33
Hard Disk Serial Number,WD-WMAKE2357695
Hard Disk Total Size,32247 MB
Power State:,Active

Logical Drive(s)
Logical Drive,C: []

ATA Information
Hard Disk Cylinders,65531
Hard Disk Heads,16
Hard Disk Sectors,63
Total Sectors,66055244
ATA Revision,ATA/ATAPI-6
Bytes Per Sector,600
Buffer Size,8192 KB
Multiple Sectors,16
Error Correction Bytes,74
Unformatted Capacity,37797 MB
Maximum PIO Mode,4
Maximum Multiword DMA Mode,2
Maximum UDMA Mode,150 MB/s (6)
Active UDMA Mode,150 MB/s (6)
Minimum multiword DMA Transfer Time,120 ns
Recommended Multiword DMA Transfer Time,120 ns
Minimum PIO Transfer Time Without IORDY,120 ns
Minimum PIO Transfer Time With IORDY,120 ns
ATA Control Byte,Valid
ATA Checksum Value,Valid

Acoustic Management Configuration,Adjust
Acoustic management,Supported
Acoustic management,Disabled
Current acoustic level,Max performance and volume (FEh)
Recommended acoustic level,Min performance and volume (80h)

ATA Features
Read Ahead Buffer,Supported
DMA,Supported
Ultra DMA,Supported
S.M.A.R.T.,Supported
Power Management,Supported
Write Cache,Supported
Host Protected Area,Supported
Advanced Power Management,Not supported
Power Up In Standby,Supported
48-bit LBA Addressing,Supported
Device Configuration Overlay,Supported
IORDY Support,Supported
Read/Write DMA Queue,Supported (32)
NOP Command,Supported
Trusted Computing,Not supported
64-bit World Wide ID,Not supported
Streaming,Not supported
Media Card Pass Through,Not supported
General Purpose Logging,Not supported
Error Logging,Supported
CFA Feature Set,Not supported
Long Physical Sectors (1),Not supported
Long Logical Sectors,Not supported
Write-Read-Verify,Not supported
NV Cache Feature,Not supported
NV Cache Power Mode,Not supported
NV Cache Size,Not supported
Free-fall Control,Not supported
Free-fall Control Sensitivity,Not supported

S.M.A.R.T. Details
Off-line Data Collection Status,Successfully Completed
Self Test Execution Status,Successfully Completed
Total Time To Complete Off-line Data Collection,1719 seconds
Execute Off-line Immediate,Supported
Abort/restart Off-line By Host,Not supported
Off-line Read Scanning,Supported
Short Self-test,"Supported, Click To Start"
Extended Self-test,"Supported, Click To Start"
Conveyance Self-test,"Supported, Click To Start"
Selective Self-Test,Supported
Save Data Before/After Power Saving Mode,Supported
Enable/Disable Attribute Autosave,Supported
Error Logging Capability,Supported
Short Self-test Estimated Time,2 minutes
Extended Self-test Estimated Time,30 minutes
Conveyance self-test estimated time,5 minutes
Last Short Self-test Result,Never Started
Last Short Self-test Date,Never Started
Last Extended Self-test Result,Never Started
Last Extended Self-test Date,Never Started
Last Conveyance Self-test Result,Never Started
Last Conveyance Self-test Date,Never Started

Security Mode
Security Mode,Supported
Security Erase,Not supported
Security Erase Time,Not supported
Security Enhanced Erase Feature,Not supported
Security Enhanced Erase Time,Not supported
Security Enabled,No
Security Locked,No
Security Frozen,Yes
Security Counter Expired,No
Security Level,High

Serial ATA Features
S-ATA Compliance,Yes
S-ATA I Signaling Speed (1.5 Gps),Supported
S-ATA II Signaling Speed (3 Gps),Not supported
S-ATA Gen3 Signaling Speed (6 Gps),Not supported
Receipt Of Power Management Requests From Host,Supported
PHY Event Counters,Not supported
Non-Zero Buffer Offsets In DMA Setup FIS,Not supported
DMA Setup Auto-Activate Optimization,Not supported
Device Initiating Interface Power Management,Not supported
In-Order Data Delivery,Not supported
Asynchronous Notification,Not supported
Software Settings Preservation,Not supported
Native Command Queuing (NCQ),Not supported
Queue Length,Not supported

Disk Information
Disk Family,Raptor
Form Factor,"3.5"" "
Capacity,"74 GB (74 x 1,000,000,000 bytes)"
Number Of Disks,2
Number Of Heads,4
Rotational Speed,10000 RPM
Rotation Time,6.00 ms
Average Rotational Latency,3.00 ms
Disk Interface,Serial-ATA/150
Buffer-Host Max. Rate,150 MB/seconds
Buffer Size,8192 KB
Drive Ready Time (typical),7 seconds
Average Seek Time,4.5 ms
Track To Track Seek Time,0.6 ms
Full Stroke Seek Time,10.2 ms
Width,101.6 mm (4.0 inch)
Depth,147.0 mm (5.8 inch)
Height,26.1 mm (1.0 inch)
Weight,730 grams (1.6 pounds)
Acoustic (Idle),2.9 Bel
Acoustic (Min performance and volume),3.6 Bel
Acoustic (Max performance and volume),3.6 Bel
Required power for spinup,"1,400 mA"
Power required (seek),10.0 W
Power required (idle),9.2 W
Power required (standby),2.7 W
Manufacturer,Western Digital Corporation
Manufacturer Website,http://www.westerndigital.com/en/products


Dunno if that helps
July 4, 2009 11:09:14 PM

Did you not read jsc's post? i will reiterate. It seems like you linux install has made it's own partition thus making the drive show smaller when on windows.
July 6, 2009 12:05:11 AM

I have read jsc's post and i tried partition magic. Partition magic just recognizes 32 GB as well.

How do i change the media descriptor byte back to whatever so my computer will recognize the entire drive again? Even the bios only says 32 GB hardrive
July 6, 2009 7:52:04 AM

blove31 said:
I have read jsc's post and i tried partition magic. Partition magic just recognizes 32 GB as well.

How do i change the media descriptor byte back to whatever so my computer will recognize the entire drive again? Even the bios only says 32 GB hardrive


You're obviously missing his main point. Linux only left 32gb for windows. Partition magic will not see it, unless i am mistaken. Windows won't it, only linux will see it. My guess as is JSC's, is if your Lunix install was removed Windows would recognize all 74gb.

If that is not the the reason why you're not seeing your entire hard drive from windows, which is a possibility, then i'm not sure what the problem is.

Unfortunately i can't help you on the media descriptor thing. Only thing i can think of is either removing Linux or googling "How to change media descriptor byte" or similar. At least until someone who does know responds. If someone does. Also you could try changing the partition size of Linux. Again i couldn't help you on how. Sorry.
July 6, 2009 12:29:22 PM

run a debug script on the HD........
July 6, 2009 7:44:15 PM

Ubuntu has been removed, i have reformatted, I have written 1's and 0's to the drive. The linux partitioner sees the entire drive if I try to install ubuntu again, it also sees windows.

If i boot up windows Xp cd it sees only 32gigs for NTFS formatting.


I have checked jumper settings, bios is updated.


What completetly does not make since is why the bios only recognizes 32 GB. Seems the bios should always state the correct capacity. Even though if i boot up a ubuntu partitioner cd it sees 74 GB.
a c 342 G Storage
July 6, 2009 8:15:38 PM

Somehow you must delete all partitions on the drive. When starting from a Windows Install CD, you should NOT be trying to Format anything. First you need to Delete any Partition you find. Then you Create a new Primary Partition but only IF it can see that the disk has the full 74 GB available for use. If that works, only then do you Format the new Partition.

If Windows Install CD can't delete all the old partitions to see the whole drive, maybe your Unbutu system has a utility to delete all existing Partitions. Alternatively, look around for an old Windows (like Win98) version that includes the old FDISK.EXE DOS utility. You'll need a way to boot into a basic DOS so you can run FDISK, but it might be able to delete all Partitions so you can start fresh.
July 8, 2009 11:16:27 PM

I am real close to getting this fixed and man this has been one of the few things with computers that has really tested me.

Somehow my CHS (sectors) I think are setup wrong. I used a boot iso called "test drive", which is linux based to scour my hardrive.

My CHS needs to be 9039,255,63, sector size=512 which makes it 74 GB. For some reason it shows up as 4011,255,63, sector size = 512 which = 33.9 GB.

U can change these values in test drive but when I reboot its like it didnt save. I think this is the problem but still unsure how to fix it properly.

I have tried numerous live boot iso's including linux based and windows such as Hiren's cd and the ultimate boot disc. A select few linux based recognized all gigs but no windows boot iso's would notice my drive as 74 GB.

I tried a debug script on a floppy with fdisk to wipe all partitions and that still didnt work. Any ideas on the CHS sector problem and how to fix?


EDIT: I think its called testdrive, its on a G-parted boot iso.
August 9, 2009 8:44:41 PM

I had a similar problem where a 250 GB drive was only showing 9 GB. Win XP only showed 1 partition of 9 GB. I connected the drive as a slave to another Win Xp computer and in Administrative tools/ computer management it still showed up as 9 GB, but when you highlight the disc it showed the other partition. I right clicked the 200GB partition and was able to reformat with NTFS file system. I reinstalled in original computer as Master and windows saw both partitions which I removed, reformated the drive and had my 230+ GB.
August 9, 2009 9:36:20 PM

I managed to fix this, i downloaded a boot cd called seatools and booted into it. There is an option in advanced settings to set drive to maximnum capacity. Took 2 seconds rebooted and bam 74 gigs again. Not sure how it got messed up in the first place but it worked. And its not even a seagate drive.
!