Sign in with
Sign up | Sign in
Your question

Need help saving my data from WD My book 1TB dual drive

Tags:
  • Hard Drives
  • Western Digital
  • Storage
Last response: in Storage
Share
July 6, 2009 9:52:01 PM

Ok so here is my problem/question. I have a WD 1TB MyBook (its one of the old dual 500 gig drive setups). It has always acted kinda funny by not being recognized or on occasion having very slow transfer rates (this probably should have been a sign of things to come, but i never thought it would get this bad). So any way It is now not being recognized by anything i hook it up too, I have 3 computers and a WD TV and no matter how i hook it up it will not work. I have tried usb and both firewire 400/800 and nothing!!! So i thought well i can fix this ill just take out both drives and hook them up internally. This is where my questiong comes up, they are recognized by windows and all proper drivers install, but then it says that the drives are not formatted and do i want to format them. I assume its because the drive was set in a raid array. If anyone can shed some light on how i might be able to fix this or recover the data i would be extremely grateful.

More about : saving data book 1tb dual drive

July 7, 2009 4:01:11 AM

I'm honestly a bit in the dark regarding your hard drive model. Have you tried contacting WD support? Might be frustrating but you never know what info the company will share...
!