Sign in with
Sign up | Sign in
Your question

New PCI video card, no diplay after loading screen

Last response: in Graphics & Displays
Share
May 12, 2008 3:56:26 PM

Ok, Here's the situation.

I recently bought a new video card for my parents' computer (Dell Dimension 2400; Celeron system). It has onboard video and they wanted to play some games that required more. I bought an EVGA GeForce 6200 (PCI). I installed it, the card was recognized and windows loaded in 640x480. I loaded the drivers from the NVIDIA website (as well as the accompanying CD on the 2nd try; same result). It claimed to be successful.

Once restarted, all was fine, I got the XP loading screen, but then when it went to display the desktop, the screen appeared to be changing resolution and never comes back on. Based on what's coming from the speakers, it seems like windows is finishing the loading process.

My only theory is that the card wants to default to a higher resolution than the CRT monitor can handle. Should I try hooking up an LCD?

Also, the 2 options in the bios for the onboard video are "on" and "auto". With auto selected, and the monitor cable plugged into the pci video card, the bios screen and XP load screen display fine.

Any ideas?
May 12, 2008 4:17:36 PM

Ah...Dell Dimension 2400...those things are NOTORIOUS for having problems with PCI video cards.

Since you got as far as getting POST and the splash screen to display on the PCI card, I'd say the problem from here is drivers.

1) If you have a second monitor, plug one into your onboard and one into your PCI card.

2) Download and install the drivers for your card.

3) Reboot.

4) ????

5) Profit? (hopefully--let me know)
May 12, 2008 6:03:51 PM

That's a good idea. In that way, it would be like having multiple displays and hopefully I can troubleshoot one from the other. We'll have to see if the bios will let both be active under the "auto" setting.
Anonymous
a b U Graphics card
December 8, 2008 6:38:09 AM

Eureka!! I found the issue!! Only after pulling out all my hair and making up new four letter words!

Ok, Dell computers mainly here but more possibly. Dell offers no option to disable the onboard video card in the bios so just set it to auto if it is not already there. To do this just make sure your monitor is plugged into whichever video output that lets you see the boot screens and press (F2 on most Dell systems) to enter setup. Once in setup scroll until you see the video adapter options and set to auto.

Now, turn the system off after you lose video. Do this by pressing and holding the power button until it goes off. Switch the monitor cable back to the onboard card and restart. You may not see anything until Windows loads (the opposite problem as when using the new card). Once you can log onto Windows do so and at the desktop right click the mouse on the wallpaper (background) which will bring up the display settings box. (Ensure you have the proper drivers installed for the new video card and that the video card is showing up in the device manager [ right click on "my computer" then click "manage" then click on "device manager" in the left column. In the right column expand the "display adapters" by clicking on the "+" sign ] if the card shows with no error icons on it then you are good so far. Once you have the display settings open click on the "settings" tab at the top. You should see two squares with numbers "1" and "2" in them. This means that Windows "thinks" you have two monitors and there is your conflict!!

Here lies the Dell issue, it is probably still using the onboard card as the "primary" monitor card. Click on the monitor it shows to be using and the card driving the monitor will show in the Display dialog box under the monitor area. The option to change uncheck "Use this device as the primary monitor" is grayed out too which means you cannot change it. Now, click on the other monitor box and see if your installed card appears in the Display dialog box. If so, right click on the monitor square. If "primary" is grayed out click on "Attached" then right click on the monitor box again now you should see "primary" no longer grayed out and it will let you click it. This will set the new card and monitor it is driving to your monitor. Apply your settings and close the Display Properties box. Shut down and plug your monitor cable into the new card and reboot. You should now have video as desired!! Now you can go into the Display properties again and if you are NOT using two monitors, click on monitor "2" and uncheck the "Extend my Windows desktop onto this monitor" box. Apply and happy computing! :) 
!