Sign in with
Sign up | Sign in
Your question
Solved

Any way to lock a hard disk's drive letter?

Last response: in Storage
Share
July 15, 2009 2:41:21 AM

I have 2 internal hard drives and a Western Digital My Book external hard drive. On the external I keep all my music and iTunes library, and I have moved some of Window's directories to it (My Documents, Shared Documents, plus my desktop image is stored on it). I've been partitioning my internal drives quite a bit lately to make room for the addition of many new operating systems.

The problem is that when I partition a drive it doesn't just take up the next open drive letter, it just takes up the drive letter of my external. This means all my drive letters are getting messed up every time I partition my drive. My question is that is there any way to lock my external to the drive letter it's currently at so that next tie I partition a drive it won't be messed up?


Let me try to explain what's happening a little better:
I have an internal drive on letters C and D, for Window XP. On letters E and F I have a CD-RW drive and DVD drive, respectively. On G is my external hard drive. I partitoned C to make room for Vista (just felt like it?) and this is what happened...
C-> C
D-> D
E-> E
F-> F
Vista-> G
G-> H
So when I booted XP I had to do some fancy changes in My Computer-> Manage to fix it, but I'm going to be partitioning my drive more soon, and don't wan to have to again. Any help?

Best solution

a b G Storage
July 15, 2009 6:36:08 AM

Do you know how to go to Windows' Drive Management app? Connect all your drives, press Windows Key + R, type "diskmgmt.mmc" and press Enter. You should see a list of your drives, and right-clicking on any of them lets you change the assigned drive letter. Your changes should be saved by Windows.
Share
a c 87 G Storage
July 15, 2009 8:07:20 AM

Agreed.

I think in XP you have to reboot on every change but in Windows 7 I didn't need to. Either way you can definitely reorder the drive letters.

You should realize that when you are in XP it will be your C-Drive and Vista when installed will be seen as whatever. However when you boot into Vista if you've installed it properly it will now be your C-Drive and XP will be shown as perhaps your D-Drive.

m
0
l
Related resources
a b G Storage
July 15, 2009 12:29:44 PM

A little late to do this now but if you had put your external as drive Z then it would have never changed.
m
0
l
July 15, 2009 1:51:47 PM

r_manic said:
Do you know how to go to Windows' Drive Management app? Connect all your drives, press Windows Key + R, type "diskmgmt.mmc" and press Enter. You should see a list of your drives, and right-clicking on any of them lets you change the assigned drive letter. Your changes should be saved by Windows.

I tried putting that into 'Run' but it didn't work; I understand how to get to it by right clicking on My Computer, choosing 'Manage', then Disk Management. That is what I had done to fix it after I added the partition, also.

I had also done this a while back, but the changes were not saved by Windows, as I saw from adding the new partition. :cry: 

My original question was whether there was any software or a setting I could change to make drive letter G always be assigned to my external and nothing else.
m
0
l
a c 415 G Storage
July 25, 2009 5:18:27 AM

r_manic's suggestion should have worked. But perhaps you don't realize how drive letters are assigned. Let's take an example:

- you plug in your external drive
- you run disk manager and assign drive letter "G:" to it.
- you unplug your external drive and reboot
- you plug in your external drive - it should still be called "G:".

So far so good, I hope? Now here's perhaps where you're running into problems:

- you unplug your external drive. There is no longer a "G:" drive on your system.
- you run disk manager and create a new partition on a new or existing drive and format a file system on it. It assigns the letter "G:" to the file system..

Is this the thing you're trying to avoid?

If so, you're out of luck. By default Windows will assign the lowest available drive letter to a new file system. If you don't have your external drive connected at the time, and if letters "C" through "F" are already in use, then the new file system will get letter "G:" by default. There's no way to tell windows NOT to do this.

But it's really not that big a deal. When you create the file system you just choose a different drive letter. "G:" is only a default choice - you can change it if you want.
m
0
l
July 25, 2009 2:40:44 PM

Alright, thanks for the help. I guess I'll just have to live with fixing it every time I re-partition my hard drive.
m
0
l
July 7, 2010 5:06:47 AM

Windows 7 is confused. I am very prolific about handling external hard drives and USB flash drives as I use several of them. When I used XP I had no problem what so ever locking the identity of my external storage devices drive letters with the computer management. But that ability is not stable in Windows 7. The only solution I have found is to put my USB flash drives in a separate USB hub and name them from the bottom of the alphabet and up. Thus using my remaining USB slots for my external drives. This works to a degree that it at least protects the drive letter of the external hard drives.
m
0
l
July 9, 2010 7:45:09 AM

What you need is usbdlm. Google it and you will love it !
m
0
l
!