Sign in with
Sign up | Sign in
Your question

Hal.dll missing or corrupt when copying hard drive

Last response: in Storage
Share
July 16, 2009 1:18:55 PM

I am using Windows XP. I used Norton Ghost to copy a 120GB HD on my laptop to an external 320GB HD. My intent is to swap the two so that the 320GB is in the laptop and then erase the 120GB and use for storage.

With Norton Ghost 14 I used the "Copy Disk" feature. The original C: drive was 105GB and i copied that and called it the I: and set it to active and copied the Master Boot Record as well as using it to fill up 291GB. There was a Recovery partition (D:)  which I also copied and called the H:

When swapping the drives, I tried to boot with the 320GB and got an error saying corrupt or missing hal.dll

How do I fix this? Did I copy the drives improperly or did I simply miss a step?
July 18, 2009 6:49:35 AM

I ran into the same problem using Ghost v14. My solution was to copy the drive again using the same settings as you, copy MBR, bootable, and primary, except this time I deleted all partitions from the destimation drive and didn't assign any drive letters to any destination partitions within the copy drive wizard and ghosting to unallocated space.
a c 100 G Storage
July 18, 2009 6:57:32 PM

There's lots of answers if you Google. Here's the Microsoft one:
http://support.microsoft.com/kb/314477

Your issue might indicate a deeper problem such as your hard drive. If you continue to have problems try reinstalling Windows:
1) Copy all important data
2) remove all but the Windows drive
3) Run a Diagnostics CD to check out the drive (replace if major problems)
4) Reinstall Windows (FULL NTFS) and partition if necessary
5) Reinstall drivers and programs
6) Import saved settings, e-mail etc
7) Make a backup Image to a secondary hard drive (i.e. Acronis True Image)

A good drive is WD 1TB Black.
!