Sign in with
Sign up | Sign in
Your question

Flash drive problems

Tags:
  • Storage
Last response: in Storage
Share
July 20, 2009 10:20:06 PM

HI,
I'm new around here and thought some one might have experienced this or have asome knowledge about this

when the system is on and I conncet a usb Flash drive I have no problems with it until I reboot or
shut down completely and power up. Then the flash drive does not work. the flash dirves LED
does not show activity during bootup as in a normal operation. The drive is a Corsair Flas
Voyager CMFUSB2.0-8GB. This problem happens when there is data, or above a certain
amount of data on the drive. I don't have this problem when there is no data or some smaller
amount. I have no problems with this drive on my other 2 systems (an Acer tablet and the other
one with a maximus extreme MOBO}. It seems to be some kind of a time out issue for when
the drive is emty it comes up faster as opposed to when it is half full it takes lonnger for the
LED activity during boot.

This system is the Midi side of a dual PC setup crossovered to the Audio PC.
Here's some specs,

I-Star CS-D-300-S-MUSIC
I-Star TC-3U46 460w Power TC-3U46 Quieter Fan Option
2) AcoustiFans 60mm Dust Proof 3)80 mm Nexus Quiet Case Fans
AcoustiPack™ ULTIMATE 3-Layer PC Soundproofing Kit

ASUS P5Q-E LGA775 ATX
Motherboard, Intel P45 Chipset, Supports Intel Core 2 Extreme CPUs,
Dual DDR2 1200, SATA 3Gb/s RAID, CrossFireX Ready, PCI-E 2.0

Intel Core 2 Quad Q6600 Quad-Core Processor 2.4GHz, 1066FSB, LGA775, 8MB
ZALMAN CNPS8700 NT Copper Intel/AMD CPU Cooler

CORSAIR DOMINATOR with DHX Technology TWIN2X4096-8500C5DF
4GB PC2-8500 (DDR2-1066) DDR2 Memory

ATI All-In-Wonder 9600 XT AGP 8X 128MB DDRVideo Card w/TV-Out & Video-In
Zalman ZM-17Cu Silent Video Card Copper Heatsink

Western Digital Raptor WD740GD 74GB Serial ATA 10,000RPM Hard Drive w/8MB Buffer
Western Digital Caviar SE WD2500JD 250GB Serial ATA 7200RPM Hard Drive w/8MB Buffer
2) Smart Drive 2002 Copper Cool, Quiet Hard Drive Enclosures
Pioneer DVR 212BK DVD Burner

Oh yea,
I'm runing XP PRO 32 SP3

More about : flash drive problems

a b G Storage
July 21, 2009 2:39:01 AM

The problem is obviously with your computer, and not the flash drive. Have you tried updating the drivers of your mobo and chipset? These upgrade packages usually include drivers for the USB controller.
m
0
l
July 23, 2009 7:47:23 AM

yes
m
0
l
Related resources
July 23, 2009 4:13:58 PM

Have you tried different USB ports? Sometimes this does make a difference...
m
0
l
July 23, 2009 8:46:41 PM

yes
m
0
l
July 23, 2009 8:53:38 PM

and brfore you ask I do have the latest drivers for my MOBO
ALso playing around with EHCI or acpi 2.0 I couldn't get any results but here's what other trial and error thing I was doing,

As usual when a I boot or reboot with drive connected it doesn't work so I went in to device
manager\USB Controllers and I find unknown controller if I reseat the drive unknown changes to USB Mass Storage device and then the drive becomes available.

So I started reseating during restart and found that as long as I plugged the drive in any time
after the point where the screen signal comes back the drive is available after it finishes booting. I'm plugging it in way before BIOS boots and its working.

My thoughts are that maybe the MOBO needs to be grounded some where specifically or may be it's missing a jumper or it's in corectly jumpered somewhere. I didn't mess with anythng when building and I am getting the same results on any of the USB ports internal or external.

Anyway, I hope this helps and thanks for your replies
m
0
l
!