Sign in with
Sign up | Sign in
Your question

Memory errors with 4GB, 2GB works fine

Tags:
Last response: in Memory
Share
July 4, 2008 11:59:03 AM

Hi, i really hope someone can help me with this because this is driving me crazy.

Just to mention, i'm an IT Tech and this is one of the weirdest problems i've encountered...

I've got a problem with my computer recently. I have 4GB of ram and i keep getting random BSOD while working in Windows(either in XP 64 or Vista x64). The errors are either 0x00000007F or 0x00000007A

i did a Memtest v2.01 with a Boot CD with 1GB at the time, in each of my 4 memory slots for 1 hours each, no errors. I did a Memtest with 2GB in random slots for 7 hours, no errors, i did another Memtest with the other 2GB for 18 hours, no errors.

As soon as i put the 4GB together, Memtest gives error codes...

Before, i had the 4GB and had no problems, this suddently started to happen. I even lended my memory to my friend so he could test it and he got no problems.

I don't understand why if i put 2GB in any of the 4 ram slots, it always works, as soon as i put back 4gb, BSOD and errors ...

Anyone has any idea ?

(i have all the lastest drivers and firmwares, i tried to reset the Bios multiple times and reprogram it, i've left everything on Auto, OC 0%)

btw here are my specs:

CPU: Q6600 Core2Quad 2.4
Video: EVGA 9800gx2 1GB
MOBO: XFX Nvidia 680i SLI
Memory: Crucial Ballistix 4x1GB DDR2-1066 5-5-5-15
HDD: Raptor 10k 150GB
PSU: Corsair HX620W
July 4, 2008 12:23:34 PM

On what ram settings did you encounter errors in memtest?

680i has a tendency to overheat the northbridge & memory controller. You can see the NB temp in bios & Windows. I assume your board is out of warranty. So you might wanna reapply TIM on NB, mosfets & maybe SB. There's a thread on how at:

http://www.evga.com/community/messageboard/defaultmb.as...

Oh and you can't leave everything on auto with 4 1066mhz sticks. You need to up vdimm to at least 2.1v and maybe lower your ram speed to 800 or even 533mhz which is the stock speed with Q6600 (9x266). At lower speed, 4 sticks will work perfect. At rated speed, it may need some tweaking.
July 4, 2008 12:24:44 PM

Up your memory voltage a bit. Ive something about nvidia chipsets and memory errors, but i think that was with overclocking
edit: ^too late
Related resources
a b } Memory
July 4, 2008 12:38:48 PM

Its probably a timing issue, try relaxing the timings for 4GB
July 4, 2008 1:03:26 PM

Filling all four slots on a motherboard often brings on these kinds of errors.
Try relaxing timings, slowing memory bus speed (say from 800 to 667) and make sure voltage is at mfg spec. Upping the Northbridge voltage has also been known to help in some cases.

Consult your MOBO manual and see if there are any special instructions for filling four slots.
a b } Memory
July 4, 2008 1:04:53 PM

With some boards you need to add +0.1(i needed a bit more to squeeze my old DDR2 667 sticks to work with 4 sticks) extra to run 4 sticks. Give it a try, 0.1 will not hurt anything.


Also 1066 is kind of hard on the board for little to no gains try 800 or even lower. Only try this if a voltage bump does not work.
July 4, 2008 1:06:22 PM

Also 4 memory chips puts more strain on the northbridge should you might need a bit of extra volts and probably extra cooling for the northbridge.
July 4, 2008 7:28:13 PM

Thanks a lot everyone for your suggestions, i will try that tonight :D 
July 5, 2008 3:55:50 PM

I tried with +0.1v and it didn`t work (with timings on auto)
ill try to mess around with the timings...
a b } Memory
July 5, 2008 4:32:59 PM

drop the speed. As said 1066 is harder on the chipset. if it runs at 800 then you can try 1066 with a bit more voltage on the chipset.
July 5, 2008 4:38:15 PM

Wow ... i just found this on a forum by pure hazard

My MOBO manufacturer found the following Microsoft 'fix' (maybe) for this problem:

http://support.microsoft.com/kb/929777

that addresses the IRQL_NOT_LESS_THAN_OR_EQUAL problem on machines running Vista (64 bit) and trying to use more than 3Gb.

It seems that Vista has a problem itself addressing more than 3Gb memory. Will let you know if this fixes it...

i installed the patch and for now it seems to have booted Vista (which didn`t work with 4gb before) was this all because of a stupid M$ issue :S

i'm gonna do some more tests to see if it works for good...
a b } Memory
July 5, 2008 4:50:09 PM

Do you have vista SP1?

I have 8 gigs on vista 64 without issues. and i installed it that way(but my DVD had SP1 on it)

EDIT, well i do not meet the requirments

This problem occurs if the following conditions are true:
%u2022 The computer uses more than 3 GB of RAM.
%u2022 The computer uses a storage system that is running the Storport miniport driver. <-----
%u2022 The computer uses a controller that uses 32-bit direct memory access (DMA).
a b } Memory
July 5, 2008 4:53:09 PM

Why not? is is supposed to fix allot of problems related to software and drivers that do not quite like vista.
a b } Memory
July 5, 2008 6:22:14 PM

Just a couple of comments:

1. Did you ever get memtest (Bootable disk) to work, If NOT - hold off on playing with operating system UNTIL you get memory problem solved. Mem errors can cause wierd problems inside of operating system such as corrupting your HD and even your BIOS.

2. As motherdude pointed out I would try upping your FSB and (g)MCH voltage by +0.1 V ( I assume you are already runing at manf spec on Ram)

I'm running 4 x 1 Gig DDR2 800. Two get the 2nd two sticks to work I had to up both voltages for stability. Tried with only one at a time - No Dice.

3. Once you get bootable memtest to work, Then nukemaster excellent advice, use SP1. Then run prime95 (I used orthos - Have dual core) to reverify memory. Ran short test (1 to 2 hrs ) with memtest, No errors; BUT had errors within 7 to 13 mins using orthos.
July 6, 2008 3:03:00 AM

Quote:
2. As motherdude pointed out I would try upping your FSB and (g)MCH voltage by +0.1 V ( I assume you are already runing at manf spec on Ram)


That's Notherdude, with an N. I wouldn't quibble to correct you but considering the implications I'm sure you will understand. ;) 
July 6, 2008 12:54:56 PM

Quote:
Did you ever get memtest (Bootable disk) to work, If NOT - hold off on playing with operating system UNTIL you get memory problem solved.

Quote of the Day. I been saying that for ages here. I do that too. The average user doesn't do that, instead they open a questionable download, get infected with malware, before they try to scan it for malware. It should be the other way around.
July 7, 2008 11:06:33 AM

i've said it before and i'll say it again "some mobo's do not play well with 4x1 g of ram" I think that quality control and adherence to JEDEC standards are lacking,plus 2x2 just makes more sense,,and allows for further addition of more 2x2 in the future..:) 
a b } Memory
July 7, 2008 4:50:13 PM

Notherdude
Hope you accept my apologies - Blame it on "need new glasses" or N & M are next store keys and I hit the wrong Key, Not a fordian ( SP - intentional slip of the tougue) slip
July 7, 2008 6:31:11 PM

Its possible that one of the dimm slots of your mobo is corrupted. Trying cleaning them. Try Testing 1 memory in each slot.
July 8, 2008 2:20:17 PM

Well its really weird because in XP 64 i also got BSOD sometimes but since i installed the patch in Vista, i got no problems for the passed 3 days ... really really weird.

maybe my computer is haunted by the ghost of Bill Gates or somethin'
a b } Memory
July 8, 2008 10:43:56 PM

venozOr - I believe he stated in his first post that he already tryed one at a time in different slots. Also by swapping in an out he basicly "Cleaned" the pins/socket. But this is a valid point on systems that have been in use for a year or more as oxidation can build up and removing/re-inserting the DIMMS/ cards (Also applies to Video/PCI, and Cards) several times can remove this oxidation
July 9, 2008 11:59:34 AM

this is right RetiredChi ef, i did already try it in multiple slots, but i guess maybe the oxidation was the issue ? i guess ill never know...

stupid computers lol
!