Sign in with
Sign up | Sign in
Your question

XFX 680i LT MotherBoard Del button problem

Last response: in Motherboards
Share
July 5, 2008 3:34:44 AM

Hello Everyone this is my first post here
I'm having trouble with the bios on my motherboard

My current configurations are this

NZXT Tempest
XFX 680i LT Motherboard
1 XFX 9800GTX Graphics card
2 Sticks of Corsair XMS2 DDR2 1GB each
1 Q6600 Processor
1 Thermaltek BigWater760i CPU cooler
1 Utlral 1600 watt power supply
2 Western Digital Velociraptor Harddrives

The problem is that I can get the computer to start and display something. Since its my first time booting this thing up i need to go to the BIOS and configure the Harddrives and other things. When I press the delete button nothing happens. Is the screen frozen at the place were it says 'Press Del to enter the SETUP, or Press ESC for the Boot Menu'?
I've tried 3 keyboards and I can't get to the bios or get it to start up. I assure that all the connections are made properly, It starts up and displays fine. I just can't get past that black and white screen with all the information. I tried the ESC key as well and nothing happens.

Can anyone tell me what is wrong? I've called XFX but they won't get back to me until Monday.
July 5, 2008 1:12:12 PM

Clear cmos, try each stick of ram in each slot, go to bios, load defaults, set up ram to specs.

You might need a ps/2 keyboard if the USB keyboard setting is disabled in bios.
July 5, 2008 11:40:12 PM

I can't get into the bios! That was the main problem. since the DEL button or w/e on the MB is bugged.
!