External Storage

I just bought a new WD drive for my external USB enclosure. I am running Vista on my laptop. The drive is recognized when I first log in comes up in Drive Manager says it needs to be initialized. When I click through the prompts it then says that the drive is not ready. Drive is jumpered for standard config. I have a desktop running XP, it doesn't recognize the drive at all. Drive enclosure is a SATA Fantom Titanium which had a recertified 250Gb drive of unknown origins and worked fine and then crapped out. Any help would be appreciated. checked BIOS settings on both computer, no help. Thanks
4 answers Last reply
More about external storage
  1. Hmmm... have you tried connecting the hard disk directly to your desktop, via the mobo?
  2. That's the problem it's an older desktop and doesn't have SATA connections. Someone suggested I change the BIOS settings to be able to emulate SATA on the desktop, but there are no settings to change.
  3. Do you remember if your original drive in the Fantom Titanium was formatted as NTFS or FAT 32? I can't confirm for sure, but the controller that converts from SATA to USB inside the enclosure may only be able to recognize FAT 32. If you try to format a drive through Vista, it only allows you to format as the newer NTFS. You could try reformatting from your XP machine where you should be able to select FAT 32 as an option when formatting.

    The other possibility is in reference to your jumpers. Jumpers should only matter for devices on a parallel bus, every time I've worked with SATA drives in the past, I've never had to mess with jumpers. If you do have a jumper on the drive, pulling it off will ensure it's not active.
  4. It turned out to be a bad drive, I verified it with another computer, I sent it back and they should be sending me a replacement in about a week.
Ask a new question

Read More

Hard Drives External Storage Enclosure Storage