Sign in with
Sign up | Sign in
Your question

Vista won't install on new Sata drive

Last response: in Storage
Share
August 7, 2009 2:34:12 PM

I'm desperate so I am hoping the collected power of the forum might be of some help. Bear with the long read, consider it a trouble shooting log.

I had a Seagate Sata II hard drive brick up on me. I'm aware of Seagates firmware snafu. Since I bought my pc from tiger direct, HP won't support it. Tiger direct won't replace the drive even though its still under 1 yr replacement warranty. They want the whole PC shipped back and will only refund my money. This is not an option. I've upgraded power supply, ram, video card since purchase.

The PC is an Compaq Presario SR5710F, it came with OS on a partition. I made recovery disks like a good boy. PC would not boot from the drive in any mode. It would get as far as the progress bar for Vista Home Premium and then hang indefinitely.

I ran F9 PC doctor diagnostics. The hard drive checked out okay but returned Biohd-4 error= Uninitialized/Corrupt Boot Structure in boot sequence check. I couldn't get to anything besides BIOS.

I tried to use my recovery disks, it would load windows files from the DVD, show the progress bar & hang indefinitely. All cables, plugs, power, ram etc. have been reseated and or checked for loose connections. Diagnostics checks out for all other hardware as passable.

Frustrated I decided to buy a new Sata II drive and an OEM vista home edition DVD. No more stupid recovery disks. They arrived yesterday. I completely unhooked the old drive and installed the new one. Bios recognized it. I set it to boot from CD/DVD drive. I put vista in and booted. It will load windows files from the dvd then show the progress bar after loaded and hang indefinitely. Notice a theme? I left it on overnight to see if it was just taking some time to initiate but this morning it was still hung up.

I can't figure wtf? The new drive checks out in diagnostics, SMART scans pass 100% in bios. Diagnostics in PC doctor reports another error code in boot sequence Biohd-3.

I've swapped out sata cables to see if it was a bad cable. I've Replaced current ram with old ram that shipped with pc, uninstalled all PCI boards from mobo, and unplugged all USB equipment. I cleared CMOS and even changed the power connection.

Why won't a clean install work on a new drive? This not a raid configuration just one to one install.

I'm at my wits end with all this, any help is greatly appreciated. Thank you.

August 7, 2009 4:20:47 PM

Seems like you covered all the usual problems, all that's really left is the board itself, or possibly the PSU, though as you already upgraded that to what I assume to be something better, it should be fine. One last thing to try would be to download a Linux Ubuntu Live CD and see it it will run off the disc, no need to install. Quick and dirty way to see if there's a serious problem, or if it's just Windows being user-unfriendly.
August 7, 2009 5:06:00 PM

Thanks for the quick reply and good suggestion. I will try and download Knoppix http://www.knoppix.net/ this evening to see whats up. Hope its not the mobo...




Related resources
a c 349 G Storage
August 7, 2009 5:52:08 PM

In understood that VISTA had built-in all the drivers it needs to be able to use SATA drives even for installation. But maybe I'm wrong and VISTA Home does not. Anyway, one trick to try is to go into the BIOS Setup to where you set the SATA port parameters, and set them to use IDE Emulation instead of native SATA mode (and certainly not RAID). Then try the Install.
August 8, 2009 5:33:36 AM

Knoppix hung up like everythin else and wouldn't boot. I verified my burn of the image. Also let it sit for an hour and then had to power it down. Wish I had another SATA capable PC around to drop my drive with Vista Premium installed on to test. All I got now is the wifes lappy and my old colege rig thats a decade+ old. and only supports EIDE drives.

Think I'm pretty much screwed, its gotta be something wrong with the mobo. Originally I was playing Battle Forge and the PC froze, didn't think anything of it. Couldn't Alt+tab out or Ctrl+Alt+Del my way out so I powered down manually. Thats where the trouble started, it never recovered from that freeze up.

Ah well...back to tiger direct to drop more dough unless anyone has some creative suggestions. Thanks guys.

August 8, 2009 5:13:52 PM

Take out some ram try one stick at time, if one gives you a issue pop in another and try. You covered the bases so now its either ram or mobo.

Try running memtest86 for 8 hours and se if the ram has errors.

BTW Tigerdirect sucks ass!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I will never buy from them again.
August 10, 2009 1:51:08 PM

Thanks for the help everyone. Two sets of ram swaps didn't help so its gotta be the board. I ended up buying a new mobo and upgraded to a new processor too. Didn't want to get a new board without processor and end up having a dead cpu and be waiting yet again for parts. That should take care of all my issues...hopefully. :) 

I guess this is case closed for now. :hello: 
!