Sign in with
Sign up | Sign in
Your question

Secondary SATA drive not recognized

Last response: in Storage
Share
August 13, 2009 1:09:39 AM

I'm trying to install a WD Caviar green SATA hd as a secondary drive in my Dell Precision 360. The primary drive is an IDE Maxtor. The computer is not recognizing the second drive. WD support had me put a jumper in the 3 spot, then told me I need to update my SATA drivers. When I did a scan, however, they came up as current. Bios are A01.

I went in the Bios and turned all the drives onto auto, and they all say "unknown device." and no recognition of drive. Should I take the jumper off and try again? Move it to different spots?

Can anyone help me get this little bugger recognized before I throw the whole thing out the window? :fou: 
August 13, 2009 1:27:02 AM

Update: I flashed the BIOS to A08, still nothing. The HD is connected via WD Quickconnect cable from the HD to the ATA 1 slot on the motherboard.....
m
0
l
a c 342 G Storage
August 13, 2009 6:08:48 PM

OK, so you have a Maxtor as Master on the IDE0 port that serves as the boot drive called C:. And now you're trying to add a second HDD, to be used for data and not as a boot drive, on a SATA port.

Let's clarify a few things. There is no such thing as Master and Slave on any SATA device. However, I understand your use of the term "Secondary" for the new drive as meaning it is just the second, non-boot drive in the machine. The jumpers on some SATA drives confuse a few people because they remind us of Master or Slave settings on older IDE drives. On some SATA drives, the manufacturers used jumpers for a different reason. They were solving a problem for people who buy a recent SATA II (i.e., 3 Gb/s max data rate) unit to install on an older system with the original slower SATA controllers. The installation of the jumper simply forced the drive to revert to the slower data transfer rate. In fact, many such drives arrived with the jumper installed that way. If you have a faster SATA II controller system, you're supposed to remove the jumper. I don't know if this is what your WD Support guy was talking about. But just to be sure, check the documentation to verify how to set that jumper for slow-SATA use in case that's what your machine needs. An older original SATA system fitted with a fast SATA II drive that has not been forced to slow down can behave exactly as you describe.

To use any SATA device, your BIOS Setup screen has to be set to Enable the SATA port(s). Then there is another setting to specify how the BIOS uses that device. You may have some (or all) of these 4 options: IDE Emulation (or mode), SATA, AHCI, or RAID. You definitely do not need RAID. Any of the other three settings should certainly allow the BIOS to recognize the drive, so I'm confused by your statement that it says "Unknown Device". Is that really what it says in the BIOS Setup screens? Or, is this message coming up somewhere else?

If the "Unknown Device" message is coming up in BIOS Setup, I'd worry that the drive is defective. Go to the WD website and get the proper version of their Data Lifeguard tools. Download and install on your C: drive. Use it to run diagnostic tests on the new drive to check it for problems. If it detects any, go back to WD Support and report the details.

If this problem is not actually in the BIOS Setup but a message within Windows, you may have a different problem to solve. First, VISTA should not have this problem - it could show up, though, in any version of XP or earlier. Before VISTA, Windows' own built-in driver systems knew how to handle IDE devices nicely, but had no drivers for SATA devices. So you had two options. The straightforward process was like any other device - you start Windows, then have it find and load the device driver for your new piece of hardware. Although it's not built into basic Windows, in all its versions it should have the drivers necessary for SATA drives available on the hard disk. Try forcing it to search for new devices and install the appropriate drivers. In rare cases this process might even be needed in VISTA, but I would not expect that.

The other option for XP and earlier is to use a feature now common in many mobo's BIOS settings for SATA devices (don't know if yours has this). In BIOS Setup you can choose to have the device on the SATA port treated in IDE or PATA mode (or emulation). In this case the BIOS controls the port to make the rest of the world (read, "Windows") believe this is really just a plain old IDE device that it always knows how to handle. Then Windows has not trouble, and no need for additional drivers to be installed.
m
0
l
Related resources
August 13, 2009 10:41:19 PM

I'm working with XP Professional. I went back into the Bios. In Hard Drive Configuration, the only one that had anything listed was Primary Master, which said HD. The rest were all off. I set them all to Auto. Now they all come up as unknown device: SATA Primary, SATA secondary, Primary Slave, Secondary Slave. Secondary Master says CD-ROM.

I couldn't find any area to enable the SATA ports.

A couple of the other settings:

Boot sequence is set at 1 1. IDE CD-Rom device
IDE HD Acoustics Mode is set at bypass
IDE Drive UPMA (? not sure if that's right, can't read my own writing!!) is on

Still no recoginition of HD

When rebooted, it said
SATA primary not found
SATA secondary not found
Primary drive not found
Secondary drive not found


Sigh.......
m
0
l
a b G Storage
August 14, 2009 1:49:47 PM

Try using a regular SATA cable and a SATA power connector from the power supply.
m
0
l
a c 342 G Storage
August 14, 2009 3:48:13 PM

I looked at the downloadable manual for your machine and I find it frustrating - there is no direct mention of the SATA system! Regarding drives, it talks only about the IDE system, and the only option seems to be that a drive port can be Off or Auto. The display of info you get makes sense for the IDE ports - it appears your original HDD and optical drives are each Masters on separate ports, presumably each with its own cable. Since there are no Slaves on each port the display is right. IF it is possible to set them separately, you might consider turning OFF the Primary and Secondary Slaves.

The fact that both SATA ports show Unknown Device when your new drive is connected says the BIOS cannot communicate with it. So why?
1. Drive needs a way to force it to slow down to SATA I. Check with WD again and verify proper installation of jumper.
2. SATA cable (power, data or both) is faulty. Try other cables.
3. Drive is faulty. Download and run WD's diagnostics. Also try same on another computer.
4. SATA port on the mobo is faulty. Contact Dell Support for help. Maybe try the other port in case only one is not working.
m
0
l
November 7, 2010 7:49:19 PM

I read all the stuff above from paperdoc. I have the same problem. Dell 8300 adding 2nd SATA drive, brand new. I have checked and crosschecked. Used various cables. Either drive is recognized as SATA Primary drive. Both come back with "Unknown device" when connected to the second SATA socket on the mobo. It's like the 2nd socket is dead.
Dell Tech support is COMPLETELY USELESS. It would be a joke if it were not such a complete waste of time. THey don't even understand what I Want to do let alone have a clue about what to do.

Macho
m
0
l
!