Sign in with
Sign up | Sign in
Your question

Trouble w/ Athlon X2 5000+ System! What happened?

Last response: in Systems
Share
May 14, 2008 9:00:23 PM

Hello All,

My system:
- Athlon X2 5000+ Black Edition (Brisbane 65nm) overclocked to 3.0GHz
- MSI K9A2 Platinum motherboard (790FX chipset)
- Crucial Ballistix DDR2 1066, 1GB x 2 (running at DDR2800)
- PC Power & Cooling Silencer 750 Quad PSU
- GeCube HD3870 video card
- Seagate Barracuda 750GB HDD
- Samsung SH-S203N Sata DVD burner
- Kingwin RVT-9225 92mm CPU cooler, installed with Arctic Silver 5
- Sony 1.44MB floppy
- Windows XP Pro (32-bit) w/SP2

System was built mid-February. I began by running Memtest86 v3.4 for 24+ hours with no errors. I then installed the OS, and ran stability tests using Prime95 on both cores, and encountered no errors for 10+ hours. I then set the CPU clock from the initial 2.6GHz to 3.0GHz, and repeated the tests - again, finding no troubles. Although I can't read the core temperatures due to the Brisbane problem, the motherboard reports the CPU temperature in the mid-20s for idle, and low 30s for high loading. The CPU HSF is cool to the touch. The system has been 100% rock stable ever since - until now.

I finished a game of Oblivion last night, and left the system to go into power-saving standby mode. This morning, the screen was blank (as it should have been), but the system wouldn't "wake-up" on keyboard or mouse activity. I reset the system, but the screen remained utterly blank. I repeated this several times, and finally got the BIOS message saying that my overclock had failed. I went into BIOS setup, verified the settings (but didn't change anything) and started Windows. Everything seemed fine.

I started Prime95 in the mixed mode and it failed almost immediately. I then tried the small FFT test, which runs primarily from CPU cache and uses little external memory. The system ran a little longer, but it still failed the test after a minute or so. I then restarted the system and dropped the CPU clock to 2.8GHz, and tried Prime95 again. Still had failures.

I put the Memtest86 floppy into the drive and restarted the system. After running for one minute and 45 seconds, Memtest86 halted with an "unexpected interrupt" error. This is not what I would expect to see for a memory error. I have run this program on other systems with bad RAM, and have seen what those kind of error messages look like. I restarted Memtest86, and shortly afterwards, the program crashed!

This is where I am now. I don't believe it's a RAM problem, but it might be. It could also be a motherboard or CPU problem. My question to all of you is this: How can I figure out what is bad? I don't have any other AMD2+ motherboards or suitable CPUs to swap out, and I don't want to buy more just for the purpose of testing.

I would like (helpful) suggestions as to what I should do next?

Thanks in advance for your help!

Altazi
a b B Homebuilt system
May 14, 2008 9:07:42 PM

Clear CMOS and try
May 14, 2008 9:25:21 PM

Clearing CMOS might help. yes. If not unplug the computer from the wall socket for a few hours (sometimes, that helps with freaky stuff like this). That unexpected interrupt could be due to overheating. Check if the cooler has come loose.

altazi said:
The CPU HSF is cool to the touch.

What kind of heatsink are you using?
I guess you're using AutoVoltage for the CPU?
Have you tried it at stock settings?
Related resources
May 14, 2008 9:27:00 PM

Hopefully you might have a friend that runs this socket and try your cpu on his/her board. You didn't mention if you did the one stick at a time thing.
The only other way I know of to test the cpu is take it to a reputable shop.
I'ld hate to think your oc damaged you on die cache....Hope this helps.
May 14, 2008 10:27:15 PM

I have cleared the CMOS, restarted the computer, and am running Memtest86 again. So far, it has been running for 58 minutes, and is 76% of the way through the first pass.

If clearing the CMOS fixed the problem, all I can say is "WTF???" What caused this? A stray cosmic ray? The system is connected to a good UPS on a properly-grounded circuit. I use this system for work, and I need it to be reliable.

I'll let you all know how this shakes out. Thanks for all of your great suggestions.

Altazi

May 14, 2008 11:04:45 PM

With a system that has some 10^12 "components" (software and hardware) we tend to underestimate the power of a single logic value. If the right value get's "altered" just about everything can go wrong.

That's why my very knowledgable logic designer friend says : "He who said computers are deterministic machines lied". ;) 
a b B Homebuilt system
May 14, 2008 11:19:17 PM

altazi said:
I have cleared the CMOS, restarted the computer, and am running Memtest86 again. So far, it has been running for 58 minutes, and is 76% of the way through the first pass.

If clearing the CMOS fixed the problem, all I can say is "WTF???" What caused this? A stray cosmic ray? The system is connected to a good UPS on a properly-grounded circuit. I use this system for work, and I need it to be reliable.

I'll let you all know how this shakes out. Thanks for all of your great suggestions.

Altazi

Clearing the CMOS may have solved it so the problem could be that the BIOS is not retaining BIOS settings because the power from the battery is too low. Had a smiler problem with a P5K a few months back.
May 14, 2008 11:32:36 PM

Memtest86 ran for one hour and 22 minutes before crashing. It looks like the program itself crashed, because it is totally unresponsive. Hitting "ESC" should exit the program and force a system restart, but the system is utterly frozen. I have never seen Memtest86 respond like this before.

I will try running on one RAM stick at a time, but I am doubting if this is a memory issue. . .
May 15, 2008 12:42:55 AM

Doesn't the lithium coin cell only provide power for the CMOS RAM when there is no system power present? Surely the designers wouldn't do anything stupid here, would they?
May 15, 2008 1:55:34 AM

Not all batteries are the same. The shelf life is around 5 years. Various events shorten the lifespan (IE faulty BIOS settings/extreme temperatures during storage/...).

You say your system is on an UPS. Can you test on a surge protector socket only? I've had my issues with UPSes and a CRT screen. And sometimes my board would ignore my BIOS settings entirely.
May 15, 2008 3:08:15 AM

Clearing CMOS helped so maybe something happened with the BIOS? I would flash it if you can.
May 15, 2008 5:55:57 AM

Reflashing the BIOS? Now that's a conundrum. The warning that comes up for BIOS flash programming warns that the system must be stable before you attempt the re-flash.

At this point, I had five successful passes of Memtest86 on one stick of the RAM (several hours worth of testing). I switched sticks and am now testing the other, and it's 38% of the way through the first pass - no errors so far.

Just thinking ahead - what if both sticks pass individually, but fail as a pair? I am not overclocking the memory, and the system has been absolutely stable up until this morning. I haven't had to reset the system due to a problem even once until today.

I measured the coin cell voltage with my DMM and it measures just above 3.0V, so I don't think it's the cell. . .

Keep those suggestions coming! Thanks!
May 15, 2008 10:27:46 PM

Good points, MrsB. These tests are being done at 2.8GHz, a 200MHz overclock. The CPU is barely warm. I suppose I should drop the frequency to 2.6GHz, but why would the system be stable for almost 3 months solid, and then go to crap all at once?
May 15, 2008 11:18:46 PM

Exactly. It totally blows me away that the system was stable for co many months and all of a sudden it turns crups. When I said reflash the BIOS I meant once you get the system stable enough.
May 16, 2008 4:18:30 PM

OK, now for the final and total weirdness. I ran five passes of Memtest86 on the other RAM stick (6 hours of testing) with no failures. Next, I ran Prime95 in the RAM test modes, again receiving no failures after several hours of testing. Both sticks of RAM individually test OK, and everything seems to be rock solid when the system is running with either stick of RAM.

Why would the system be challenged when both sticks of RAM are installed?
a b B Homebuilt system
May 16, 2008 6:01:18 PM

Maybe a bad slot? Perhaps your mobo decided after a while it does like dual channel anymore, or did your ram timings or voltages change?
May 16, 2008 6:11:31 PM

None of the timings or voltages have been changed. I am wondering if the bus drivers are damaged, and therefore the extra load of two sticks of RAM causes the instability. I think I am going to pick up some extra RAM - Fry's is having a special on Crucial Ballistix DDR2-800 4-4-4-12 2 x 1GB for $20 after $30MIR. I'll swap these in and continue testing. If I still get faults, then I guess it points to either the CPU or the motherboard. Wish I knew how to tell. I don't have an extra AM2 CPU sitting around, and I certainly don't have another MSI K9A2 Platinum mobo.
May 16, 2008 11:33:17 PM

Did you test in all 4 slots?

Run the "in cache" test of Prime95 with 1 stick. If it fails you'll know its the CPU. If it doesn't it's a good bet one of the slots went to heaven.


May 17, 2008 7:13:35 AM

Hi Andrius,

I have run Prime95 on both cores (simultaneously) using the small footprint (data fits in cache). I have not seen a failure in this mode. However, when I run the mixed test that uses lots of RAM, I get failures in both test windows almost instantly.

I have tested the RAM sticks individually using slot 1, and the test is successful. Using both of the sticks, either in slots 1&2 or 3&4 causes a failure.

I still don't quite get how the system could have been rock solid for about three months, and then just go gunnybag all at once. I went and got some Crucial Ballistix DDR2 800 4-4-4-12 and I suppose I will try that next.

Is this looking like a bad motherboard?
May 17, 2008 12:16:28 PM

The small footprint test means no bugs in the cache I guess.

Can you try in slot 1&3 or 2&4?

The pattern would indicate that the IMC has a bug. Now if that is true the same thing should happen with slots 1&3 or 2&4. That would then indicate something is wrong with the dual channel memory controller part.

You could buy a cheap dualcore X2 and test or you could just downclock your chip to say 2.0GHz and repeat.

Hardware fails with time (capacitor aging, electromigration, ...) but 3 months is a very short time for it. Unless you run your chip at an insane voltage of say 25% or higher over stock. It's a bad sign anyway. :/ 
May 17, 2008 5:38:37 PM

Prime95 blend test fails with RAM in slots 1 & 3. Now trying slots 2 & 4. I will be out for a day or so, but will continue to log in here; I just won't know the results of the test until later tomorrow.

Since this is an Athlon, with the integrated memory controller, wouldn't that point to a bad CPU?
May 17, 2008 10:11:11 PM

altazi said:
Since this is an Athlon, with the integrated memory controller, wouldn't that point to a bad CPU?
It would as it is not limited to a certain RAM slot. I think it is time to RMA the chip and play dumb when asked about overclocking (or maybe not since it's a Black Edition). :) 
May 18, 2008 4:15:33 AM

So far, the system is passing the test with RAM in DIMM slots 2 & 4. Core 1 is running the Prime95 blend (lots of RAM tested) and core 2 is running the small footprint. The system has been stable for almost 10 hours now.

I had only overclocked the chip to 3.0GHz; I did all of the prime95 stability testing, and it passed with flying colors. It was just fine for almost three months.

For the current testing, I am running the CPU at 2.8GHz, a mere 200MHz overclock.

I checked on Newegg, and they don't seem to have the X2 5000+ BE any more. . . What to get now?
May 18, 2008 5:46:11 PM

There is no way this can be the motherboard, right?
May 18, 2008 6:27:43 PM

It's hard to say. The somewhat erratic pattern of faults is making it hard to pin down the culprit. It could also be the PSU. Do you see any drawbacks from running in slots 2 & 4? If not try upping back to 3.0 and run Memtest86 on that configuration. If it passes do a blend test in Prime95 (12-24hours) and you should be good (but I'd run a memtest once a week for a month to check if the problem is repeating).
May 19, 2008 4:54:31 PM

Update: The system failed using slots 2 & 4. I pulled out the stick in slot 2, and ran Prime95 blend (core 1) and small footprint (core 2) and left it running overnight - the system had crashed (blank screen, no wake-up) when I checked it in the morning. I ran Memtest86 and it crashed with the "Unexpected Interrupt" message. I then moved the RAM stick to slot 1 and am running Memtest86 again.

Isn't there any kind of conclusive test I can do? Is there some diagnostic program that will point to the culprit?
!