Sign in with
Sign up | Sign in
Your question

No autorun or manual setup from DVD

Last response: in Storage
Share
August 16, 2009 1:43:36 PM

I have an asus 24x DVD RW and it worked fine until I uninstalled a few of my games so I could reinstall them after I installed a few drivers. it reads the DVD fine, it shows up in my computer, the icon shows up, I can even start the autorun on some instances, but when I try to install it. the installer never shows up, sometimes it even says I need to put in the correct disc, though it says its still in the drive.

the same goes for running the installer through the setup.exe on the disc, instead using the autorun. the installer sort of starts up, then It just quits with no indication why.

the weird thing is, I can manually drag all the files off the disc, and onto my desktop, and install it that way no problem.

but that is incredibly inconvenient and I shouldn't have to do that

I have tried it with 3 different games and non work. some get further than others though, the furthest I got installing from a CD is with crysis warhead and the worst I got was from far cry 2
a b G Storage
August 17, 2009 4:40:45 AM

Errr, how were you able to install after copying it on your hard disk? Don't game installers fail when they detect they're running from an optical drive?
August 17, 2009 10:45:47 AM

i have no idea, the cd was still in the drive and the computer was showing that her was still a cd in the drive, so it installed. it didn't install correctly though, the game never loaded up, just a black screen
Related resources
August 17, 2009 3:52:47 PM

Try a system restore to when it still worked.
August 18, 2009 8:21:09 AM

no good, I deleted all the restore points before I noticed it wasn't working, I have already tried...

I used a registry fixer last night and I was then able to install crysis, but it is back to the same problems this morning, and the fixer doesn't do anything now

Edit: I don't know if this means anything but when I move some icons from the desktop to other folders, they appear to be an unknown file/ generic windows file icon

the icons still work and the names are there, they just don't have the picture anymore. I'm thinking there is a big error with the registry

am I going to need to reinstall windows? is there any way I can do so without losing my data?
August 18, 2009 6:29:28 PM

Sounds like some copy protection F**ed up your install. The easiest fix is to do a clean install. Otherwise you will have to narrow down the offending program and use google to find instructions on how to properly uninstall it. If you don't know for sure then it could take some time. Old versions of Safedisk or Secure RAM cause trouble with Vista which is why I still dual boot with XP and keep clean images of both OSs :D .
August 19, 2009 2:08:35 AM

that's exactly what I did.... I reformatted and reinstalled and installed both service packs

everything works great now, I defragged and everything is great,

im never gonna mess with registry cleaners, ever again.... ever
!