Sign in with
Sign up | Sign in
Your question
Solved

A partition of Old HDD not accessible when connected a new HDD

Last response: in Storage
Share
August 19, 2009 7:51:05 AM

Hi everyone,

I have a system with 2 primary IDE channels and 1 HDD (segate-ST340014A, 40GB - 4 partitions). Recently I purchased a new HDD (160GB, segate- ST3160215A) and tried to connect in my PC. I first tried on one cable with different jumper settings but system did not booted. Then I removed CD-ROM connection and connected new HDD there, removing the jumper.


Somehow when the system booted, BIOS and OS(WinXP) detected both HDDs but what I see - Out of the four partitions in the old HDD I am not able to access the last partition (F drive, NTFS). When I click on it, windows asks do you want to Format it.


The F drive had approx. 10 GB of important data. How do I recover my data and partition - Please Help.


Also how to connect both hard drives on one cable so that I have CD-ROM on the other.

I have gone through the jumper settings guide (on segate.com) but still its not clear. Please can somebody give me clearly the settings/info I need to make.

PLEASE HELP

Any help is appreciated. I can also provide any additional sys info if required.

Thanks in advance.
a b G Storage
August 19, 2009 8:26:11 AM

What is your motherboard, IIRC, some mobo's have a limitation regarding the number of disks they can support, and the number of partitions they can "see".
m
0
l
August 19, 2009 11:25:59 AM


My motherboard is "Ausus KM400/KM266 chipset Series"

What is IIRC (didn't get you)

FYI
1. The partition (F Drive) was visible & accessible before connecting the 2nd drive.
2. Now after connecting a new drive, its visible but not accessible. (i.e it doesn't show File system etc. when in list view and shows free space as 10GB, when you try to open it - it says "do you want to format".)

Thanks
-Arun
m
0
l
Related resources

Best solution

a c 342 G Storage
August 19, 2009 2:53:34 PM

You certainly should be able to connect both hard drives to a single IDE cable. I'll assume you want to keep the old 40 GB unit as the device you boot from (with the C: drive as its first Partition), and the new 160 GB becomes a data-only drive.

On the old drive, the jumper should be on pins 7 and 8, the vertical pair furthest away from the 4-pin power supply connector. On the ribbon cable the END connector should be plugged into this old drive as Master.

On the new drive, there should be no jumper installed at all to set it as Slave. If you want to just store the jumper so it does not get lost, stick it on so one side is on one pin and the other is not on any pin. The MIDDLE connector of the ribbon cable should go to the new Slave.

Then you can re-connect your CD_ROM drive to the second IDE channel; set its jumpers as the Master for this channel, and connect the END connector of the ribbon cable.

If you want to, you could set this up differently. You could set jumpers and plug things in this way: old 40 GB as Master on channel 1, CD_ROM as Slave on channel 1 (set its jumper for Slave), and new 160 GB as Master on channel 2. To set the new drive as a Master, use the same jumper setting as the Master on channel 1 (pins 7 & 8).

Now, for accessing all the partitions, you need to check two items using Disk Manager in Windows XP. I'm sure Disk Manager in VISTA works the same. Before doing this, I suggest you set up all your jumpers on the HDD's and the CD-ROM drive as you want them to end up, and connect the cables EXCEPT for the ribbon (data) cable on the new drive - leave that one unconnected. This way you can set up drive names (letters) for all your devices and partitions as you were before the new drive is added. Then when you add the new drive it can do it with minimal adjustments.

Boot and click on Start at the bottom left and then RIGHT-click on My Computer in the menu. In the pop-up menu there click on "Manage" to open the Computer Management window. Expand Storage if needed on the left, then click on Disk Management. On the right side there are two scrolling windows. The upper one shows you all the drives you are able to use now, so you should see there the four Partitions on your 40 GB unit with their letter names, and the fifth "Drive", your CD-ROM unit with its name. For each one if you RIGHT-click on it the drop-down menu offers you some choices, one of which is to change this drive's letter name. If all the names are already correct you won't want to do that. But if you do, remember that you cannot change TO a letter already in use. So if you need to interchange two names, for example, you change one to a temporary unused name like "K:", then change the other to its final name like "D:", then go back and change the temporary one from "K:" to its final, like "F:".

If you come across a setting to specify the maximum drive letter to use, make sure it is set to allow a few more than you have. You will be needing one more, anyway, for the new drive you're about to connect. And your system might want to reserve a drive letter in future for something like a USB "thumb drive" or an external hard disk. Right now I suspect the trouble you have is that the system has limited itself too much and it was forced to assign to your new drive a letter previously used for the last Partition on the 40 GB unit, causing confusion.

So, with all of this set up, back out of the tools and shut down. Go into your case and plug in the new 160 GB unit, then reboot. Now go back through the menus to get to Disk Manager again and check all those drives you had - are they still named correctly? Now look at the lower right panel (don't forget it scrolls, too). Is your new 160 GB unit there? Check its name. If it has one, I would also expect it is shown in the upper panel, too. If it has no name, RIGHT-click on its area in the lower right, choose the Change Name item, and give it a name that does NOT conflict with your existing drives.

If the new drive shows only in the lower right panel and has no name, look closely at its Properties. Any new drive needs two operations on it to prepare for use - Partition and Format. If these have not been done on the new 160 GB unit it will be labeled "Unallocated Space" and you can't use it and you can't even give it a letter name. If that is your situation, let's go through the steps. If, however, these things already have been done, skip this next paragraph.

The first step to initialize a new drive in Disk Manager is to RIGHT-click on its Unallocated Space and choose the option to Partition it. Your first Partition must be the Primary Partition, and you can choose whether it uses up all the space of the drive, or some smaller amount. (If you don't use all, some Unallocated Space will remain and you can come back later and create in it one or more Extended Partitions.) If you plan to boot from this drive it must be made a Bootable Partition, otherwise not. Run this process to create that Partition. When done, RIGHT-click on that new Partition and choose to Format it. In the options, choose the NTFS file System unless you know you need the older FAT32 type. A Quick Format will do all the essential work in a short time. A Full Format does a Quick process and then goes through the entire disk testing every sector, which takes MANY hours - often best done overnight. This is an extra checking measure not normally required on a new disk assumed to be error-free, but you can do it if you like. When the format is complete, back out of the menus and reboot to let Windows catch up on your changes. The new drive you just created will be in place now, and you can check it in Disk Manager (as above).

If necessary, remember that you can rename any drive as long as you don't overlap names, so you can assign the letters as you wish. Back out of the menu system. If you had to make any letter name changes, or give a name to the 160 GB if it did not have one, then reboot to establish this setup. If there were no changes, the reboot won't be necessary.

Now open My Computer and look at your drives. All your old (4) Partitions on the 40 GB unit should be there, all with their correct letter names, plus the CD_ROM drive, PLUS a new drive with its own letter (160 GB, or less if you made a smaller Partition). You should be able to work with them all.
Share
a b G Storage
August 20, 2009 3:07:22 AM

IIRC = if I recall correctly :) 

So did paperdoc's article help you out OP?
m
0
l
August 20, 2009 9:40:02 AM

Paperdoc, Thanks you very much for a detailed reply. Excellent post.

Now let me tell you what I have in place.

Before connecting the new HDD to my PC, I connected it to my office PC using CD-ROM cable and partitioned it using Disk Management into 3 drives naming (M,N and O - all Basic drives). Did a full format on 'O'(NTFS) while kept M&N as unformatted. (as formatting was taking too long)

Right now (as I didn't knew the jumper settings before reading this post) I have both HDD setup on two diff cables and CD-ROM is disconnected. For new HDD I removed the jumper and the old HDD has the jumper set somewhere (the BIOS shows it as primary slave).

Now with theses settings - the system doesn't boot seamlessly, sometimes I have to hit the restart buttons 2-3 times and then somehow it boots.

When it booted first time in the MuComputer list view one of the old HDD partition ('F" drive) had no filesystem listed and new HDD partitions were not visible, I did a "import foreign disks" in the disk management and then I have able to see M,N and O drives.

But when I tried to open "F drive" it said "The drive is not formatted. Do you want to format - Yes/No".

Maybe when trying to connect new HDD, old HDD got bad sectors or what.

Thanks
-Arun
m
0
l
a c 342 G Storage
August 20, 2009 9:29:53 PM

Let's start by fixing the jumpers. You have with HDD's on separate IDE ribbon cables, and the CD-ROM dive is disconnected. So each of the hard drives is the ONLY device on its cable. That means BOTH of them MUST be set to Master with their jumpers - each will be the Master to its own IDE port. Since these are WD drives, that means on each drive you need one jumper installed across the vertical pair of pins furthest away from the power connector, like this:

    : : : : :           [:] : : :          oooo
(part of              ^               4-pin Molex
data port)        Jumper on       power
                      end vert pair      plug

You should use the END connector of each ribbon cable to connect to these two drives.

Now in the BIOS both drives should show up as Masters, one on Primary channel, one on Secondary.

Boot into Windows and go to Disk Manager. Remember what drive letters you had assigned before. There were four Partitions on the old drive, plus an optical drive. You will want to assign those same names back - probably they were C:, D:, E:, F:, and G:. But the new drive may have taken over one or more of those names. You really want the new drive's partitions to start with names like H:, etc. So, rename the first active Partition on the new big drive to H: IF the other Partitions you had created somehow have names already, change them to later letters. Now go back to the old drive's Partitions. Remember to leave one letter in reserve for the optical drive once you re-connect it. Re-name every one of the old drive's 4 Partitions to what it needs to be. Back out of Disk Manager and reboot.

In My Computer you should be able to see all four of the old drive's Partitions, each with its own correct name. And you should also see the first Partition on the new drive that is ready for use because you already Partitioned and Formatted it elsewhere.

Now, the remaining two Partitions you created on the new drive you never did format, you say, but somehow through Import Foreign Disks you made them visible. If they are here with letter names, try to click on them. They may well report that the are not Formatted and ask if you want to do that. As long as you are sure that all your previous partitions on the old drive are OK, and all the new drive names are correct, then it will be OK to format those new Partitions on the new large drive. Do that for both, with NTFS File Systems, of course. When you're done you should have all of the hard drives and their Partitions set the way you want.

Last step will be to re-connect the optical drive. Make sure its jumpers are set to Slave - both IDE channels now have their own Masters in the hard drives - and connect the Optical to one of the ribbon cables' middle connectors. Close up and reboot into the BIOS Setup screens and just check that the two drives show up as Masters on the two IDE channels, and the optical drive shows as the Slave on one. Complete the boot into Windows and go again to Disk Manager. Check that the optical drive is there and check its name. If it got the wrong letter, or if any of the others changed on you, fix them again until they all are right. Back out and reboot so Windows can get it set in the Registry. When you are into Windows again, look at My Computer and verify that all the drives and letters are present, and each of them can be read and used.
m
0
l
August 21, 2009 1:49:52 AM

One more thing to remember, with all those drive paths (letters) you'll most likey run into this again when you use a flash drive. Just remember to go to your computer management / Disk management and change the drive letter for the flash drive. You should see it in the discription.
m
0
l
August 25, 2009 1:42:41 PM

SOLVED

Hey Paperdoc,

Your detailed posts helped me fix the problem and now I am able to access all partitions (of old & new HDD). And I have both HDDs setup the way I wanted.

For the guidance that you have given me I would really like thank you from bottom of my heart.
Kudos to you and Kudos to tomshardware.

Also thanks to everyone who has contributed to this Post.

One more thing
I have posted one more related thread - its not a question but expert suggestions are required.



Thanks once again.
m
0
l
!