Sign in with
Sign up | Sign in
Your question

Iomega drive just beeping

Last response: in Storage
Share
August 22, 2009 8:20:06 PM

I purchased an Iomega usb mass storage drive, it was working fine until i knocked off the table, no even two foot onto the carpet. Then when i plugged back in, it just keeps on beeping every 5 seconds and stops after 10 minutes. Then i can plug in the usb cable but the hard drive does not show up in my computer like it did before. It shows up in safely remove hardware only. It does not show up in disk management. I even tried to install it internally just like a regular hard drive and still does the beeping. I was able to retrieve a bit of the files using active file recovery but not everything.
I just want to be able to use the hard drive like before.

Thank you.

More about : iomega drive beeping

August 24, 2009 4:11:42 PM

It sounds like your hard drive might be having a problem with the hard drive itself. If this is one of those portable drives, then it shouldn't have been that much of a problem. But if it is one of the bigger desktop drives, you could have done some damage... especially if the drive was on.

It sounds like the USB backplane is still working and you could replace it with another hard drive, but if you're still under warranty, might as well work with their tech support. It's cheaper than buying a whole new hard drive. Since it was dropped, I'd be careful what you say if you do decide to talk to tech support.

If you use chat for Iomega hard drives they don't charge you for the call, so that's a plus. Here's a link to their chat line for tech support: https://iomega-na-en.custhelp.com/cgi-bin/iomega_na_en.cfg/php/enduser/contact_confirmwarranty.php

Good luck!

~~
elcman
m
0
l
May 14, 2012 9:03:29 PM

Mine is doing the same thing right now!!!
What did you do to fix it? My email is tosha_2009@hotmail.com
Please let me know how you fixed your problem!!!
m
0
l
Related resources
June 7, 2012 10:50:05 PM

tosha_2009 said:
Mine is doing the same thing right now!!!
What did you do to fix it? My email is tosha_2009@hotmail.com
Please let me know how you fixed your problem!!!

m
0
l
June 7, 2012 11:34:55 PM

I read this earlier and said yeah, I forgot. Many of us have mini usb chords and like me, trade them for different peripherals. Well, the Iomega external hard drive I had a problem with came with a pigtail "Y" on the computer side. It needs full power to operate. Whew and I was about to open it up and troubleshoot or make it really broke.
m
0
l
!