Sign in with
Sign up | Sign in
Your question

Realtek High Definition Audio, No Sound

Last response: in Windows Vista
Share
November 10, 2012 4:29:20 AM

Hello everyone, well, for the past few days now. I've been experiencing this issue of having no sound. On the lower-right corner of the system tray, there is a Speaker icon with a red circle with a white "x" on it. So naturally, I assumed that this must be due to the sound drivers corrupting. So I went to the manufacturer's website for my Notebook. Which is an Acer Aspire 4730Z running on Windows Vista Home Premium Service Pack 2.

The drivers I downloaded were Realtek High Definition Audio, after the files finished downloading I reinstalled them, only to encounter yet another problem. Which was that they failed to install. The specific error message that appeared was "Install Realtek HD Audio Driver Failure". So I tried to install it again, this time through the Device Manager by updating the driver software. This also, did not work, the error message for that was "This operation returned because the timeout period expired".

I've also tried the System File Checker tool, Microsoft Mr. Fix-It tool, the Check Disk utility, editing specific Registry entries in the Registry Editor, resetting the Services back to their defaults. Absolutely nothing has been successful so far. I've even attempted to reboot into Safe Mode, and install the software. Which surprisingly enough, worked. I rebooted my computer again for the changes to take effect, just when I had thought that I finally solved this annoying dilemma, restarting computer reverted those changes.

So it was as if I never installed the drivers to begin with. So now, I am at a loss as to what to do. If anyone can offer any more alternative solutions. Please let me know, I'd greatly appreciate it.

Edit: I forgot add, that I used a Live CD of a Linux distribution just to confirm that this wasn't a hardware issue. And it wasn't, the speakers were functioning normally while I running the Linux Live CD. I should also note, that I've checked the Windows Audio Service. Which was stopped, but when I started it again this error message appeared.

"Windows could not start the Windows Audio Service on Local Computer. Error 0x800700c1:0x800700c1." I right-clicked on Windows Audio Service, and selected Properties to verify that all its Dependencies were started, which they are.
!