Seagate 1tb drive not detected, works via esata?

Hi all,

I have 3 1tb seagate drives and 3 WD black 1tb drives. I purchased 2 Silicon Image 4 port sata controllers, and am getting everything hooked up in a new machine.

Problem is, one of my 1tb drives is not seen by the onboard sata controller, or either Silicon Image sata controllers, but if I hook it up to my desktop via esata, it spins up and runs like a champ?

- I've tried different ports on both controllers and other drives are detected properly

- I have tried two different sata cables with the onboard and both SI controllers, no go anywhere

- I have checked the power cabling, and as far as I can tell, the drive is spinning up in the case (I have to remove it to connect via esata)

- The SI controllers detect the other 2 match drives without issue, and I have tried all the seagates on one and all the wd's on the other, and mixed them, no combination works.

Anyone have any ideas?
1 answer Last reply
More about seagate drive detected works esata
  1. Nevermind, found out I have a bad lead on my molex to sata power adapter causing the issue.
Ask a new question

Read More

Hard Drives SATA Seagate Western Digital Storage