Sign in with
Sign up | Sign in
Your question
Solved

Trouble Installing Vista on a Wiped HDD

Last response: in Windows Vista
Share
November 19, 2012 5:03:15 AM

I'm trying to install Windows Vista on an HP dc7800 USFF with a recently 5-pass wiped 250 GB Hitachi SATA HDD.

I've created bootable usb installation media with a vista .iso using Novicorp Win2Flash (real easy and recommended software!)

However, when I try to install Vista, I can only get to the dialog box that allows you to select the partition. Only one partition is visible, and it's approximately the right size (233 GB), but it gives the error message:

"This computer's hardware may not support booting to this disk."


I tried:

- using diskpart to re-create the partition

- using both bootsect and /fixboot

- Re-formatting the HDD NTFS using another workstation.

- Mounting the HDD as a secondary on another system, and using the same .iso to install Vista on it; This worked (The drive is not DOA), but the resulting installation wasn't bootable on the dc7800.

- Removing the USB when selecting the drive


The drive is SATA and doesn't have any jumpers.

My BIOS doesn't have the option to change AHCI settings; I think it <i>may</i> be automatic


I'm going to take another stab in a day or two. Any suggestions would be helpful.
November 19, 2012 5:06:10 AM

I should add that I was not being very systematic about the order in which I tried these and various other fixes. If anyone wants to just define the usual order of steps I may need to follow to prepare this HDD for OS installation (and common mis-steps), that would be great too.
m
0
l
November 22, 2012 1:40:10 PM

Just one bump! Anyone? I was hoping to take another crack at it this weekend.
m
0
l
Related resources
November 22, 2012 1:43:00 PM

No need to pre-partition the disk. Just remove all partitions and let the installer create one.
m
0
l

Best solution

November 27, 2012 8:05:18 PM

Is the hdd a Sata 2 or Sata 3 disk drive? If Sata 3, it could be the motherboard does not support that type, you need to put a mini jumper in the middle pins set to convert the hdd to Data 2 mode.
Share
November 30, 2012 9:52:22 PM

Thanks for your reply.

Although it wasn't a SATA 3 drive, it got me thinking about the BIOS.

I flashed the BIOS with the latest (Dec 2011) version using the built-in utility. The utility can see the .bin file if it's placed in the root directory of the USB flash drive.

After the BIOS flash, the installation was able to proceed.

I suspect it's something to do with the AHCI setting, although the GUI for the new BIOS version does not have any AHCI options.


Either way: Problem solved and thank you!
m
0
l
November 30, 2012 9:52:34 PM

Best answer selected by NByz.
m
0
l
!