Sign in with
Sign up | Sign in
Your question

Restoring my second RAID1 array after installing XP

Last response: in Storage
Share
August 31, 2009 4:48:28 PM

I originally posted this in teh "General storage" section, and after reading more here I should have posted here.

____
Well, I had a RAID1 array for my system drive. Had!

When I got back in town on Wednesday and turned on my PC one drive had failed. This array contained my OS and other files. I copied all of my personal files, I hope, to another drive. I had another one ready to take it's place but I had to leave town again in a few hours. So, I turned the PC off and left, came back and turned it on, and the second drive failed. The whole array failed within 2 days.

I bought two new 1TB SATA drives (Seagate) today and the OS (XP, sp3) is up and running again, and the new 1 TB RAID1 array is partitioned and formatted and is working. But... the second array, also RAID1, the one that did not fail, doesn't come up in Windows. The BIOS sees it. Device manager sees it and says it is working. Disk Manager sees it, says it is healthy and active, gets the disk space used stats right, and even gets its name right, but the only option it gives me is to delete the partition. It is formatted and has files on it that I need to keep. Seems to me it just need a drive letter.

Any ideas?
August 31, 2009 10:45:45 PM

TestDisk did not find any errors.
m
0
l
September 1, 2009 3:12:46 AM

Fixed it. Took some time, and searching.

Turns out that Norton GoBack was the culprit. I had it installed before the failure and it seems that it modifies the MBA database, or whatever it is called. Symantec has a program to take care of this. You download the ISO image file, copy it to a CD, reboot from the CD, select opton 1, then wait for about an hour and a half, and finally reboot, and now everything is good. Well, except for the two drives that failed, and for these I am beginning to suspect a driver problem that causes random SMART errors.

So, I solved a noob's problem. What do I win? ;) 
m
0
l
September 2, 2009 10:06:51 PM

Final report.

Here's what I did, and to spoil the ending, I got my files and everything is running.

I took these drives and mounted them in an external SATA drive bay and ran SeaTools (DOS version. Windows versions did not work). SeaTools showed that one drive had reported a SMART error (temperature above 70C) but the other hadn't. The first drive failed the short test and crashed the system during the long test. The second drive passed the tests. Hopefully I would still be able to get my files off this drive.

After the SeaTools tests I put them back into the system to verify that the system could not use them. I tried, one, both, then switched them (swapped cables). The BIOS reported one had failed and the other was offline, or not working, depending which I hooked up with which cable. Anyway, it was clear I wouldn't be getting the system to boot this way. I thought about going into the RAID BIOS utility and switching them back to solo drives but was concerned about data loss.

To back up a bit, I've now replaced my 2 x 500 GB RAID1 array that held my OS and other files with 2 x 1TB drives, installed the OS and a few apps, and that's working.

I found a file DIY recovery tool at Seagate and was all ready to try out the demo version, just to see if I could get my files back. I installed the still-good drive in an external SATA bay and booted the system, and it booted to THAT drive! That was probably the best luck I could have had, because now I could just copy my files to another drive. I guess the boot order in my BIOS had reverted to using the Promise SATA card. I backed up my files asap, plus I downloaded a program that would backup my Thunderbird email and FireFox settings and backed them up. I shut down, removed the former RAID1 C: drive, rebooted, and the new system came up. I then installed Firefox, then restored my old settings. I then repeated the process for Thunderbird. Done. Now I can finally put the top back on the case, finish installing apps, and get back to work.

I was surprised that the system would boot on this drive and even more surprised that everything was intact. RAID1 is mirroring, so there should be duplicates of the files on each drive, but I still expected issues with the file names, partitions, etc.
m
0
l
!