Sign in with
Sign up | Sign in
Your question

Hard Drive Issues (disappears and re-appears)

Last response: in Storage
Share
September 7, 2009 5:39:23 AM

About 3 weeks ago, a hard drive failed on me. I tried it on different SATA ports, with different cables and it was a no go.

So I replaced it with another drive, which has worked no problem. Now, I recently got a second SATA drive (for backup purposes) and plugged it in as well (I have more than enough power for it and plenty of cooling).

It was working just fine for about a week, but now it'll just disappear on me at times, then if I reboot or switch it around on the ports, it'll come back. Then it'll disappear again (not just in Windows Explorer, but in the BIOS)

In event viewer I'm getting this error: Source: ATAPI "The device, \Device\Ide\IdePort5, did not respond within the timeout period"

I just noticed as well, I got some of these from yesterday:

Source: Disk "The system failed to flush data to the transaction log. Corruption may occur."
Source: ATAPI "The driver has detected that device \Device\Ide\IdePort2 has old or out-of-date firmware. Reduced performance may result."
Source: Disk "An error was detected on device \Device\Harddisk0\D during a paging operation."
Source: ATAPI: The driver detected a controller error on \Device\Ide\IdePort2.

Let me just say, the hard drive that I said failed, I sent back to WD and they sent me a new one because it was under warranty. So I assume they verified it was toast before sending me a new one.

I'm just wondering what's going on, is my SATA controller gone, or rather going? What do I do then? How can I test to make sure?

Do I need to replace the entire MOBO if it is gone?

a b G Storage
September 7, 2009 6:53:52 AM

Is the second SATA drive you acquired used or new? Is it SATA 3 ?

Make/model of PC and second HD please?

Have you tried different SATA ports, cables?

Whoever tries to resolve this for you will need that info.

Could be your controller, smells like the disk though. If its the controller you will be replacing the mobo. (wouldn't by chance be an EVGA mobo, would it? I have a sense of deja vu . . .)
September 7, 2009 7:05:29 AM

Second SATA drive is new. It is SATA 2.

Specs: ASUS P5K Mobo, Intel Dual-Core E6750 2.66GHz, 2GB OCZ DDR2 RAM, Boot drive is a Seagate Barracuda 500 GB drive.

Second HD is a Western Digital 500GB, I don't recall the exact specific model. As I said, it was a replacement sent by Western digital. I didn't want to wait for it originally, so I got another drive (which has been running fine for a few weeks on it's own) and want to use this one as a backup.

The backup drive worked fine for almost a week.

I've tried it on different SATA ports, I'll try a different data cable next, but I used a brand new one, so it seems odd it would be defective. The SATA power cable is on a chain, with the primary hard drive using the connector in the chain after the one the secondary drive (the one that is not working) uses. So I don't think that's the issue, unless the one connector could fail and the other would still work, even if they are chained.

This is the original problem I was trying to diagnose, when the computer started to overheat, which has now been resolved due to fixing of the dislodged heat sink post (thanks to you TwoBoxer).

It would just amaze me if the drive I received as a replacement for the malfunctioning one (which failed within a year and a half, well within the 3 years warranty), failed within a week! It would make me wonder if something was not maybe causing these drives to fail, like the PSU. I checked the voltages and they were all within norm though.

I wanted to quickly add, when I re-booted this is the order of errors: (it sort of hung after the Windows XP loading screen for about 10 seconds or so)

Error: The device, \Device\Ide\IdePort5, did not respond within the timeout period. (atapi)
Warning: An error was detected on device during a paging operation. (disk)
Warning: The system failed to flush data to the transaction log. Corruption may occur. (ftdisk)
Related resources
a b G Storage
September 7, 2009 12:55:00 PM

I had a problem with SATA ports on a DFI board I had. No matter what I did, they simply would not maintain a solid connection. I could wiggle the connection at the board with the PC on, and the drive would stop, start, stop, start kind of thing.
After several different types of cables, I finally found a very soft set that would plug in and maintain a constant connection.
September 7, 2009 7:42:37 PM

I've now switched to a brand new SATA data cable and it still doesn't work.

I've tried it on different ports (should be one from each controller now).

Any other thoughts? I can't believe they sent me a replacement drive and then it failed within a week! If that is indeed what's happened.

If it is indeed the drive, will they send me another one?

edit to add: I've also used a molex to SATA power plug and thus used a different power connector for the drive and it still doesn't work. The drive did show for like 30 seconds again, but then disappeared.
September 7, 2009 11:50:52 PM

I ran Western Digitals diagnostic tool and it picked up the drive and the quick test showed nothing wrong.

This baffled me because the BIOS would detect the drive and then lose it and Windows never seemed to pick it up anymore.

Then I ran a full test, about 2 hours in it gave me this "DRIVE NOT READY ERROR/STATUS CODE:0104".

Dead/dieing drive?
a b G Storage
September 8, 2009 12:39:51 AM

Tough to say lol. I had similar problems on an EVGA mobo. Replaced cables, disk drive . . . finally put in a Gigabyte mobo and problem disappeared. Could have been the cable not maintaining satsifactory contact in the mobo connector, could have been the sata port came loose from the mobo.

To this day I wonder if I had shoved a wooden toothpick into the sata port to jam the cable in . . . would I still be using an EVGA mobo lol.
September 8, 2009 1:00:24 AM

Well consider this, the boot drive has had no problems (for about 3 weeks since I've had it) and was even running overnight last night.

I put the secondary hard drive (the problem one) onto that same port and it found it and lost it shortly after. If it's a connection problem, it's on the hard drive end, not the mobo.

I've tried different data and power cables already.

It has to be the drive, something on it because it ran fine for 4-5 days and then quit and won't stay found on any port with any cables.

Meanwhile the boot drive and the DVD-RW drive are perfectly happy working on the SATA ports problem free.
a b G Storage
September 8, 2009 1:58:03 AM

Then it seems you have found your answer.
September 8, 2009 2:16:44 AM

Even if I think I've found the issue, I still like to bounce my ideas off others. Which I appreciate being able to do here.

I'm going to RMA it, see what Western Digital ends up saying.
!