Sign in with
Sign up | Sign in
Your question

is my gigabyte GA-EP35-DS3L broken?

Last response: in Motherboards
Share
July 30, 2008 9:45:10 PM

ordered my new computer last sunday, was all excited till i tried to put the cpu on the mobo. After i read the instructions carefully, i did what it said and put the cpu in the slot, piece of cake. But, the "cover" that comes down around the cpu is bent outwards. So i cant clamp the cpu down without it exerting a great amount of pressure on the cpu. I havent tried it obviously worrying id break all the pins in the slot and prob ruin my e8400. Is it supposed to be slightly curved like this or am i right thinking its broken?

I can provide pictures of it if someone can tell me how to post it here. The bend is very slight, but enought that the thing wont clamp down.
July 30, 2008 10:00:04 PM

i just read another post from a few months ago almost exactly like this one. Im thinking thats how its designed, i just wasnt expecting that. Im used to how amd had their slots designed. With amd it just falls straight in and clamps down super easy. Can someone confirm it takes quite a bit more force for an lga 775 slot than an amd 939 slot? Im just a bit worried about messing something up, so i freaked out when it was different than i was used to.
July 30, 2008 10:13:28 PM

If you are sure the CPU is properly in place, then pull the lever down and lock it. It certainly is possible that the load plate is malformed but it is unlikely. This may help.


Related resources
July 30, 2008 10:27:46 PM

thannks a bunch zorg. That vid was perfect, i was woried by how the cover thing didnt lay flat against the socket, which is how they showed it in the video. Even tho the video gets annoying, its good for novices like me. :wahoo:  Gonna build it now
July 30, 2008 10:34:00 PM

Good luck with it.
July 31, 2008 2:00:33 AM

Did it work? Yes, you will feel quite a bit of resistance when the plate comes down over the CPU and you really have to push hard to get the lever to seat under the lock.
August 1, 2008 5:11:55 AM

Yes, it worked fine. The computer is up and running, with no known issues. Other than windows taking over 4 hours to update....
!