Sign in with
Sign up | Sign in
Your question

X1950Pro Is Dieing I thnk

Last response: in Graphics & Displays
Share
June 17, 2008 7:15:19 PM

My X1950Pro is about a year and a half old now and I think it is dieing. I can't run AoC, my card stops outputting video for about 5-10 seconds every minute, and does this weird thing in games were it seems like it forgets a point on a texture and a triangle stretches on forever. Here are some examples in wow, but it happens in AoC, Overlord, SupCom, and EVE. Also, I get flashes of odd textures on my screen, not big, like a single frame of distortion on on part of the screen.

Also on black backgrounds I get what looks like green frozen pixels, that go away when the black does, but things like minimizing don't work. I have reinstalled DirectX, drivers, windows, and nothing works. The Green Pixels also occur is BIOS start up so it is hardware.

Any help?


More about : x1950pro dieing thnk

June 17, 2008 7:37:00 PM

you can also get artifacts when your psu is dying. i ones got artifacts at a to low powersupply. and i bought a new one and no artifacts again.
June 17, 2008 8:15:18 PM

Is there a way to test that without another computer?
June 17, 2008 8:18:14 PM

no, you need a psu from an other psu and has to be equivalent or better watt than the one you have in your case. i guess there will be people who now programs? i don't know.
June 21, 2008 3:55:23 PM

I had the same problem with my old 9600 Pro. Polygons would stretch right across the screen in games, then eventually the card started artifacting even with an idle windows desktop. For me it was the card that was dieing, a new X1800 AIW put everything back to normal.
!