Sign in with
Sign up | Sign in
Your question

The great CRC error mystery

Last response: in Motherboards
Share
August 5, 2008 9:07:16 PM

Not sure which is the correct forum to post this in, so I'll try this one, hopefully the mods will move it if it needs moving

I have a ridiculously frustrating problem that I have no idea what the next step is in troubleshooting.

Whenever I try to install a game, and only a game, I get a cyclic redundancy error. This is often displayed as an error with a cab file, which varies from game to game, but always stops the install between the 10 - 20% mark. I've tried various different things to rectify the sitaution to no avail.

The strange thing is, that software installs just fine. I've installed MS Office with no problems along with Visual Basic Express and a couple of other software suites, and they install with no trouble whatsoever.

The problem only arises during game install, mainly but not exclusively limited to large games. I have taken the following steps to try and troubleshoot the problem;

  • First thing I did was try a different game, there were problems installing every game
  • I cleaned all the disks and ensured there were no scratches or marks on the CD
  • I removed the CD/DVD drive and replaced it with another CD/DVD drive
  • I tried the current CD/DVD drive in another PC, and the install worked with no problems
    These points essentially eliminate the problem being the CD drive

  • I copied the contents of the CD to my hard disk and tried to install from there.
  • I created an ISO file from the CD and mounted it using daemon tools
  • I downloaded a copy of the game I was trying and tried to install using that, mounting the image I downloaded using daemon tools
  • I installed ALL the game with no problems on a seperate PC
    This pretty much assured me that the CD's of the games I was trying were not to blame

  • I ran memtest86+ on an extended loop for 8 hours, and it gave 0 errors
  • I removed one stick of RAM and vice versa, ran memtest on them individually and changed the slots no errors and still a CRC error on the game install
  • I cleaned the RAM and ensured the slots were free of dust and grime, still no luck
    Pretty much tell me it isn't a RAM fault

  • At this point I reformatted my computer and reinstalled my copy of Windows Vista with no luck
  • I then rolled back my OS to Windows XP 32 bit AND Windows XP 64 bit, trying XP 64 first and then 32 bit when XP 64 didn't work, still got a CRC error.
    Eliminated the OS as a problem, although I didn't really believe it was a problem anyway

  • I ran a full chkdsk on my primary and secondary Hard Disk, and both passed with flying colours
  • I replaced the IDE cable and SATA cable of both my primary Hard Disk and Secondary Hard Disk
  • I ran grc.com's spinrite for 9 hours overnight with no obvious problems arising
    It's not a Hard Disk error!

    This pretty much leaves me complete at a loss. I''ve bought a ghaming PC, and all of a sudden it's decided it won't let me install any games. I've had CoD4 working on it previously, and since a reinstall even that won't install now. I have absolutely zero idea what the problem is, and I've run out of ideas.



    A) Could anyone suggest anything else I could try?

    B) Can anyone find me the updated BIOS for my motherboard, so I can reflash and see if that is the problem. Is it worth me hunting down a new BIOS, or does that ever cause problems with CRC errors?

    C) Could it possibly be some a driver error that is recurring when I'm installing the OS, as I'm using all the supplied driver CD's but perhaps there is a problem?

  • 500 GB SATA HDD UDMA 300 7200 16MB
  • CREATIVE SB AUDIGY SE 7.1
  • AMD ATHLON 64 X2 5200+ 2MB SKT-AM2
  • XpertVision 512MB RADEON HD 2600PRO SUPER PCI-E
  • ASUS SKT-AM2 M2N-MX SE PLUS M-ATX 2000MT/s
  • ASUS DVD±RW 20x S-ATA DRW-2014L1T BLACK LIGHTSCRIBE (SATA)
  • Speeze QuadroFlow VIII - Low Noise
  • 600W PSU
  • 4GB DDR2 PC-6400 800 MHZ (4 x 1 GB 800)


    ANY helps is very very appreciated. This is incredibly frustrating at the moment as I've got an almost brand new gaming rig and it won't play any games!
    August 9, 2008 4:21:53 AM

    Some sanity checks... there are many things that are easy to overlook.

    Have you checked that the voltages and temperatures under "PCHealth" in the bios?

    Are there any errror messages in the event viewer?

    Do you have any conflicts - in particular have you disabled the onboard video and sound subsystems so they don't conflict with your separate cards?

    Try reseating the video and sound cards in their slots.

    I would look for the most recent drivers from the vendor web sites - the ones that are shipped are often out of date by the time the cards are delivered. You should be able to find the most recent motherboard bios on the ASUS web site. Also, I've found that the Nvidia SATA drivers can be finicky depending on the specific components. If your configuration is non-RAID, you can use the MS Windows default drivers for your hard disk and optical drive - perhaps slower, but more stable.

    After checking these points, you could try a general stress test such as the Prime 95 torture test.

    Finally, you could simplify your system configuration by removing the video and sound cards and simply using the onboard subsystems.

    Let us know what happens.


    Good luck
    Robert
    Related resources
    December 27, 2008 6:45:04 AM

    Hello jaxxstorm, I am in the exact same boat.

    Im running Windows Vista Ultimate SP1 64bit on:
    Asus P5W DH Deluxe, latest BIOS
    Core 2 Q9550
    4GB Corsair

    On this same system I have run Unreal Tournament 3, Grid, Guild Wars, and Command and Conquer 3. Of those, I can ONLY get Guild Wars to install (and I used the web client). The system is of course stable, Ive run CPU burn, BOINC for days on end, and multiple passes of memtest 2.11. Nothing is apparently wrong, but no matter what, UT3 will CRC error at about the same 20% of the way in (or randomly thereafter).

    This is honestly the most frustrating problem Ive encountered. Ive seen lots of answers that dont work. Set affinity of the setup executable to a single core. Change the permissions of the windows temp folder. Clear the windows temp folder. Copy the disc to a folder. Make an image and use daemon tools. Nothing works. These same games can be installed on my laptop and do not have any trouble.

    But yet, I installed office with no problems. As well as video software like total media extreme.

    At this point I would reinstall windows AGAIN if it would fix it, but even that failed to get rid of the issue.

    I thought it might be the BIOS, but considering your board is a different make, it couldn't be that widespread of an issue at Asus.... could it?

    -Mike
    December 27, 2008 7:12:28 AM

    Started to happen to me after bad overclock and i'm using Gigabyte board not Asus maybe you Overclocked too and failed
    December 27, 2008 9:06:44 AM

    This is actually possible. Though Im not overclocking exactly, Im forced to. See, the Asus P5W DH Deluxe is a 975X chipset and is running with a Q9550 which requires the core clock to be at 333 Mhz. Im gonna try and drop it to 266 and underclock the processor to see if that fixes it...
    December 27, 2008 10:01:13 AM

    Yep, apparently the P5W DH at its default settings for the Q9550 are NOT stable. While it can do laps on memtest and CPU burn, the higher clock seems to screw with the south bridge. Dropping the clock got rid of the CRC errors. Really odd that installations were the only issue, no problems with anything else including compressing / decompressing RAR archives and such.

    Thanks. Now to find a balance of speed and true reliability.
    December 27, 2008 1:19:32 PM

    Thats great also i recently i found some program 'RegCure' i was suprised it realy fixed my problems o_0 actualy couldn't believe it .The program is not freeware but there are plenty of serials over the net
    !