Sign in with
Sign up | Sign in
Your question

Gigaware SATA / USB enclosure external HD

Last response: in Storage
Share
September 18, 2009 6:27:19 AM

I have a 3.5" Western Digital 160 GB SATA HD installed in this enclosure however none of my 4 Laptops running WIN XP 1 thru 3 ) nor my desktop ( still on Win 2K SP4 ) recognize the drive when plugged directly into one of the USB ports on the machine(s) and is the only external drive. SATA Drive is also not recognized either even if if another USB port has an IDE / USB Gigaware box attached and working. SATA drive was working internally in another PC but was removed to be replaced with larger internal drive.

. The xtrnal SATA box blue power light lights, the box warms up and one can feel the drive running. All the above PC's recognize a 3.5" Western Digital 260 GB IDE / USB drive. Neither drive has jumpers installed and is the only external drive.

Once, upon power removal, the desktop complained that a USB device had been turned off without proper procedure, but have never seen the drive icon, and none of the OEM drivers work. Have never been able to repeat the wrong removal error message.

Instructions with the box state no driver is needed. Yeah right .........

Gigaware is a Radio Shack house name made in China and their site has been of no help. have done searches for gigaware and sata/usb but nothing applies to this G/Ware model 25-423 :( 

Anyone here have a suggestion as to drivers?

Mahalo and Aloha from Hawaii !

Jack
a b G Storage
September 18, 2009 7:21:02 AM

Either there's something wrong with the cable or you, my friend, have purchased a faulty enclosure.
m
0
l
September 18, 2009 7:28:43 AM

I assume that you also mean it REALLY needs no driver. Thanks! Will swap cable from IDE box and if that fails, return the box to R/S
Mahalo!

Jack
m
0
l
September 25, 2009 7:53:30 AM

r_manic said:
Either there's something wrong with the cable or you, my friend, have purchased a faulty enclosure.



I assume that you also mean it REALLY needs no driver. Thanks! Will swap cable from IDE box and if that fails, return the box to R/S
Mahalo!


Nothing, no swaps worked for the SATA so I returned the box for IDE enclosure swap. I have several large capacity IDE's also so could use the extra IDE BOX.
m
0
l
!