Sign in with
Sign up | Sign in
Your question

Possible RAID 0 Failure??

Last response: in Storage
Share
September 18, 2009 4:03:32 PM

Ok, So just recently my brother has been having some issues with his home built pc.

He said within the last two weeks his boot priority seems to becoming deleted and everytime he starts up his pc he needs to reassign his boot priorities.

Little background on his pc.

Thermaltake Armor full tower case
Asus M2N32-SLI Deluxe Wireless Edition Motherboard
Corsair XMS2 2GB DDR2 800 (PC2 6400) RAM
AMD 4400+ AM2 Processor
Zalman 9500A Heatsink with Artic Silver 5 Thermal Compound
HIPER Type-R 580watt Power Supply
EVGA 512-P2-N570AX 512mb GDDR3 16x PCI-E Graphics Card
UltraATA133 RAID Controller JU-NNBR11
2x Western Digital Caviar SE16 WD2500KS 250GB 7200RPM SATA 3.0GB/s Hard drives
2x Western Digital Raptor WD740GD 10000RPM SATA 1.5GB/s Hard drives in RAID 0
Western Digital Caviar SE WD1200JB 120GB 7200RPM IDE Ultra ATA 100 Hard drive
Seagate Barracuda 7200.11 ST31000333AS 1TB 7200RPM SATA3.0GB/s Hard drive

Windows XP SP3 Professional.

So just Wednesday night, he booted up his computer after work just like he always has, and he receives some sort of BOOT DISK error.

So he corrected this error by just reassigning the boot priorities like he has been doing. And his computer will go through the POST and start to load up Windows where the blue status bar at the bottom scrolls. And after this screen his screen will remain blank.

So he rebooted thinking his computer just stalled and now it said he has an error in his raid.

So, his main concern is salvaging the information off his RAID 0 setup. He has installed windows on another hard drive and this boots normally with all the other hard drives when the two Raptor drives are unplugged. However, when he plugs the raptor drives in and keeps his boot priority into his other hard drive not the RAID 0 stripe, his windows does not detect the raid, even though his BIOS can detect the raid and deems it healthy.

I am not really sure what is happening, but when I get home from work, hopefully I will have an update with specifics.

So, my question is really how to salvage information from his RAID 0 setup because he wants to reformat it because there is a problem somewhere in the RAID.

Thanks in advance and I will post again when I get home.

More about : raid failure

September 19, 2009 1:30:09 PM

Correction I guess the first problem other than the drive priorty needing reassigning was that there was an error saying that dll files for kernel was missing. Then this is where is problems started because it posted and could not enter windows. Then the raid failed.

I was trying to take a look at his raid setup this morning and it seems like he took out the two trouble some drives, i think he was testing them separately in a different build.

Any insight would be helpful, if not I will reply again at a later time once I get ahold of him.

Thanks.
September 19, 2009 1:59:07 PM

Maybe try Acronis true image to clone the information across. If I remember correctly with onboard RAID the drives are fromatted as dynamic and quite often you can't access them from another boot drive. You really need an aftermarket raid card like the Areca. Connect any set of raid drives to any Areca raid card and it will work. The other thing is to keep an image of your boot drive on a spare drive so you can quickly restore everything if something goes wrong.
Related resources
September 20, 2009 2:43:08 PM

What he did was just do a fresh windows install on a different hard drive, and then attempt to recover the files. He was seeing just 1 of 2 of the raid drives in the nvidia mediashare hot swap array. and it said the raid was corrupt.

But he left the computer untouched after he turned it off yesterday, and went back at it today to work on it, and now nothing posts.

No post on bios and nothing.

he has attempted to rest the CMOS already by swapping the pins on the bios reset and removing the battery. but nothing has fixed yet.

anyone have any ideas on how he can get back into windows?
September 20, 2009 3:02:48 PM

I had a lot of problems with two western digital drives at the begining of the year. They were corrupting everything including the bios. They tested fine, benchmarked fine but the firmware or controller chip was doing something crazy. To be honest I don't think you have much chance of getting you data back. I could be wrong but it's not looking good.
September 20, 2009 5:53:30 PM

On my alternate drive that I installed windows, I can see 1 of my 2 raid 74gb raptor drives.
I see it in my bios and in my computer.

it says local disc: 0 bytes available 0 bytes used.


now Ive tried different SATA cords and also Different SATA ports on my mobo.

nothing has fixed it.

also I have tried acronis true image, and it sees that one drive however it recgonizes it as having no data on it.


any other suggestions?
September 21, 2009 9:33:32 AM

The raptors have very poor reliability so that could be it. I had two of the first 74gig raptors and the died very quickly and all the other drives sold in my area also died. I think your information is gone. BTW have you tried the western digital diagnostics tool. That might give you an answer.
September 21, 2009 3:03:38 PM

You can try r-studio, it has free demo so You can check if files are still there but to recover files larger then 64KB You will need to buy it. It has virtual RAID feature where You do not create Raid in Your bios but leave drives on their own and then create virtual Raid in R-studio and check if You can recover something.

It helped me once. I had situation where RAID 0 failed showing only "error occured" and nothing more. I built virtual RAID and recovered almost everything. After tat tested drives individually and they were fine, built a new RAID and restored all my stuff and they are still working, don't know what was wrong.

If one of the drives does not show up in bios I am afraid you are out of luck. Only way then is to send them to labarotory to take faulty hdd apart, put physical media in another hdd, copy contents bit by bit to another hdd, then try to rebuild RAID and pull off data if possible . But in this case You are looking at minimum £300 bill.
!