Sign in with
Sign up | Sign in
Your question

Vista install not recognizing RAID drive on all new build.

Last response: in Storage
Share
September 19, 2009 1:51:56 AM

I am building a PC from all new parts. The Gigabyte EX58-UD4P mobo (for Intel i7 920) has Intel ICH10R southbridge controlling 6 SATA2 ports. Have four HDDs there, which I’ve set up for RAID in BIOS per Giga’s user manual. Installing Vista, when it asks where to install, I then download the RAID driver for Vista64 from Giga’s CD (that came with mobo) (using a second optical drive on the PC). But when I tell Vista to then proceed with the install, it fails to “find” any of the three volumes visible on screen (two RAID volumes and a fifth nonRAID HDD). Could I have out-of-date drivers, with every piece of this build brand new?

Any help anyone can give would be welcome. (I've this same inquiry in to Gigabyte, but no reply yet. and my last exchange with them has reduced my expectations from that quarter.)

Here are the gory details:

(1) I have four 500GB SATA2 HDDs on SATA2_0, SATA2_1, SATA2_2, and SATA2_3 ports (see build details at bottom of email for more port info). These are for my RAID. (I also have a 2 TB HDD on SATA2_4, and two optical drives on SATA2_5 and GSATA2_6.) (Mobo user manual indicates I can put up to all 6 SATA2 ports 0-5 into a single RAID.)

(2) In BIOS, on the Integrated Peripherals screen, I set “SATA RAID/AHCI Mode” = [RAID]

(3) In the "Intel Matrix Storage manager" (accessed by ctrl-I in boot seq):

(3a) I created one RAID0 volume using the four 500GB hard drives, but using only 160GB of the net 1,863GB available. ("strip"=128KB. Volume name follows constraints: 9 characters, all alphas, no spaces or specials.)

(3b) I then created a second RAID volume on the same four hard disks, using the remaining 1,703GB. ("strip"=128KB. Volume name follows constraints: 9 characters, all alphas, no spaces or specials.)

(4) I rebooted, and began installation of Vista64 from Windows CD.

(5) At the screen that asks "Where do you want to install Windows?" I loaded drivers from the Gigabyte CD:

(5a) I have two optical SATA drives. So, I put the Gigabyte CD into the second optical drive.

(5b) In Vista installer, I browsed to the Gigabyte folder "BottDrv\iMSM\64bit".

(5c) There, Vista found "Intel(R) ICH8R/ICH9R/ICH10R/DO SATA RAID controller (E:\BootDrv\iMSM\64Bit\iaStor.inf)". I selected that, and clicked "Next". (This is the file the mobo user manual says to download at this point in the install. It also is the only file that appears in this Vista installation screen, when I click the box a the bottom to "Hide all drivers incompatible with this equipment.") This appeared to install properly (showed a progress bar for maybe 20-30 seconds, after which I saw no error messages).

(6) Back at the "Where do you want to install Windows?" screen, I chose "Disk 0 Unallocated Space 160.0 GB (total size) 160.0 GB (free space)" and clicked Next.

(7) Vista Installer then tells me "Windows is unable to find a system volume that meets its criteria for installation."

(8) I tried repeating this sequence downloading the driver set from the floppy that Gigabytes’ DOS program creates. No different.

(9) I tried repeating this sequence, but at “Where do you want to install Windows?”, I tried formatting the drive first. No help there either. I also tried at that same screen setting partition size (equal to full volume size). Also no help.

(10) My next thought is to get rid of multiple volumes in my RAID, and use Vista disk partitioning instead to create two separate drives (one to boot from Vista, and the other to boot from Windows 7, when I get it). But I don't have much hope that this will make a difference either.

(11) I did try doing the Vista install without a RAID set-up, on this exact build, and that works just fine. So the problem is definitely in the RAID driver that allows Vista to see it.
_______________
Build details:
Motherboard Model Name : GA-EX58-UD4P(rev. 1.0) (by Gigabyte)
Mobo M/B Rev : 1.0
Mobo BIOS Ver : F8
VGA Brand : nVidia Model : GTX 260
CPU Brand : Intel Model : i7 920 Speed : 2.66GHz
Operation System : Vista 64-bit SP1
Memory Brand : OCZ Type : DDR3
Memory Size : 6GB Speed : 1600
Power Supply : 750 W
Drives:
Four Seagate Barracuda 500GB 7200 rpm HDDs, all connected on SATA2_0 through SATA2_3
One Seagate Barracuda 2TB 7200 rpm HDD, SATA2_4
Optical drive on SATA2_5
(All six of these SATA2 ports on mobo are controlled by Intel ICH10R southbridge.)
Second optical on GSATA2_6
Unused GSATA2_7 port
(These last two GSATA2 ports also hang off the ICH10R, but with an intermediary the Gigabyte user manual just calls “Gigabyte2 SATA” … these are for eSATA.)
a b G Storage
September 19, 2009 2:41:21 AM

There may be 2 files to load for the raid controller.

also just use the intel matrix driver files from intel over gigabytes..
this might also fix your problem.

m
0
l
September 19, 2009 5:30:01 AM

No, only the one file. The driver already in place is the Intel Matrix Driver (see item 3 above). Though I see Intel's Download Center has a more recent version of it. I may try that. Meanwhile, I tried just eliminating the dual volume setup I was attempting in this RAID array using the Intel Matrix Driver setup utility (before OS installation). And that did the trick! Now Vista Installer has no trouble finding the drives and installing to them.

I did notice that my boot time is nothing special. I thought with a brand-new higher-end mobo, Intel i7 920, and especially a 4-disk RAID0 array (of 7200 rpm HDDs), that I would get a noticeably faster boot time. But it's about 50 seconds to the logon screen. And that's with ONLY Vista installed so far. That's about 10 seconds slower than the non-RAID system I just built from slightly less impressive components (AMD Phenom II 3-core, Gigabyte MA780G-UD3H mobo, 4 GB DDR2 RAM, booting from a 7200 rpm 320 GB HDD).

I thought Vista would load much faster (given the 4 HDD RAID0 array). Numerous tutorial websites say the base speed boost from a RAID0 (striped / no parity) array of n disks is nx. So a 4 HDD RAID0 array should be able to load the OS four times faster, "in theory." Granted "in practice" it may be slightly slower, but I should still see a boost, right? Nope, no boost at all. In fact, it's 10 seconds slower than a not-even comparable build. (That 10 extra seconds may be about the time the DOS readouts (during boot) take to run the HDD checks.)

This strongly suggests the bottleneck for bootup is NOT the HDD read rate, but is the system checks pre-OS, and the way the OS code converts from HDD storage into woring RAM code. Can anyone corroborate that with a more informed perspective?

Here is a YouTube video of a very similar hardware build to the one I'm working on here, except instead of a 4 HDD RAID0 array, he used a 2 SSD RAID0 array:

http://www.youtube.com/watch?v=hve1CkH5Z04

Before you say "Oh! Of course the SSD was way faster!" I have heard widely that SSDs are faster for true random access retrieval, but are actually slower for serial retrieval. And loading programs -- like a your OS -- is a serial read, not a random access read. I also heard from a lead tech at a large hard-core tech store who had recently tried a SSD, he said it was disappointing, for just this reason.

So, I should expect my build to be at least as fast as this YouTube build. But its not even close. He's up to desktop in 12 seconds. I only get to the logon in 50. Can I chalk that up to his build having Windows 7, vs. Vista64 on mine?

m
0
l
Related resources
a c 353 G Storage
September 19, 2009 4:38:23 PM

If planning a dual boot - vista and win7. Recommend using 2 pairs of raid0, one for vista and one for Win 7. Only connect one pair (short stroked) and install Vista. Disconnect and connect 2nd pair (Raid0, short stoked) and install Win 7. Select operating system at bootup.

I have Simular set-up. Have 4 HDD. But I set one pair up as Raid0 and loaded vista 32 bit. The 2nd pair I set up as Raid0 and as you did I short stroked using 400 gigs, using a 64K stripe, and the remainder as stripe 128K. Had NO problem installing Win 7 RC. ADDED - With Win 7 did not have to load (F6) drivers.

I have an older 965-DQ6 MB and dual boot to vista 32 bit and win 7 32 bit so your problem could be 64 bit raid driver problem ???

Using a short stoke it cut access time to 9.5 mSec (from 12.5 mSec). My 128 gig Patrot Torqx beats the short stroked WD overall. Access time is 90 x Faster (0.1 vs 9.5) and Random 4k read/writes are on the order of 10 -> 15 x faster. Seq read/writes and seq 150K are close. Seq read/writes are not near as important as files/data are not normally seq in nature. Also note that on operating system and system programs the majority of files are < 8K in size

NOT Sure, Back of my mind some boards have a problem with Raid0 using more than 3 drives.
m
0
l
September 19, 2009 9:09:30 PM

Thanks all. I found an outstanding article on Anandtech explaining EVERYTHING about SSDs - where they excel, where they don't, the wide performance gaps among SSDs, and the shortcomings of SSDs (other than price) (stutter, write speed degredation over time, and limited life): http://www.anandtech.com/storage/showdoc.aspx?i=3531&p=... ... and its update: http://anandtech.com/storage/showdoc.aspx?i=3631

This corrected my misunderstanding from my local tech guru: OS load is NOT largely a series read, but a torrent of random reads. So, the ~10x (or more) faster random access read speed of a good SSD slaps any HDD-based configuration silly. As the author, Anand Lal Shimpi, puts it, you can't reproduce an SSD's system load time no matter how many HDDs you RAID together.

So, now I know my RAID will not help my boot time much, but should help speed my video file management very nicely.

Thanks for the tip on short-stroking. Here's a nice reference on short-stroking from Tomshardware.com: http://www.tomshardware.com/reviews/short-stroking-hdd,... ... They got about 40-50% speed boost from using only the outer 10% of the HDDs.

Seems you should be able to effectively short-stroke your OS and Apps by disk partitioning, ... no? Set first 100GB of the 2TB RAID0 array as one partition, and the remaining 1900 GB as a second partition. Put the OS/Apps on the 100GB partition, and your recorded TV programs and iTunes on the 1900GB partition. Just need to make sure the partition sets the outermost physical sectors to the 100GB OS/App partition. I'll hunt around on that topic.

m
0
l
!