Sign in with
Sign up | Sign in
Your question

RAID 0 drive won't post

Last response: in Storage
Share
September 19, 2009 5:47:58 AM

Please help...

I have 2 WD GREENS RAID 0 on my system. I tried to repair a windows xp image restore on the RAID 0 sets using the windows XP installation disk. it ran fine then on reboot the RAID bios post didn't respond. now my bios (AHCI controller) won't post the drives on the Intel AHCI/RAID bios. It would freeze when it was trying to detect the drives.

I had these on port 3,4 on my onboard controller and it wouldn't post. When i move it to port 1,2 only 1 drive posted and the other would hang the RAID bios when i move it to other ports none of them post.

Any help? Thanks in advance....

More about : raid drive post

September 19, 2009 5:51:59 AM

I forgot to add i tried to repair the MBR using Microsoft Diag. tools. idisconnected the drives and went into IDE mode and rebooted then recoonected and teh drives detected fine and then tried to repair the MBR on each drive. i get teh exact same results....
a b G Storage
September 19, 2009 4:01:35 PM

> I tried to repair a windows xp image restore on the RAID 0 sets using the windows XP installation disk

Did you forget to load the RAID/AHCI device drivers
using the F6 option?


> went into IDE mode and rebooted


Try enabling RAID mode + RAID Option ROM in the BIOS
and then boot into the Option ROM to re-initialize your RAID 0.

Then, double-check the Boot Priority to make sure that
the BIOS recognizes that RAID 0 array as a discrete "device".


If your system cannot find the RAID device drivers on your
hard disk subsystem, you'll need to provide those drivers
via F6 + a floppy disk.

To my knowledge, the XP installation disc is hard-coded
to expect those device drivers to be on a floppy disk.


(Hope this helps :) 


MRFS
September 21, 2009 1:23:51 AM

Thanks for your advice MRFS! I did quite a number of things to fix it.

1. i had to delete all the MBR and partition information on the drive the bios would freeze on in non RAID mode.

2. I had to a failed raid array so then i went into the RAID bios and deleted the other drives RAID info and then created a new RAID array using the exact same information

3. when i rebooted i didn;t touch the drive except to initialize using MBR.

4. I used a deep scanner for the entire drive and sorted the partitions that i could see files and folders. (this took 10 hours) (Active@)

5. using power recovery partition i am copying my files now.

!