Sign in with
Sign up | Sign in
Your question

Dell Inspiron 531s not seeing sata drive

Last response: in Storage
Share
September 24, 2009 5:51:10 PM

I am working on a dell Dell Inspiron 531s. It is not finding any hard drive I pit on it. On boot one day it stays on the dell screen for a while. Then comes up with no bootable device. I have put a couple different sata drives on here and I get the same thing. It does see the sata dvd drive but none of the hard drives I put in so far. I have reset bios to default and pulled all the hardware one after another with no luck. What am I missing here. Thanks people.

puterdr
September 25, 2009 1:31:07 PM

The computer will only take sata so this option is set automatically. There is no option in the bios to set it. This was something I had thought about and checked already. Thanks for your input though. If I am wrong please correct me.
m
0
l
Related resources
a c 342 G Storage
September 25, 2009 1:34:15 PM

Yes, ensuring the SATA drive is set to emulate an IDE drive will make it easy for Windows XP or earlier to use it. (In VISTA this should not be necessary.) You reset the BIOS and, depending on your machine, some will default to having the SATA drive handled by the BIOS as a native SATA device. For that matter, some will default to NOT having the SATA ports enabled so they "don't exist". Make sure in BIOS that the SATA ports are enabled and are set to IDE Emulation mode. Then ensure the drive is set as one of the devices (maybe second, after the SATA optical drive) in the Boot Priority Sequence.

These SATA drives you are trying to install: are they brand new and empty? Or, do they have some Operating system installed on them already? I kind of assume they must have some OS installed, since you expect the machine to boot from them. Even if they do, unless the drive originally was in this machine and set up for it, you MAY need to do a Repair Install of your Windows OS when you get the drive recognized. This process, which requires the original Install disk, checks that all the drivers you need for this specific machine have been installed, and fixes any deficiencies.

m
0
l
September 25, 2009 2:07:59 PM

I have the disk with the vista installation that was in here before the problem started. It was cut on one morning and just said no hard drive found. Since then I have tried a empty drive as well as a drive with another vista installation just to see if it would show up and nothing shows up at all on any of them. On boot it saids SATA 0 and shows the cd/dvd. Drive 1, 2 and 3 are NONE. The dc/dvd will not boot a vista dvd or a xp cd. Boot order is set with the cd/dvd combo 1st and hard drive 2nd and usb device is 3rd and 4 is disabled. As I stated above since this computer doesn't accept ide so there are no sata settings in the bios what so ever. I just quadruple checked.
m
0
l
a c 342 G Storage
September 25, 2009 2:36:37 PM

If I get this right, the BIOS can see and use the optical drive connected to the SATA_0 port, but is never even sees any hard drive connected to another SATA port. All this is completely independent of Windows. If that is correct, sounds like you have a hardware problem.

1. I assume you already know that the hard drives you are trying to use work OK in another machine.
2. A test for a port problem. Disconnect the SATA data cable at the optical disk, and plug that into the hard drive, then try to boot into BIOS. With a known-good SATA_0 port and cable, does it detect the hard drive now? If yes, that confirms the drive is OK, and the problem is a port or cable issue.
3. Replace that data cable with the one you originally were using on the hard drive. Same test. Now, did the drive disappear? Then you know you have a bad cable. If it did NOT disappear, suspicion is on the other SATA port you were trying to use for the hard drive.
4. Reconnect almost as originally: Optical drive, with its original data cable, on SATA_0 port, hard drive with a known-good data cable on the SATA port you originally tried. If the drive still is not detected, the SATA port is bad OR is mis-configured. Try connecting to another port, or changing something about the first port's settings in BIOS.

I'm also intrigued with your statement that the Boot Priority is set to use optical first and HDD next, yet it will NOT boot from a bootable Vista or XP Install disk in that optical drive. At the very least I would expect it to boot and run from the Install disk before giving you a message that it failed to find a hard drive to use. Even if XP Install failed to boot because the optical is being used as a true SATA device (XP has no driver for this), Vista Install DOES have SATA drivers and should be able to boot and run.
m
0
l
September 25, 2009 3:45:05 PM

You are correct and that is what is throwing me off. It does see the sata cd/dvd but not any sata hard drive. Yes the hard drives I am connecting are fine. I have tried the hard drive that was in here before the non boot happened. It shows in another computer. Also the 2 other sata drives I have put in this computer don't show up either but they came from working machines. As you mentioned testing the port I did do that before posting. I switched them by reversing the ports and the dvd drive showed up and no har drive did. I tested it with all 3 hard drives.
When I boot into the dc I get the black screen showing the processor , shows the memory test and then lists sata 0 through sata 3. And shows the same things as I have already said. I get this no matter what CD is put in. It will not even boot into seatools for dos. I used that first thing to check the hard drive that was already installed.
I am perplexed to the point of a headache. I am sure you know that feeling.
m
0
l
September 25, 2009 4:42:36 PM

I found something.
OK, I had the computer to the point where the boot menu is. Just like maybe 30 times before. This time I was thinking about going into the bios and looking things over again................. I hit F1 to reboot(I have been cutting it off by hitting the power button) and I got another boot menu. This boot menu shows the dc/dvd drive. I highlighted the drive and hit enter and it started installing windows vista. BUT........... when Vista gets to the point where it asks where would you like to install Vista to , there are NO options. So it is still not seeing any of these hard drives. I have retried all of them again.
m
0
l
a c 342 G Storage
September 25, 2009 6:01:11 PM

OK, that helps. You CAN boot from the optical drive, and the SATA ports and cables are all OK, but the machine still cannot see the HDD's in BIOS.

Well, since it WAS working at one time and now is not, my next idea should be wrong, but try checking anyway. IF you have a computer / mobo with original (slower) SATA controller ports and are trying to use it with newer SATAII (faster) drives, it may not work. Some drives can pick this up and adapt by themselves. Others have to be forced into the older SATA mode. On Seagate and some other maker's drives there is a jumper that must be placed on certain pins on the back edge of the drive unit to force the older SATA mode. Even if it is there and in the right place, pull it off and re-install a couple of times to make sure the pins are clean and it has a good connection. If your drive(s) do NOT have this system, check your drive maker's website for more info. I know at least one maker used a configuration (software) setting on the drive's board for this, and you have to download a utility from them to set it.
m
0
l
September 25, 2009 6:46:17 PM

I am gonna take this route. Tell me if you agree. I pulled the drive that was in this computer and put it in another computer. Did a install of vista. It went fine. I was also able to check the drive with seagate for dos after the install while in the other pc. It said it was fine. I pulled the drive and put it back in the problem pc and I expected it to boot and blue screen but still it is saying no hard drive. There Has To Be a setting here somewhere that's not set correctly. But I cannot find it. The drive is orinnal so it should pick it up.
m
0
l
September 25, 2009 6:52:48 PM

I would also like to add that when I run seatools for dos now in the problem computer , you know how it scans to list the drives. I have done this with one and 3 diffefrent hard drives and nothing shows in seatools. I even put a hard drive in each channel and it still did not see any hard drives
m
0
l
October 3, 2009 9:26:13 PM

Ok, I am putting an end to this thread. I thank everyone for there input. I did get this computer fixed, but I went through a lot of unnecessary troubleshooting in order to fix it. I am glad however it seemed to stump some of you out there as it had me.

The Fix - I had another system come in that was 80% just like this one. The man just wanted it reinstalled. He had his CD so I decided to run his CD on this machine to see if I could get it to see the hard drive. The same thing happened, NO HARD DRIVE. So I went on and fixed the other machine. When I was done I put the hard drive from the other machine into this machine and it started to boot into Vista but blue screened and rebooted. So I cloned this drive over to the drive from the problem machine and tried it. Same thing it blue screened. Thats what I was hoping for. I booted it up a second time and this time I went into the Vista start up repair and did a repair. It booted up fine. It worked fine and I did all the Vista updates and made sure it was gonna register with microsoft and it did fine. Everything is working ok.

Still wondering - Why would it give me so much trouble. I did everything right. Vista has all the SATA drivers. I did go to Dell and download the SATA drivers but found there was no way to load them. So why would this not see a hard drive no matter what I did. There has to be a reason and an easier way to do this. If I had not goten the other machine in then I would have had to send it home like it was. I would still like to know if anyone has seen this before or has a suggestion that may help me when I get another one in that does this. And I am sure I will see it again.
Once again, thanks for everyones input.
m
0
l
November 10, 2009 8:18:21 PM

I also have an inspiron 531s and went through a very similar problem the machine would recgonize my hdd and dvd drive but always gave me a faluire to find bootable device error (after the Dell Screen) I fixed mine by making sure that after resetting my bios I made sure the SATA ports were set to be IDE compatable. Just making the point that after resetting bios you should always go to system setup and input the proper bios settings as they will often be reset to default. (a Particullary nasty virus managed to screw with my bios settings during a reboot) but I suspect for this to hapen there must be some sort of weakness in the insperion bios
m
0
l
November 10, 2009 10:01:04 PM

Thanks for the hit.
My computer has no bios setting for sata or IDE at all. That was the most confusing part of my issue. I have since confirmed this with Dell. I had a dell rep in my shop, he stops by a couple times a year see if I have changed my mind about doing field service work. I did it a while back but did not renew my contract with them. I showed him all of the notes and pictures I took of that mess and he was telling me there should be a setting as I even thought at that time. He told me page by page in the bios where the setting was ...........thanks to my cell phone I took a picture of every page in the bios. He looked at it and went............ hummmmmmmmmm............well see..............mmmmmmmmmmm..............I think.......................well no............hummmmmmmmmmmmm.............. I will get back to you. A week later I got an email from him asking me to send him a copy of the pictures. Then I got a call from a tech guy from Dell telling me that there was not a sata/ide setting in that bios. Well that I already knew.
If I could have found the proper settings then I would not have had an issue.
Plus my thinking is............If there was a setting to be set and it was set wrong. Then when I cloned the vista over to this computers hard drive and booted it up............. well it should still not see the drive because the setting was not changed. Because thats how I ended up getting it to work. I mean if there was a setting that was not set correctly in the bios ................ taking another drive from the same model Dell and putting it in this problem computer should give me the same thing. But it didn't. It booted right up into vista. Thats what gave me the idea to just clone the Vista from one to the other to get this repair done.
I am still baffled over it but the customer is happy.

Any thoughts
m
0
l
November 20, 2009 11:28:36 PM

I consider this thread closed. If no one was really able to give the best answer do I just leave the thread the way it is or is there another option other than best answer.
m
0
l
Anonymous
a b G Storage
February 8, 2010 10:55:41 PM

go into the bios by hitting F2 at start up
once in the bios goto "Advanced"
Hit <Enter> on "Integrated Peripherals"
and then Hit <Enter> on the Sata -ATA Configuration
and set it to Sata 1+2
save your bios and your drives may work.
m
0
l
Anonymous
a b G Storage
August 21, 2010 7:41:12 AM

Quote:
go into the bios by hitting F2 at start up
once in the bios goto "Advanced"
Hit <Enter> on "Integrated Peripherals"
and then Hit <Enter> on the Sata -ATA Configuration
and set it to Sata 1+2
save your bios and your drives may work.


Thank you this solved my invisible SATA drive.
m
0
l
April 22, 2011 10:46:38 PM

I tried all of this, and it still wouldn't recognize my Sata Drive.

I had the above settings (Sata 1+2) and did the following:

1. Boot up
2. F12
<message appeared about no SATA drive found, however, it was listed as boot option 1. Boot option 2 was the CD-Rom. XP Home Edition was already installed and would boot up to a virus intected XP Home Edition, so I know the drive works>

F1 to continue, F2 to enter bios appeared.

3. Pressed F1, and immediately pressed F12. (At my office I remembered I had a machine where the battery was going bad, and if I pressed F1, it would continue to load. So I was thinking maybe press F1 and then F12, it would 'get enough juice' to contine)

4. Magically I was presented with a blue screen (not a BSOD) that had the hard drive as boot option 1 and the CD rom as boot option 2

5. I selected the CD-Rom

6. Windows is now reinstalling from the CD-Rom.
m
0
l
December 20, 2011 7:00:57 PM

Quote:
go into the bios by hitting F2 at start up
once in the bios goto "Advanced"
Hit <Enter> on "Integrated Peripherals"
and then Hit <Enter> on the Sata -ATA Configuration
and set it to Sata 1+2
save your bios and your drives may work.


I know this is an old thread, but I had a similar issue recently with a Dell Inspiron 531 and I wanted to share in case anyone else searching for a solution finds this thread like I did.

My issue apparently started around the same time as an automatic Windows update a few days ago, but I'm not certain if there is any connection.

My particular problem could not be resolved with any of the ways listed here (or many others that I tried). In the same "Integrated Peripherals" settings, I had to disable RAID entirely. Once I did that, everything worked. Of course, now I am operating on a single disk instead of RAID 0, but I can try to re-enable that later. For now, I can get to my data and do what I need to do.
m
0
l
!