Sign-in / Sign-up
Your question

How to run CHKDSK on logical partition of my Hard Drive in XP

Tags:
  • Hard Drives
  • File System
  • Partition Magic
  • Windows XP
  • Storage
Last response: in Storage
September 25, 2009 4:22:26 AM

Hi,

I want to fix the error 2003 of partition magic. It started when I wanted to reallocate disk space of my c drive which is NTFS file system. But my other logical partitions are in FAT 32 file system. So when I gave instructions to my partition magic software an error happened. I did not know earlier that I was supposed to change the file system first.

Can be mentioned here that later I changed my logical partitiona to NTFS.

But now I am facing this problem. My windows XP is showing all my directories except my 1 logical directory, which is called F;, or Download (F:) .

This directory is not showing in My Computer. But when I am opening my partition magic software, I can see my Download (F:)  directory. I can even browse my directory. But in my partition magic software this directory is not labeled. That is, it is only showing as Download, but without the letter F. Can be mentioned here that F: is my Download directory. Also the path is showing as : Download (\\.\disk1.part4\).

I also visited couple of places in the internt. Some said the problem will go away if you run Chkdsk. I did that, but the problem is still there. Every time I am running this chkdsk, its only checking my C: drive, nothing its doing on my logical drives. that is its not checking my 5 Nos. of drives.

Now, can anybody help me how I can run this chkdsk on my logical partitions, that is on my other directories. And can anyone help me how I can fix this problem of error 2003 of partition magic, so that I can save my F; logical drive and can see that drive in My Computer.

Thanks
Kamrul

More about : run chkdsk logical partition hard drive

September 25, 2009 4:36:30 AM

start/run/chkdsk press enter

I didn't have time to read all of your post but this will run check disk.

To manually do this you can right click on the hard drive icon, go to properties, tools, error checking and you will notice the drive letter will be in the title bar of the window you are working in. Check both boxes and select start. This will make two passes and will be done. You will have to do this manually for each drive you want to check...
m
0
l
September 25, 2009 7:00:11 AM

Hey Enlandr,
Do you have any idea how to fix this error : Error # 2003. File size does not match FAT allocation for file.

My partition magic is saying this error and it started when I tried to allocate space to my NTFS Primary Partition from FAT 32 Logocal Partition.

I should have at first changed my logical partition to NTFS file system before commanding my partition magic software to allocate spaces to my C drive from my D, E F, G and H drives. When I learned it was too late.

Now I have changed my drives to NTFS except my F drive. My F drive is in my hard drive at present, because it is showing in partition magic software. I can see it and all the folders. But I cannot see it in my XP/My Computer.

And whenever I am trying to run chkdsk on F, the following error is showing : Cannot open volume for direct access.

I have run chkdsk to my C drive and to all my other logoal drives, that is, on D:. E:. G:. and H:.

So now can anyone help me how to solve this problem of error 2003 and how I can revive my F drive to my XP.

The full path in my partition magic of my F drive is showing like : \\.\disk1.part4\ and also as : Downloads (\\.\disk1.part4\). Can be mentioned here that Downloads is the name of my F: drive. But the alphabet F is not showing in th partition Magic software window.

Thanks
Kamrul
m
0
l
Related resources
September 25, 2009 1:41:29 PM

Hey Evrybody,

Boy O Boy, I started with this problem early in the morning and I got it solved during this evening. Boy am I happy now. And for that I am going to enjoy that with you guys. Because this sort of prob can happen with anybody.

OK. you got to read my earlier post for getting the taste of my problem. Now here is how I solved the problem. As I mentioned in my early post that the problem occurred when I tried to allocate more spaces to my primary partition ( that is the C drive and which is in NTFS File System) from the idle spaces of my Logical Partitions, all of my 5 logical partitions are in ( or more actually were in ) FAT 32 File System.

So when I fired up my Partition Magic Software to do the above job without changing my logical partitions from FAT 32 to NTFS File System, BAM.... after, several minutes the Partition Magic Software showed Error No. 2003 and gave me messages like could not complete the job. And when I restarted my compu, BAM... my drive F is gone from " My Computer". I was so worried. Then i checked with the Partition Magic software about the standings of my HD and I am lucky there seeing my F drive. Then I thought that even though my XP is not showing the F drive but the Partion Magic is showing the drive. Somehow my HD got stuck and could not show the F drive.

I was trying to figure it out what went wrong and starting to write in forums. I wrote to 5 forums about my problem and searched Google, still could not solve the problem, but I was making progress bit by bit. Finally Viceman Did It Up. Hey buddy thanks a lot. You really made my day.

Here is the solution he gave me : Open Device Manager ( select-Run-Devmgmt,msc) and right click on the problem drive. ( I clicked on my Hitachi HD icon ). and uninstall it. Reboot and window should reinstall the drive. Now open Disk Management ( Right click My Computer, click Manage(r), click Disk Management), right click in the drive, import the foreign drive or assign it a drive letter or do whatever you can with it. If you still cant do anything with the drive, try reinstalling your chipset driver and doubly check the BIOS setting. I like to point it out that I solved the problem without doing the chipset driver reinstalling thing.

Thats the way I solved my prob.

Thanks Viceman again.
Kamrul
m
0
l
September 26, 2009 3:21:14 AM

Great to see you got it fixed, congrats!
m
0
l