Sign in with
Sign up | Sign in
Your question

WD VelociRaptor extremely slow transfer rate

Last response: in Storage
Share
Anonymous
a b G Storage
September 25, 2009 6:11:27 PM

Hi,

I have 3 SATA drives and 1 ide drive connected.
SATA:
- 2x WD 1GB
- 1x WD VelociRaptor 300GB (system hdd)
IDE:
- Maxtor 200GB

I freshly re-installed the Windows XP and for few days, everything was working fine.
After few days the Windows boot starts to last about 3-4 minutes and my computer is working slow.

I ran the HDD tests in HD Tune and figured out, that my VelociRaptor has only about 4 MS/s transfer rate, what is extremely low.

Any suggestions what is wrong?

Thanx, Mike
a b G Storage
September 25, 2009 6:51:36 PM

My guess would be that something else is trying to access the drive at the same time as you are trying to. That would cause it to slow down a lot. Is your hard drive activity light on all the time?
Anonymous
a b G Storage
September 26, 2009 5:50:30 AM

nope is not, the same problem is in safe mode. may i need a special driver for VelociRaptor HDD or change special setting in BIOS?
Related resources
September 26, 2009 8:37:00 AM

no, if you have ICHI mode in BIOS not. You can install an xp to the other disk (having raptor not as system disk) and check again the raptor with HDtune. If you have now the same transfer rate, then raptor is kapputt!!
and changing will be not a problem with WD.
a b G Storage
September 26, 2009 10:27:29 AM

What does the HDTune plot look like? Can you post a screenshot?

September 26, 2009 11:49:28 AM

Hi! Disconnect the IDE disk drive and then restart your system. Also check if you have DVD drive connected on IDE cabel not sata.
Anonymous
a b G Storage
September 26, 2009 12:58:32 PM

Hi, so, all disks are SATA, i thought one was IDE.

I tried to install Windows on another drive, and after that, VelociRaptor HDD was working just fine. But thats not a solution, because i bought Raptor as a system drive.

So something in my system is slowing it down, cant figure out what
September 26, 2009 3:43:31 PM

Quote:
Hi, so, all disks are SATA, i thought one was IDE.

I tried to install Windows on another drive, and after that, VelociRaptor HDD was working just fine. But thats not a solution, because i bought Raptor as a system drive.

So something in my system is slowing it down, cant figure out what


tell us some infos
Motherboard, sata controler, xp sp2/3, 8GB Ram ?
bios setting: AHCI mode or ide ? has to be AHCI
XP has old sata drivers better is vista.
you have to update the sata drivers from motherboard manyfactory
and the bios too
(for xp you have to use f6 during installation and floppy disk with the new sata drivers !)
Anonymous
a b G Storage
September 26, 2009 4:28:16 PM

lma111 said:
tell us some infos
Motherboard, sata controler, xp sp2/3, 8GB Ram ?
bios setting: AHCI mode or ide ? has to be AHCI
XP has old sata drivers better is vista.
you have to update the sata drivers from motherboard manyfactory
and the bios too
(for xp you have to use f6 during installation and floppy disk with the new sata drivers !)


Here is some more info as you requested:

1.
Motherboard P5Q Series
Sata Controler – Marvell 61xx RAID Controller
XP Profesional sp3
4GB Ram

2.
My setting is IDE and working fine with system on other HDD with it. When I change it to AHCI, Windows on VelociRaptor keeps restarting when booting …

3.
Did upgrade Sata drivers for motherboard

4.
Didn’t update Bios, because it was working fine. Again, the HDD was just fine for few days, after that it is slow as never.

5.
Didn’t pressed f6 during XP installation, because I didn’t have to. Don’t have floppy disk drive anymore anyway.
September 28, 2009 7:23:29 AM

2.
My setting is IDE and working fine with system on other HDD with it. When I change it to AHCI, Windows on VelociRaptor keeps restarting when booting …


Having this setting in BIOS: sata mode: AHCI, try to install now a new xp on VelociRaptor. I hope sp3 have the AHCI sata drivers (otherwise you need a floppy disk with these drivers (donwloading from asus P5Q page) and typing f6 while installing the system, when you see that in display). If you have no problems with the installation you are working now in AHCI mode and have all the features of Sata: NCQ, hot swap, better transerates etc..
..and now having AHCI mode you can test again the transferrate of your Raptor.

Maybe you can install the AHCI sata drivers in your old system. You have to consult the motherboard manual (Howto install AHCI sata drivers after installation (post install)) or doing a google searce. With some gigabytes board that is possible otherwise you have to install a new system as described above.


Good luck
a b G Storage
September 28, 2009 1:40:08 PM

XP does not contain the drivers for AHCI settings. You must provide a floppy with the correct drivers during install.
You cannot install XP in one mode (IDE mode or AHCI) and then change it later, you must install it the way you want it.
Did you load the motherboard drivers after the install? It simply sounds to me like the drivers are not installed. My WD 1 TB drive will do the same thing if drivers are not installed, show a transfer rate of about 5mb/s.
The only difference in IDE mode, and AHCI mode is (besides the drivers of course) AHCI mode will allow you to support NCQ, and Hotswapping. There is very, very little speed difference in the 2 settings. So if you are only getting 4mb/s, that tells me that either
A: the drive is bad (unlikely)
B: you do not have the correct driver loaded for the SATA controller, whether it be AHCI mode, or standard IDE mode.
Reinstall all your motherboard drivers.
!