Sign in with
Sign up | Sign in
Your question
Solved

New DVD/CD Writer not reading DVDs or CDs

Last response: in Storage
Share
September 29, 2009 1:41:40 PM

I just built a new PC 4 days ago which included a new Samsung Black 22x (SH-S223B). After the build I powered it up and was able to use the DVD drive to install Windows 7 RC. After that, I was able to install Office 2010 tech preview also from a DVD.

Yesterday I threw in my motherboard DVD to make sure I had the latest set of files installed and the DVD couldn't be read. I tried two other DVDs and finally a music CD and none worked. Each time I popped it in I could hear the drive spinning, and the light flashed on the front of it, but nothing would happen. Eventually I would try double clicking on the DVD drive in windows explorer, but it would pop-up a message telling me to insert a disc.

I updated the latest firmware from samsungodd.com this morning. But the same issues still occurred. Of course when I check on the drive and its drivers in Device Management - it displays the correct name for the drive and tells me that everything is functioning properly. It also says it is using a (generic?) windows cdrom driver. I expected that to change since I updated the latest firmware but maybe driver <> firmware?

I have done some research and found other places where people suggest that this can happen if the drive is plugged into the wrong SATA port on the motherboard or the BIOS is setup wrong, but they didn't explain why or what the correct settings are so I didn't know what to try here. My motherboard is the Gigabyte GA-P55M-UD2, by the way.

I appreciate any help or ideas you have.
a b G Storage
September 29, 2009 4:33:19 PM

Try a different color SATA port, like suggested.
m
0
l
a b G Storage
September 29, 2009 4:55:06 PM

I have that problem on a GA-EP45-UD3P. I am waiting for a bios update to fix the problem.
m
0
l
Related resources
September 29, 2009 7:31:47 PM

Most of these recommendations are for the problem where CD/DVD Drive is 'missing'. Not the same as my problem where it just won't read a DVD or CD. But some of the tips are for not being able to read so I'll certainly give those a try. Thanks.

Which problem are you having? Is it the exact same as mine: the DVD/CD player shows up in Windows, but when you insert a DVD/CD it doesn't find anything? How do you know it's a BIOS problem, has Gigabyte acknowledged as much?
m
0
l
September 29, 2009 11:47:08 PM

There's a place in the Device Properties where it says "Current Region: Not Selected". Do I have to pick a region? Could that be my problem?
m
0
l
October 5, 2009 1:44:26 PM

I returned my Samsung (TSSTcorp) SH-S223B and picked up another one. Interestingly, outward appearance/label looked slightly different. I had taken a picture of the first one but it proved too blurry to compare the finer details. Main details (as I remember them) match, so maybe I'm wrong. Then the inside drive tray seemed cheaper and there are "holes" in it that I'm sure weren't there before, so maybe they are at least a little different. Not that it matters.

I cannot get this drive to work either. I tried changing the Sata port it was plugged into. On my GA-P55M-UD2 the HDD is in SATA2_0. The DVD drive I originally plugged into SATA2_1. I moved it to the SATA2_2 connector. Still didn't work. I also upgraded the firmware from SB01 to SB02. I even picked a region - it came as "No Region", I changed it "Region 1". None of these changes worked. I even played with some of the BIOS settings for IDE Legacy vs. IDE Native mode, granted it was approaching 1 am and I'm not exactly sure what these settings should have been doing anyway. In the list of connected devices the HDD is showing up as Master 0, and the DVD drive is showing up as Slave 0.

Anybody have any other ideas what could be going wrong?

Also, I tested with a CD that contains a bunch of digital photos, the boot DVD I used originally to install the Windows 7 RC OS I'm running, and a store-bought DVD movie. I had previously tested with a store-bought music CD but did not repeat that test with the new drive.

In all cases the DVD drive light flashes for a minute or two with nothing ever happening or showing up under the DVD Drive D: in Windows Explorer. If I double click the DVD Drive, the drive ejects and it asks me to "Please insert a disc".
m
0
l
October 6, 2009 4:02:03 AM

Clarification: the BIOS change I mentioned earlier was to the SATA Port 0-3 Native Mode. It was originally set to Enabled. I changed it to Disabled. When that didn't work I changed it back to Enabled.


Is it possible I've just had the (bad) luck of the draw and ended up with 2 bad drives?
m
0
l

Best solution

October 9, 2009 4:53:50 PM

Well I returned the second DVD drive. This time I picked up a Sony Optiarc 24x. Took it home, plugged it in, and it ran. No issues with an install disc or a burned music CD. So far so good.

Guess the store had a bad batch of Samsung Black 22x's?
Share
!