Sign in with
Sign up | Sign in
Your question
Closed

New drive very, very slow

Last response: in Storage
Share
October 2, 2009 4:13:41 AM

Hi. I just bought a (generic) 500GB IDE disc from Amazon - it had lots of good customer reviews - to be used as a slave drive (XP SP2) for backup. but I notice that the performance is very poor: videos played from this drive stutter and freeze up for several seconds, especially when trying to 'fast forward'. The same video doesn't have the same problem when read from my master drive.

So I downloaded a couple of HD speed tests - DiscSpeed32 shows my master drive read speeds at c.35 MBytes/sec, average, whereas the new slave drive comes out at barely 2 Mbytes/sec. DiscSpeed32 also shows CPU usage: the master shows c.10% during the read test. The new drive the CPU shows at 99%, so the responsiveness of the PC plummets of course. Something's clearly very wrong. Is the drive definitely faulty or might there be something I can do before I have to return it? Drive properties show DMA as DMA 2 - switching to PIO doesn't help (why would it?!).

The disk has been defragmented BTW..

Thanks,

Martin

More about : drive very slow

a c 107 G Storage
October 2, 2009 5:06:57 AM

Hmmm sounds like you might have a lemon. All I can think of is check the jumpers are set correctly and maybe try new cables. I personally would never ever buy a generic HD. Sounds like a data loss headache waiting to happen lol. :non: 

As SATA drives are cheaper and easier to find than IDE ( last time I looked anyway ) you can get a PCI card that will let you run SATA drives on an older MB for around $15. I had one on an old P4 box.
Score
0
a c 415 G Storage
October 2, 2009 6:37:29 AM

Your new drive must be running in PIO mode instead of DMA mode - that's what causes all the CPU utilization. See this Microsoft article.
Score
0
Related resources
October 2, 2009 10:35:31 AM

But as I say, the drive is shown as using DMA 2. I'm using the same cable as with the drive I just replaced, and that worked fine.
Score
0
a c 127 G Storage
October 2, 2009 11:07:59 AM

Quote:
The new drive the CPU shows at 99%, so the responsiveness of the PC plummets of course.

No! It shouldn't even with high CPU usage. The reason why in PIO problems the performance is so bad, is because this isn't just "normal CPU usage" - the CPU is being flooded with something called as interrupt; PIO mode will drop in and say to the CPU "stop whatever you're doing i'm more important". The result is choppy behavior even from your mouse which is unusual. The only reason is that the CPU is being interrupted to many times, when doing I/O using PIO.

So if you mouse is choppy and the CPU usage very high, there's a good chance you're either affected by the PIO issue sminlal said, or some similar driver interrupt issue. I suspect the former.
Score
0
October 2, 2009 11:24:41 AM

So, the $64,000 question: what can I do about it? According to Device Manager DMA is enabled on the drive, but you are saying that it is running in PIO mode even so?. Reviews of the drive by other purchasers on Amazon say theirs reads/writes fast, and that it has proved more reliable than previous 'famous brand' names they have owned (a matter of luck I'd say), so I didn't feel I was buying anything at all suspicious: did I get a dud one then? If so, maybe exchanging it will resolve the problem, or am I always going to get the same thing with this particular drive for some obscure reason?

I'll do an internet serach, but ido you know of some way I can test whether the drive is really running in DMA or PIO mode, despite what Device Manager is telling me (does it always report the truth?)?

Thanks,

Martin
Score
0

Best solution

a c 127 G Storage
October 2, 2009 11:30:59 AM

Any disk will suck at PIO transfers; its most likely not the disks' fault.

You can try running (and completing) a HDTune benchmark, it will display raw speeds and also CPU utilization. If this is a flat line of no more than 14MB/s (the maximum PIO speed) and near 100% CPU utilization (50% for dualcore; 25% for quadcore) - then its pretty much a PIO issue for sure. :) 

To fix it, deleting its IDE/SATA controller from device manager will reset the controller to use DMA mode again. So after you've confirmed you've got a PIO issue, find your controller in the device manager list and delete it (hit the DEL key). It will find it again when you reboot, and reset it so it uses DMA again.

This may also be caused by bad cabling; so if the issue persists i would replace the HDD data cable.
Share
October 2, 2009 11:39:15 AM

I'll try that and post back when I can with results. (The cable works fine with the previous drive, no performance issues, but I can try a new one anyway of course).

Thanks!

M.
Score
0
October 2, 2009 1:50:56 PM

Yes, the situation was exactly as you said when I ran HD Tune - a flat line of c.13MB/sec. I realise now that when I said that the disc was marked as running in DMA mode, I'd stupidly looked at the Secondary IDE channel instead of the Primary. When I looked again I saw that the 2nd. drive on the Primary channel was indeed marked as PIO mode.

So I deleted the primary channel in Device Manager, as you said, and rebooted twice. HD Tune now reports 60MB/sec and Device Manager shows the drive on DMA Mode 5.

Thanks so much for this. You're a hero!!

Martin
Score
0
a c 127 G Storage
October 2, 2009 10:00:09 PM

Cheers! :) 
Score
0
a c 87 G Storage
October 3, 2009 5:11:18 PM

FYI:
I had something similar just "happen" on several computers where speeds were much slower.

The problem was solved by going into the Device Manager and removing (right-click... ) the Controllers and rebooting. In every case everything was fine.

This solution probably would have worked for you too.

I recommend running HDTune every month or so and if you get a problem do the above steps.
Score
0
a c 127 G Storage
October 3, 2009 5:34:14 PM

By deleting the IDE controller it will try to use DMA instead of PIO transfer, so your issue may have been the same.

In fact, the PIO issue is quite common and Microsoft should have done more to prevent users running under PIO while their hardware is just fine. PIO is an emergency fallback solution; one step above having no communication with the harddisk at all.
Score
0
a c 415 G Storage
October 3, 2009 6:26:20 PM

sub mesa said:
In fact, the PIO issue is quite common and Microsoft should have done more to prevent users running under PIO while their hardware is just fine. PIO is an emergency fallback solution; one step above having no communication with the harddisk at all.
I know why they do this - they're taking the paranoid attitude that if communication with the disk using DMA was flaky at *any* time, then they don't want to risk possible data corruption by using that mode.

But I agree that it's a royal PITA. It would be nice if they did something to make it easier to discover and reset, such as having something like the "your USB device is running slower than it could be" pop-up that has a "fix" pushbutton.
Score
0
a c 127 G Storage
October 3, 2009 9:03:09 PM

Hm, it should be possible to disable write buffering (the DRAM chip located in the harddrive itself) while still having DMA enabled, to achieve the same effect.

It also comes without any warning message, such as one of those balloons popping up with a message like "Your harddrive C: is running in low-performance mode after a timeout has occured. Click here for more information" - at least something to use google on, some message that is familiar and easy to diagnose.

In some cases, people may just think their computer is old, and buy a new one. While their problem was just the PIO issue....
Score
0
October 18, 2009 6:50:46 PM

Oh dear, not solved I'm afraid. The DMA mode stuck for a while, but now I notice the same symptoms as before. The disc drive is stuck in PIO mode and this time deleting the IDE primary drive entry in Device Manager (and rebooting twice) doesn't help - the drive is still shown in PIO mode (with DMA if available as the choice).

Does this indicate a fault with the disc, or with the MoBo/DMA controller. Where do I go from here?

Thanks.

Martin
Score
0
October 18, 2009 6:52:25 PM

(I'll try a new cable, but if that doesn't help??)..
Score
0
a c 415 G Storage
October 18, 2009 7:26:57 PM

I'm betting on the new cable - let us know if it helps.
Score
0
October 18, 2009 7:38:01 PM

Will do ..
Score
0
October 20, 2009 8:18:10 PM

Installed the new cable - still the second hard drive is in PIO mode. I can force it to DMA by various registry tweaks and the like Or deleting the Primary IDE channel in Device Manager, rebooting twice, setting the drive to PIO, rebooting; then reset the drive to DMA if available, rebooting again), but it's only a matter of minutes or another reboot and I'm back to PIO.

I installed a spare disc in place of the 'nuisance' one, on the same cable (should the Master disc be on the end of the cable or on the middle connector by the way?) and that shows DMA Mode 6 fine.

So can it be the disc itself that's at fault then? I didn't think the cause of a disc refusing to go to DMA mode could be the disc itself, but probably I was wrong? If so, does anybody else have to return some 50% of the PC stuff they buy as faulty (and most I don't get from eBay! - or am I just jinxed? I am sick of it frankly. I sometimes think I should ditch all my PCs and take up origami or something instead.

Hmm, sorry about that - just need to know about the current disc really! Do I return it for a replacement (more postage costs!!) :-)

Thanks,

Martin
Score
0
a c 415 G Storage
October 21, 2009 1:02:33 AM

Well if a cable swap doesn't solve the problem and a disk swap does, then it kind of points to the disk drive. I'm wondering if it's got some suspect sectors and is causing timeouts when it has to do error recovery... perhaps you could plug the drive in and check it's SMART statistics using a program such as DiskCheckup.
Score
0
October 21, 2009 7:17:45 AM

Hi. Downloaded Active Smart to check the status of the disc. The programme of course shows the performance as Low (as far as the scale goes to the left!), but all the SMART lines show the SMART status as OK. Disc health shows as 100% good..

============================================================

S.M.A.R.T. status
Date: 2009/10/21 08:15:52

Model Name: MD05000-BJBW-RO
Serial number: MW0WCAPW1046428
Capacity: 500.1 GB
Firmware: 00.02N00
Drive interface: IDE
Current temperature: 26 °C (78 F)

------------------------------------------------------------------------------------------------
Attribute Name Threshold Value Worst Raw value
------------------------------------------------------------------------------------------------
1 (01) Raw Read Error Rate 51 200 200 0
3 (03) Spin Up Time 21 167 167 6625
4 (04) Start/Stop Count 0 100 100 119
5 (05) Reallocated Sectors Count 140 200 200 0
7 (07) Seek Error Rate 51 200 200 0
9 (09) Power-On Hours 0 100 100 302
10 (0A) Spin Retry Count 51 100 100 0
11 (0B) Recalibration Retries 51 100 100 0
12 (0C) Device Power Cycle Count 0 100 100 113
187 (BB) Reported Uncorrectable Errors 0 100 100 0
188 (BC) Command Timeout 0 1 1 519698972794
190 (BE) Airflow Temperature 0 74 56 26
192 (C0) Power-off Retract Count 0 200 200 37
193 (C1) Load/Unload Cycle Count 0 200 200 120
194 (C2) Temperature 0 124 106 26
195 (C3) Hardware ECC recovered 0 1 1 136269337
196 (C4) Reallocation Event Count 0 200 200 0
197 (C5) Current Pending Sector Count 0 200 200 0
198 (C6) Uncorrectable Sector Count 0 100 253 0
199 (C7) UltraDMA CRC Error Count 0 200 200 0
200 (C8) Write Error Rate (Multi Zone Error Rate)51 100 253 0
------------------------------------------------------------------------------------------------

I'm confused. Maybe there is a problem with the motherboard??? I'd need to test the drive in another PC, but not sure how I am going to do that for the moment (all my other 'PCs' are laptops..

Martin
Score
0
October 21, 2009 7:18:46 AM

Er the columns didn't come out, but you can see the values (inasmuch as they mean anything to me). All the lines end 'OK'.

M.
Score
0
a c 127 G Storage
October 21, 2009 11:34:20 AM

The SMART data is good. If you were having a bad cable, the UltraDMA CRC Error Count should not have been zero. Look at the raw values instead of those "threshold" values which are not that meaningful.

Quote:
this time deleting the IDE primary drive entry in Device Manager (and rebooting twice) doesn't help

Are you sure you uninstalled/deleted the controller, instead of the actual drive? The controller has tabs in the properties screen which display the configured and actual transfer mode (PIO or DMA). Could you give us a screenshot maybe?
Score
0
October 21, 2009 11:47:53 AM

Hmm. In Device Manager, I have IDE/ATAPI Controllers (I'm not deleting Disk Drives entries, if that's what you mean) and under that, firstly "NVidia MCP2 IDE Controller" and then "Primary IDE Channel" and "Secondary IDE Channel". I have been deleting the Primary Channel, with the two hard drives. Should I be deleting the NVidia controller entry?? I haven't tried that, it's true. Not sure what that entry is to be honest.

I just tried something else. I swapped the primary & secondary IDE inputs on my m/B. Rebooted, and for a second I thought I'd found the problem - the new drive was in DMA Mode 5. But another reboot and it was back to PIO. So I swapped back to how it should be (booting up is very slow with the channels reversed) and now the new disc has been showing DMA Mode 5 for 15 minutes or so. I'll leave it a while before rebotting, when I am fairly sure (judging by the past week on this) it will go back to PIO - I haven't done anything to 'fix' it, so why would it not?

The last stage is for me to borrow my mother's PC and fit the new drive in there and see if I get the same problem, but her PC is so inaccessible I'm dreading it! :-) (I'll wait for your response re. the NVidia controller first! Thanks again for your help).

Martin
Score
0
a c 127 G Storage
October 21, 2009 3:33:51 PM

Try to delete the nVidia controller entry in Device Manager also. And yes you appear to did it right, by not deleting the disk volume itself but the controller instead. It just might be that you need to delete that nVidia entry as well. It should be safe to remove all three of them (primary/secondary/nvidia) and let windows find all three again after reboot.

Also, if you continue to have issues, please double check the cable + power plug. They should be of high quality and low quality cabling can cause just this problem. Especially if after running in DMA mode the transfer mode falls back to PIO again; that is caused by a timeout on the device not by itself.
Score
0
October 21, 2009 7:43:09 PM

Yes, I don't want to send the disc itself back because I really don't think it's the disc that's at fault. If I get problems, I'll take this disc out and try it in another PC. For now, it has been running in DMA mode all day - not sure why, I just removed the cable (it was a new one bought yesterday for the purpose) and plugged it in again - but I've done that a dozen times this week, checking the pins are seated properly.

I'll try delting the NVida entry, but it will then ask me to reinstall the driver and for now I have no idea where the driver may be - have to search online first.

M.
Score
0
October 22, 2009 12:34:57 AM

Deleted the Nvidia controller & both channels. Rebooted. XP finds all three & reinstalls them. Primary Channel, 2nd. device, still PIO. Select PIO for that device, reboot, twice. Then select DMA if available, reboot. It's still in PIO mode. :fou: 

I can only assume that the drive itself must be the cause. I will bite the bullet and install it into my mother's PC tomorrow (which has onbly one HDD) - as I say, since the other PC is so inaccessible (my mother prefers 'tidy' to 'convenient'), it's going to be a pain, but if the drive is PIO there, I think that will prove that it is the culprit.

Martin
Score
0
October 26, 2009 7:05:42 PM

An update: the drive maintains DMA Mode5 until I reboot, when it reverts to PIO. Hibernating in between PC use doens't kill the DMA mode, so that's what I do for now.

I downloaded a script which forces DMA on all drives, so if I run the script and reboot, I usually get DMA again, uintil the next reboot.

All very odd: I haven't tried the drive in another PC yet, which may tell me whether the drive itself, or the M/B (etc.) is at fault,. I will do at some stage in the not too distant future..

Martin
Score
0
a c 415 G Storage
October 26, 2009 10:35:30 PM

This is probably a long shot, but I wonder if the drive is configured to use a delayed spinup and the OS isn't able to communicate with it right away during boot? You could probably tell by putting your hand on the drive while powering the machine up to see if you can feel it spinning up or not.
Score
0
October 27, 2009 9:20:49 AM

I'll have a look!

M.
Score
0
October 30, 2009 9:32:41 AM

The disc seems to spin on startup. But oddly, the past few days I have rebooted the PC, the disc always comes back in DMA Mode 5, according to Device Manager. Well, so much the better, but I am no nearer to finding out whether the problem is with the PC or the drive. I will have to put it into the other PC at some stage and see what happens, though, as I said, given how inaccessible the other PC is, it's going to be a bit of a pain and so I've not actually tried it yet..

Martin
Score
0
November 17, 2009 2:28:24 PM

Weeks of frustration - I'm returning the drive.

Score
0
December 20, 2009 2:27:44 PM

Just to round this up, the new drive is fine. I had returned the faulty drive to the supplier (via Amazon) who sent me a 'replacement' (without any reply to my various emails) in the shape of the old, faulty drive now repackaged as if it were a fresh one. Crooks! Luckily I'd made a mark on the side so recognised it. Amazon got me my money back, and I got a Western Digital drive from somewhere else: I still have the original faulty drive, not that I am using it now of course. Any suggestions? (Use it as a replacement brick and throw it through the original vendors window perhaps?). :-)

Martin
Score
0
February 23, 2012 9:48:30 PM

This topic has been closed by Mousemonkey
Score
0
!