Sign in with
Sign up | Sign in
Your question

Drive shows up in Device Manager, but not in Disk Management

Last response: in Storage
Share
October 3, 2009 8:50:31 PM

I have a drive that I took out of a Panasonic Toughbook Laptop. These laptops have built-in encryption so the drive cannot be read if the laptop is stolen. I don't believe there is anything special about this drive because the encryption is handled by the bios of the laptop. I just bought a regular old 160GB laptop drive and put it in the laptop and it worked fine.

After removing this drive from the laptop I figured I could connect it to my PC and delete the encrypted partition, reformat and use the drive. The problem is the computer can't see it. It does get recognized in Device Manager, but going to Disk Management does not show the drive. I've tried to hack the registry and remove all the used drive letters and still nothing. I can plug in any other usb drive and it works fine. Any ideas?

As an aside, I plugged it into a Mac and it doesn't show up there either. This is very strange.
a b G Storage
October 3, 2009 9:20:43 PM

This is just an educated guess, OK?

The Panasonic Laptop may have a controller and/or device driver
which altered the low-level formatting.

The BIOS in your PC sees that HDD because the BIOS only
wants to know if there is a device out there,
using basic Plug-and-Play protocol.

Your BIOS obviously does not care what type of
low-level formatting is present. If it cared,
your BIOS would probably not see that HDD either!

Now, step up to a higher level into the XP Disk Management
task: now, that task DOES care about the presence or
absence of low-level formatting.

And, if it does NOT recognize the exact low-level formatting
which your Panasonic controller and device driver left out there,
Disk Management will never recognize such an alien low-level format:
it may as well be "geek greek".

So, my best "guestimate" is to suggest that you contact Panasonic
to see if they have software which will wipe that low-level format
and reformat it "vanilla" -- so it will Plug-and-Play nice on a vanilla PC.

You may need to re-install that HDD back into your Panasonic Laptop,
in order to wipe that encrypted low-level formatting and replace
it with "vanilla" low-level formatting.


Put differently, the encryption is doing EXACTLY what it was intended to do --
by design!!! Thus, you had better turn on the charm with Panasonic,
because I would immediately suspect that you are a hacker -- or a laptop thief --
if I answered your Tech Support telephone request. :) 

You saavy now?

(Read: they have probably already had 1,000 or more telephone calls
requesting technical assistance with the very same "problem".)


MRFS

m
0
l
a b G Storage
October 4, 2009 4:14:58 AM

I'd have to agree it's probably a different low-level formatting (probably with the first few sectors altered) made by the Toughbook as well.

I'd also suggest the following:
1. Plug it back into the Toughbook and get it to remove then format the HDD into a 'vanilla' drive.
2. It's been a long time since I've done low-level formatting (not sure if it's possible with today's HDD), but you could try go to the HDD's manufactures website and see if they have a utility that does low-level formatting for their drives.

I've also heard there are paid utilities that can low-level format many different drives from different HDD manufactures.
m
0
l
October 4, 2009 5:59:52 AM

Thanks for the info. There's no way I'm sticking this back in the laptop because it was such a HASSLE. I've done a lot of drive swaps in laptops before and this one takes the cake. Even more of a pain than a MacBook Pro.

Anyway, I did try plugging it into the Panasonic through the usb enclosure but that didn't work either. I'll probably just dump the drive. It's only a 60GB drive anyway.

Thanks.
m
0
l
Related resources
!