Sign-in / Sign-up
Your question
Closed

Vista & Microphone Echo Problem

Tags:
  • Sound Cards
  • Microphone
  • Windows Vista
  • Components
Last response: in Components
July 29, 2008 11:29:02 AM

Hello

Here is my problem: I recently had a new sound card installed on my computer (Sound Blaster X-Fi Xtreme Audio), running Vista Home Edition, and consequentially purchased a new headphone/microphone to use with this new card. I mainly use the microphone with games and Ventrilo. What is happening is that as soon as i plug in my microphone jack, i can hear myself everything i do in my headphones. When i unplug the microphone the headphones still work, and i can hear everything fine, such as music and other noises, so i believe that the problem is originating with my sound card and the microphone.

I have played around with everything in control panel's and have run several diagnostics, to no avail. Any help in this manner would be greatly appreciated.

Additionally, i purchased the Ritmo ST-860WM headset, if this is of any further help.

Thanks much

More about : vista microphone echo problem

July 29, 2008 12:05:04 PM

there is a checkbox somewhere that turns that off, i think it is vista rather than creatives panel. under advanced, but my computer is down so I can't help u find it. I remember unchecking it once.
July 29, 2008 12:06:13 PM

Thats called Feedback. There is a setting either in windows, or your soundcard drivers, that lets you turn that on and off. Check the microphone audio settings and check or anykind of loop or feedback option that may be checked.

That should fix any problems.

-PM
Related resources
July 29, 2008 1:08:17 PM

I have searched high and low for the microphone audio settings which would allow me to turn off looping or feedback. i cannot for the life of me find where it is located, if its even where it "should" be. Unfortunately i am still stuck
July 29, 2008 2:38:57 PM

Try using the microphone in a different application.
Check the settings for the applications affected.
July 29, 2008 2:41:21 PM

Turn off onboard sound in the bios.
July 29, 2008 3:04:32 PM

evongugg said:
Turn off onboard sound in the bios.


Yea, this happend to me. added a Sound Blaster Audigy and got feed back from the mic, sounded so godlike tho, hehe.
July 30, 2008 10:14:17 PM

In the playback devices, select your speakers, then properties. You can go to the levels tab, and scroll down until you see the mic. Check the mute box and that should take care of that.
October 17, 2008 5:08:58 PM

Hello, i'm french and my english is so bad.

Config : Vista X64 + XtreMusic + Koss SB45.
To reply on your topic, i have the similar problem (cf in french : http://forum.hardware.fr/hfr/WindowsSoftware/Vista/prob... ).
To resume, when i start my headphone, i listen my voice into.
In reality, when i start Vista, i haven't the problem, this appear when i launch " record of sound device" in french is : "Périphérique d'enregistrement "
You can see her :
Anonymous
July 31, 2010 12:59:45 AM

Hi, in windows 7 which should be the same as vista if you want to stop hearing feedback from the mic through your speakers.

right click volume control icon
click 'playback devices'
Click the properties of 'speakers'
go to 'levels' tab
mute microphone button.

That fixed it for me. I have realtek ac97 onboard sound with win7.
July 15, 2011 9:48:14 PM

I'm using Windows 7 and Tritton Pro headset. (not that it really matters)

I just figured out how to fix a similar problem.
The problem was that whatever my microphone picked up, it would play it back out of my headset.
So no microphone feedback or picking up residual sound from the nearby speakers, it would just play it back - talking to people was really difficult. There was a very obvious delay and whenever I'd try to talk to someone, I'd always have to wait until my voice (that was being played back) caught up to wherever I was in the sentence that I was saying.

Anyway. I wanted my microphone to still be functional, but I didn't want to hear myself.

Control Panel
Sound
Recording Tab
Right click -> Microphone
Properties
Listen Tab
[ ] Listen to this device (uncheck)

That worked
Skype, gaming and all else is working seamlessly with respect to the mic issue.




Hope this helped.
July 16, 2011 12:26:45 AM

This topic has been closed by Mousemonkey