Sign in with
Sign up | Sign in
Your question

Connect extra PC to home network but exclude it from internet access

Last response: in Networking
Share
January 20, 2009 8:13:39 AM

Argh! - Typed the post then lost it (my fault, not logged in properly and didn't save it properly)

So,

here's what I have:

Orange Livebox wired up to Linksys Router.

Desktop PC for general work, email, word etc (win XP)

Edit PC purely for video editing (win XP)

Laptop etc for wireless connection (win XP)
....

What I want to be able to do is to connect the Edit PC to the Desktop PC for file sharing but I don't want the internet anywhere near the edit PC. It has no antivirus etc and I don't want it to have!

I have a spare NIC I could put in the desktop PC so could connect them together with twisted cable etc but is there a cleverer way by configuring the linksys?

I'm OK with fairly simple networking but may need details on anything more complex!

Apologies if I've missed anything out but I can't see the wood for the trees.

Double apologies if this post turns up twice!
January 21, 2009 2:34:02 AM

What Linksys router is it exactly? You should be able to set some kind of Access Control Policy for the edit pc so that it has no access in or out.
January 21, 2009 6:35:03 AM

Sorry, yes its a WRT54GS - spotted an access restrictions section, would I be right in thinking that I could set two access policies and one could be allow all and the other would be deny all - and if I set a static IP on the edit machine and set this in the second policy all would be well?

Cheers again for the response :) 
Related resources
January 21, 2009 7:38:53 PM

You would be correct in thinking so. Although, I don't think a static IP would be necessary, as I believe it can be set by MAC address.
January 24, 2009 8:28:12 PM

thanks - I entered the mac addresses of two of the machines into two policies I created - one to enable access at all times and one to deny access at all times - it didn't seem to work though - the PC on the deny list was still able to connect even after an ipconfig renew and a restart.

I wondered if because its the livebox that's connected to the internet and the linksys is connected to this that the linksys can't govern what connects? - would i simply need to deny the extra PC from access to the livebox? - Thanks in advance!
January 25, 2009 2:44:05 AM

Hm, I'm not familiar with Livebox, so I really can't say.

However, if your setup goes like this..

Livebox > Linksys > Computer

..then the Linksys will govern all the computers under it, and the Livebox will govern all the computers directly attached to it, as well as the Linksys. After a quick Wiki search, I see that the Orange Livebox is a wireless router as well, so perhaps the edit pc is connecting to that instead of the Linksys? There's probably Access Control on the Livebox that you can try as well, just to be sure.

January 25, 2009 7:56:40 AM

seboj said:
Hm, I'm not familiar with Livebox, so I really can't say.

However, if your setup goes like this..

Livebox > Linksys > Computer

..then the Linksys will govern all the computers under it, and the Livebox will govern all the computers directly attached to it, as well as the Linksys. After a quick Wiki search, I see that the Orange Livebox is a wireless router as well, so perhaps the edit pc is connecting to that instead of the Linksys? There's probably Access Control on the Livebox that you can try as well, just to be sure.


That's right as above - Livebox -wired- linksys -wired- edit and desktop

Will have a look, but there's no wireless in either the edit or desktop - they're hard wired with ethernet cable just into the linksys.

I'm now wondering if there's a higher level control which enables/disables the access control - probably a tickbox somewhere....

Will have a look at access control on livebox, but wanted the edit machine not to even get that far - am now thinking a discreet single cable network between the two machines (with a second NIC in desktop) may be safer!
January 25, 2009 10:10:25 AM

im not sure if this would work, have you tried setting a static ip and setting the default gateway to 127.0.0.1? im thinking that might stop network access but worth testing.
!