Sign in with
Sign up | Sign in
Your question

HELP!! BIOSHOCK AND 3870!!!

Last response: in Graphics & Displays
Share
July 3, 2008 12:44:53 AM

i just got my HIS 3870 today and when i started up bioshock, the performance with the 8.6 catalyst drivers wwere worse then my 8600gt's performance... what am i doing wrong cause this cant be right....

please reply!!! i wanna play bioshock without lag!!!

thankyou all!!!

More about : bioshock 3870

July 3, 2008 12:58:01 AM

what rez do you game at i have the 3850 and it plays bioshock ok
but if i where you i would rma it and get the 4850
July 3, 2008 1:01:00 AM

i play at 1280x1024 and i am getting as low as 11 frames at the intro part. what drivers are you using? and it was tempting to go for the 4850 but i didnt have the money at the time.. my next upgrade probally ; )
Related resources
July 3, 2008 1:07:44 AM

I'm do not know what to tell you but ATI 3xxx verions they made some mistakes and now the 4xxx rox socks cuz they fixed most of the promblems if not all
July 3, 2008 1:11:10 AM

Obvious software issue.

Did you correctly uninstall old "Nividia" drivers.

You should be getting over 60fps with 3870. 3870 is actually very fast for this game because this engine relies on shader which 3870 is equal to 8800gt if not better.
July 3, 2008 1:11:58 AM

Hmm, I got better performance with my 3850 than you are claiming with your 3870. I've heard that the 3xxx series cards run better on cat 8.5. Maybe try that driver out.
July 3, 2008 1:12:32 AM

kelfen said:
I'm do not know what to tell you but ATI 3xxx verions they made some mistakes and now the 4xxx rox socks cuz they fixed most of the promblems if not all


There's nothing wrong with 3xxx series. It might not perform well as 4850 but it also cost cheaper.
July 3, 2008 1:36:09 AM

my bad :o 
July 3, 2008 2:15:23 AM

I'm with Marvelous... Gotta be your software: I played all the way through Bioshock on a 4400+ and a X1950Pro @1440X900 without so much as a hiccup... and the game absolutely screams on my HD3870 (Cat. 8.5 and 8.6)...

You in Vista or XP?
July 3, 2008 2:28:10 AM

i get 60-80 fps with my hd 3870 and bioshock with 8.6 drivers on 22" 1650x1050 monitor
July 3, 2008 6:45:16 AM

I'd the same problem though with different cards.... just uninstall the Nvidia drivers and reinstall the ATI drivers...should work fine. Cheers.
July 3, 2008 8:12:22 AM

kelfen said:
I'm do not know what to tell you but ATI 3xxx verions they made some mistakes and now the 4xxx rox socks cuz they fixed most of the promblems if not all


The guy is asking for help not asking for a replacement. And im pretty sure he knows about 4xxx kicks some ass
July 3, 2008 10:35:41 AM

rambo117 said:
i just got my HIS 3870 today and when i started up bioshock, the performance with the 8.6 catalyst drivers wwere worse then my 8600gt's performance... what am i doing wrong cause this cant be right....

please reply!!! i wanna play bioshock without lag!!!

thankyou all!!!


What settings did you activate in Catalyst Control Center (AA/AF)?

Uninstall Nvidia drivers
Uninstall ATi drivers
Use DriverCleaner Pro (google for download) to clean 1.) Cab file 2.) all ATI and Nvidia drivers
Reboot
Reinstall Cat drivers
July 4, 2008 5:39:38 PM

i have been trying to use all settings in catylist max but i get like 20-30 frames in bioshock when i do that. but when i switch to full performance mode i get around 60-100 frames like godless was getting. but i was expecting to be able to run with everything on max(including cataylist) smoothly:( . ive been using the beta 8.7 drivers, its been a small improvement in bioshock but not enough to make the game work smooth enough:( 
i will try the DriverCleaner Pro that Vokofpolisiekar told me to try. thanku for all your help people! i will post and tell yall if this works(hope so!)
July 4, 2008 6:21:43 PM

ok, i just did everything that Vokofpolisiekar suggested and it seems to be running smoother but i still cant get my catylist settings on max without getting super low framerates.. and btw my OS is XP
July 4, 2008 6:30:28 PM

Maxing out the AA is probably just too taxing. Just use 4xAA and see how that works for you.
July 5, 2008 7:52:34 AM

and what about the otehr settings? ccause it seems more like image quality one really makes a differance going from performance to quality. i have to set it to opptiminal performance to get those good frames around 60-80.
July 5, 2008 9:28:19 AM

AA really kills the 3xxx series I think. Maybe if you set all the game's settings to max, but leave AA off or at x2, you'll get good results.
a b U Graphics card
July 5, 2008 12:05:17 PM

Ive read somewhere the Unreal 3 engine dont like the cats with CCC...

try to download the stand alone driver without CCC.

please check your .net framework version as well.
July 5, 2008 6:45:02 PM

ok, i unistalled CCC and now it seems to be running a whole lot smoother, thankyou! and my .net framwork is version 2.0 btw. finally, i can play bioshock!!!

i thought that the amd improved the 3xxx series's ability to use AA though, cause the 2xxx serues was aweful with it on....
July 7, 2008 6:21:53 AM

rambo117 said:
ok, i unistalled CCC and now it seems to be running a whole lot smoother, thankyou! and my .net framwork is version 2.0 btw. finally, i can play bioshock!!!

i thought that the amd improved the 3xxx series's ability to use AA though, cause the 2xxx serues was aweful with it on....


Glad to hear you made some progress. As a guideline, use CCC in balanced mode and do not adjust AA and AF in CCC. Rather let the game you're playing do the post processing techniques like AA and AF sould it support it (most new games do it).

With older games which do not support AA and AF you can run out of CCC.

Lastly - adjusting the CCC slider I think includes MipMap settings which can degrade visual quality. If you have to go the CCC route, do settings individually and with incremental adjustments, always checking the performance before proceeding. Leave HQ AF for the last. And remember that no one game is the same. Some might run 8xAA and 16xAF while another would crawl at such settings.
July 7, 2008 11:17:07 AM

ATI 38xx cant run bioshock properly
July 7, 2008 11:55:16 AM

concrum said:
ATI 38xx cant run bioshock properly

??? are you dense?

38xx runs Bioshock well if not better than a lot of cards. Some of the settings need to be be right but it runs great as long as AA is set low. No its no gtx280 or 4870 but hey its still not a bad mainstream card.

Quote:
i thought that the amd improved the 3xxx series's ability to use AA though, cause the 2xxx serues was aweful with it on....


No sadly 3xxx improved a few other things but the AA performance was not updated till the 48xx series. This is mostly due to them having to change the way they designed the RV600 chip vs just a simple fix.
a b U Graphics card
July 7, 2008 12:01:36 PM

i just dont get it, i mean bioshock runs great on the 360 (ati gpu) but on the PC, whatever.

on a side note: "Would you kindly" buy a 4850 for me? :D 
!