Sign in with
Sign up | Sign in
Your question
Solved

Excessive hard drive activity

Last response: in Windows XP
Share
October 19, 2010 3:30:22 AM

Hi all-

I'm not sure if this should be in a Windows forum or a hard drive forum, so I'll start here first. Maybe it's a Windows setting?

Recently, within the past few weeks, I've noticed that my hard drive has been running more than usual. I can hear it running, and I see the activity light flashing when the computer is basically at idle and not doing anything. The weird thing is that if I hit CTRL-ALT-DEL and bring up the performance tab, on the top portion of the graph, there is a spike in CPU activity, with the time interval being almost exactly every 60 seconds for about 2 or 3 seconds, along with corresponding hard drive activity. Then it stops and the activity spike repeats about 60 seconds later, over and over. The annoying part of this is that if I'm doing something like typing an e-mail or clicking a link, the computer freezes for a few seconds while the hard drive runs, then resumes from the "pause" caused by the activity spike.

I did virus scans, spybot scans, etc., and wasn't able to find anything. I went into msconfig and unchecked all the boxes in the startup tab, rebooted, thinking it was something in the background, but no dice. I turned off my anti-virus to see if it was causing the activity, but the computer still did it. I still get that "cyclic" hard drive activity that freezes the computer's activity for a few annoying seconds.

That's about the limit of my knowledge in attempt to fix this. Any advice is appreciated. Specs below:

Thanks for your time.


Windows XP
Asus P5wDH Deluxe motherboard
Corsair DDR2 memory 4gb
ATI HD5870
Intel quad core
WD Raptor
BFG 650W power supply

October 19, 2010 4:55:30 AM

Good thought on turning off the antivirus. That would've been my first suggestion. Try running through the malware guide in my signature.
m
0
l
October 19, 2010 4:29:09 PM

aford10 said:
Good thought on turning off the antivirus. That would've been my first suggestion. Try running through the malware guide in my signature.


OK, thanks. I'll do that tonight and see how it goes!
m
0
l
Related resources
October 20, 2010 4:27:29 AM

aford10 said:
Good thought on turning off the antivirus. That would've been my first suggestion. Try running through the malware guide in my signature.


I ran through the steps in your signature but unfortunately I'm still having the same problem as described in the first post, with spikes in CPU/hard drive activity every 60 seconds or so with the system "hanging" for a few seconds during those spikes.

Any ideas for what the next troubleshooting step might be? Is there any software I could download that would tell me what software on my computer is accessing the hard drive at any given second, for example? Any setting in Windows that somehow got accidentally changed that is causing this?

Thanks for any ideas!
m
0
l
October 20, 2010 4:30:54 AM

The easiest way to find out if it's a program, is to open the task manager, click the processes tab, click the CPU column twice, and watch to see what service runs at the times it's lagging.
m
0
l
October 20, 2010 4:47:03 AM

aford10 said:
The easiest way to find out if it's a program, is to open the task manager, click the processes tab, click the CPU column twice, and watch to see what service runs at the times it's lagging.


Cool......didn't know I could utilize that tab in that manner......well what appears to be causing the spikes is the "System idle Process" with the number associated with it in the CPU column spiking up into the 90's every 60 seconds or so. Does that indicate anything?
m
0
l
October 20, 2010 4:50:28 AM

That's normal. The system idle should be using all of the CPU activity, except for the active services. If system idle is using 90%, then another active process(s) is using 10%.

It may help to try this in safe mode. There are less services and programs running there, so it's easier to keep an eye on what's running.
m
0
l
October 20, 2010 4:55:24 AM

aford10 said:
That's normal. The system idle should be using all of the CPU activity, except for the active services. If system idle is using 90%, then another active process(s) is using 10%.

It may help to try this in safe mode. There are less services and programs running there, so it's easier to keep an eye on what's running.


OK, I'll give that a try tomorrow and report back. Thanks for your help.
m
0
l
October 20, 2010 4:36:23 PM

aford10 said:
That's normal. The system idle should be using all of the CPU activity, except for the active services. If system idle is using 90%, then another active process(s) is using 10%.

It may help to try this in safe mode. There are less services and programs running there, so it's easier to keep an eye on what's running.


OK, pulled up the Processes tab this morning under the Windows Task Manager, and the image name "wmpnetwk.exe" user name "NETWORK SERVICE" is the item that is causing the spikes in hard drive and and CPU activity. Normally, under CPU it is taking up "00" but when the system goes through these spikes, the above mentioned NETWORK SERVICE spikes to about 25 under the CPU column and the image name "System" user name "SYSTEM" goes up to about 5 at the same time, with the System Idle process dropping to about 70-75 during the spike.

Hopefully that provides some useful information?

If this link works, here's how much activity I'm seeing with a normal bootup, background programs running, nothing open.

m
0
l

Best solution

October 20, 2010 5:13:58 PM

That is Windows Media Player, and likely caused by file sharing.

In the library tab, uncheck media sharing.

Then go to start-->run-->services.msc-->scroll down to Windows media player network sharing-->right click and stop it-->click on properties-->change it to a manual startup type.

That should fix it.
Share
October 20, 2010 7:38:53 PM

aford10 said:
That is Windows Media Player, and likely caused by file sharing.

In the library tab, uncheck media sharing.

Then go to start-->run-->services.msc-->scroll down to Windows media player network sharing-->right click and stop it-->click on properties-->change it to a manual startup type.

That should fix it.


Aford,

Yup, that did it. Thank you very much for your help. The next time I see you at a bar, I owe you an adult beverage or two :) 

Thanks!
m
0
l
October 20, 2010 7:39:03 PM

Best answer selected by ualdriver.
m
0
l
October 20, 2010 7:45:45 PM

Glad to hear it, and I look forward to it. [:aford10:6]

Thanks for the vote. :) 
m
0
l
!