Sign-in / Sign-up
Your question

5000X Board (S2696) - Using Onboard RAID

Tags:
  • NAS / RAID
  • Motherboards
Last response: in Motherboards
August 30, 2008 12:38:17 AM

Hello,

I have this 5000X chipset board.

First, I fought with this board for a week trying to figure out how to get RAID arrays setup. The board shipped with BIOS 1.04 and I've been through 3 other versions. I figured out that the Intel Storage Matrix Manager info doesn't show up if a SATA CDROM is attached to any of the SATA ports. Why? Can I not use some of the ports for CDROM and some for RAID arrays? That sounds pretty ridiculous to me.

So, I configured one two drive array in RAID0. Then I reattached the CDROM drive so I could install Vista x86. Now, I can get Vista setup to start, but when I insert a USB stick with the RAID drivers on it, as soon I click Next after selecting the proper ESB2 driver, I get a BSOD saying "IRQL_NOT_LESS_OR_EQUAL" and "STOP: 0x0000000A". I don't know what the deal is. I have four sticks of Kingston FB-DIMMs and have tried only one and different ones. I have two Intel Xeon E5345 chips and I've tried each by themselves.

When a CDROM drive is attached, I get the AHCI BIOS screen which properly detects all attached drives (whether they are hard drives or CDROM), but the Intel Storage Matrix Manager screen never displays the arrays or the message to press CTRL-I for configuration.

More about : 5000x board s2696 onboard raid

Anonymous
a b V Motherboard
December 5, 2008 10:10:26 PM

Dear music man,

I think i know the anwser for your problem.

the first 4 ports are being reserved for hard drives and sata port 5 and 6 can be used for dvd burner puripals.


after that you need to configure the bios that sata is enhanced and then you also can enable the raid controller functional.

when you have done al this, download the latest matrix manager from the intel website.

please let me know if this resolves your problem ..

I have one myself.. and it's regarding sas.. but I don't know if you have that onboard on your mb?

with kind regard

Marcel
m.van.waveren@upcmail.nl
January 7, 2009 3:39:39 AM

Well, I'm told by Tyan that it doesn't matter which ports are for what. I've tried your suggestion above, but I still do not see the Intel Storage Matrix post info (which says to press <CTRL+I> for configuration. I get it if I simply unhook all optical drives. I can't figure this out. Tyan won't RMA the board because they think my optical drives aren't compatible for some reason. I've tried 5 different models of optical drives.

Any other ideas?
Related resources
February 26, 2009 11:42:12 AM

try switching from enhanced mode to compatible mode in the bios under the sata port option, i cant remember exactly where its at but there is an option to change from ehanced to compatible for the sata ports. and then try to load your raid drivers
November 11, 2009 8:24:11 PM

I had a very similar issue and luckily I found this website. Hopefully this will help you or someone else.
http://www.ithinkdiff.com/how-to-enable-ahci-in-windows...

AHCI (Advanced Host Controller Interface) enables native command queuing and hot-plugging through SATA host controllers (Serial-ATA) for your hard drives. In many scenarios it enables more efficient multi-tasking. Vista was the first Windows OS to support AHCI out of the box, where as Windows 7 does the same. But an issue with AHCI is that if you install the OS without enabling AHCI in the BIOS, enabling it after installation will render your OS unusable. This is because Windows disable the AHCI driver since it is not needed during the installation.

There is one way to fix this, although you need to have knowledge of registry editing. The detailed steps from Microsoft are as follows:

To resolve this issue, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci

In the right pane, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.
After this you’ll have to restart your computer, go to BIOS and enable AHCI. When you log in to Windows again, you’ll notice the installation of drivers for AHCI. Another restart will be required to finish the driver installation.

I’ve simplified the steps by Microsoft by exporting the registry key. Just download the following file and run it. You’ll still need to go through the steps of restarting your computer and enabling AHCI in the BIOS.

Hopefully, you’ll find a somewhat noticeable improvement in multitasking, specially if you’re a notebook user. Of course with the variety of PC hardware, experience many vary.