Sign in with
Sign up | Sign in
Your question

A Curious RAID problem

Last response: in Storage
Share
October 14, 2009 7:24:48 PM

Wonder if anyone can shed some light on my problem

I am running a MSI K9A2 CF, Athlon X2, 4GB Ram, using the RAID mode with 2 identical Hitachi drives in RAID 0. In addition I have a second drive (another Hitachi) running in JBOD

Its all running fine under Windows XP Pro I have even got a Slipstreamed CD with the RAID drivers on it which I have once before reinstalled from.

However today I attempted to install the Win 7 RC and my RAID controller did not show up in the options. According to MSI it should so I tried all the obvious things and still nothing. I therefore like a brave explorer.... gave up and thought oh well XP again it is so I put in my trusty disk rebooted and went to install XP and ... no RAID Arrays again. Now I know they exist and I know they work because I'm using it right now.

Can anyone cast any light on my problem?

More about : curious raid problem

a c 127 G Storage
October 14, 2009 8:03:13 PM

You tried to install Windows 7 RC on the RAID0 array, which at the time contained Windows XP, right? Then why would you re-install XP afterwards? If it was already installed why should you have to re-install?

So i guess i don't understand yet, please explain carefully what happened. Your issue is that you want to recover the original RAID0 with XP installed to it, right?
October 14, 2009 9:14:27 PM

Ok essentially I desided to move to Win 7 RC my XP install was getting a bit grindy so I figured Id reinstall it anyways.

I ran up the Win 7 Installer (by rebooting off the DVD) and none of the RAID Arrays showed on the options for install. I figured no drivers but the MoBo manufacturer said there were in the install.

At this point I decided to give up. I have always been able to reboot into XP (the grindy one) so obviously the RAID still works its just not showing on the install options

So I decided to give up on Win 7 and decided to reinstall XP instead. However the RAID Arrays were not showing in the install options for XP either (I was using a slipstreamed disk with the drivers for the RAID. A disk I have used on this system so I know it works) So still no sign of the RAID Arrays.

So now Im wondering how I am able to boot off a drive that no windows install acknowledges the existance of.

FYI I tried putting the SATA controller in IDE mode and it showed the drives in the install options. I then put it back to RAID mode and nothing again.
Related resources
a c 127 G Storage
October 14, 2009 9:41:35 PM

You need drivers; windows 7 is the easiest because you can put them on an USB stick and it would read those during install so it can find your RAID.

XP has the same issue for RAIDs. Some say their RAID controller worked without installing additional drivers; meaning windows 7 has some drivers already included.

Try downloading the RAID drivers on another system and put them on USB stick and re-install windows 7 and see if it can find your RAID so you can install.

As i understand, you don't need the data currently on the RAID; right?
October 14, 2009 10:01:51 PM

I understand your point about drivers however as I stated I have a slipstream XP disk with my RAID drivers on. I have used it before and it worked just fine. Now it does not work.

I do not need the Data on the RAID.

I have already tried downloading the drivers MSI swears are in Windows 7 independantly and tried them on a USB drive, apparently they are not new news to Windows 7.

I am convinced it is not a straightfoward driver issue for these reasons.
a c 127 G Storage
October 14, 2009 10:49:06 PM

And during BIOS boot, you can see your onboard RAID saying that its running a RAID0 array and both disks are found?

What RAID controller are you using?

When you tried installing Windows 7 for the first time, did it find one or maybe even both disks?
October 15, 2009 5:40:30 AM

During the BIOS boot the RAID controller initializes and acknowledges the RAID 0 and the JBOD disk as functional. I am using the RAID controller on the K9A2 CF motherboard. When I tried to install Windows 7 it only found the IDE drive and the DVD drive which I have in my system.
a c 127 G Storage
October 15, 2009 1:37:56 PM

This should still be a driver issue. If the RAID BIOS detects your harddisks belonging to a RAID-array, the drivers should see this array as well. Simple as that.

Is there no chance you did something wrong with the drivers? If you don't need the data on the disks, can you break the RAID and re-create it again?
October 15, 2009 2:11:31 PM

No chance I did anything wrong with the drivers as the disk had worked on this very machine with exactly this config before. I have already broken and recreated the RAID to no avail
a c 127 G Storage
October 15, 2009 2:53:54 PM

Then i can't help you. This should work; you may be encountering a bug or some other issue, but i ran out of ideas.
October 15, 2009 9:29:21 PM

Thank you for trying. Anyone else got any ideas ?
a b G Storage
October 15, 2009 9:42:59 PM

The problem is the driver, I had the same problem with a K9A2 Platinum and win Vista and Win 7, both x64. Solution, download the correct driver, convert both disk to dinamic and try the installation again.
October 19, 2009 9:30:26 PM

Ok in Windows 7 turned out after some messing about it was a driver problem which made me feel foolish that'll teach me to believe MSI. Does not solve my XP issue however still don't understand how a working slipstream driver disk did work and now doesn't but guess I won't let it bother me. Thanks for all your help guys. Problem solved.
!