Sign in with
Sign up | Sign in
Your question

Asus M3A + more than 3gb ram = very strange behavior

Last response: in Motherboards
Share
August 30, 2008 10:06:18 PM

Hi!

My config is:
Asus M3A
Athlon64 X2 4400+
Radeon HD3850 512mb
2x1 Gb CSX 800Mhz DDR2

I used Vista SP1 x64 on this machine. 2 weeks ago i bought more ram (2x2 Gb CSX 800Mhz DDR2, same as the 1gb ones, in every properties, exept the size).

I put them in, pushed the power button, got though POST, vista started to load, then the loading status line stopped, and BSOD. The message is:
The bios in this system is not fully acpi compliant blablabla

stop: 0x000000A5 (0x0000000000001000, 0x0000000000000000, 0x00000000FFFFFFFF, 0x0000000000001000)

I did everything after this, tried all combinations of rams modules, memory timing and voltage settings, but nothing worked. The strange is that the memtest didn't found after 2,5hours testing, and linux x64/or x86 working without problem.
Just i found found a strange thing. No matter what memory i use, if there is no more than 3gb ram in slots, then everything works. If more than 3gb then i get the error. And more things with more than 3gb ram in machine:
Memory counting at post (if i disable quick boot) stops at 3348Mbytes for 2 seconds, then it continues the counting at 4096mb, even if i got exactly 4gb ram, it counts it to 4864mb, if 6gb then to 73xx mbytes, but after it finished, it returns to the correct size (4096mb or 6144mb), and writes "OK". Then with 4gb ram at the hardware tables before booting the os i can see: base memory: 640k, extnd memory: 4096mb, 4gb+ 768mb so it writes to this table too, that plus "phantom memory".

I tried to reinstall vista, but when the installer loads the base vista from dvd, bsod with the same error.

So i tried windows xp pro sp2 x64. I've installed it and it's works. But it puts an error event message to system event log, every start if there is more than 3gb ram in the machine:

AMLI: ACPI BIOS is attempting to create an illegal memory OpRegion, starting at address 0xffffffff, with a length of 0x1000. This region lies in the Operating system's protected memory address range (0x100000000 - 0x130000000). This could lead to system instability. Please contact your system vendor for technical assistance.

http://support.microsoft.com/kb/330054/en-us

(of course the address range is depend from the ram amount in machine, this is 4gb)

So it says that the memory range from 4294967296 bytes (4gb) to 5100273664bytes (4864mb) there is an error. (Of course there is bcuz that range in memory is not exists). If there is all ram in machine (6gb) it says from 4gb to that 73xxmb).

But in system/general it says that there is 4gb or 6gb in the machine what is correct.

I use the newest bios (1001), so i contacted with asus support. They said the ordinary "put the rams to this slot and that slot, check voltage and timings, blabla" and i said nothing working so they said then i should use 4x1gb ram... so they don't wanna help really.
August 31, 2008 12:16:15 PM

As i said, i have sp1, and it's contains this update.
Anonymous
a b V Motherboard
February 17, 2012 5:44:49 PM

i have the problem with my windows 7 machine
!