Sign in with
Sign up | Sign in
Your question

Primary SATA...won't recognize IDE

Last response: in Storage
Share
October 15, 2009 2:46:53 AM

Hi all!

I am using a Gigabyte GA-K8NS-939 board and running an 80GB SATA drive for my main, and as it stands, lone means of storage. My motherboard has 2 SATA slots and 2 IDE slots (IDE1/IDE2.) On IDE1...I have my DVD burner. I am now wanting to add a second HDD for storage and such, and it is an IDE.

When I tried to install the IDE HDD on IDE2, I set the jumper to Master (even tried cable select) and neither my BIOS, nor Windows would recognize the device whatsoever. I attempted to place the drive as a Slave (and cable select) on IDE1, leaving my DVD drive as master, but IIRC, that didn't work (pretty sure, though not 100% that I did try this), and regardless this wasn't much of a permanent solution because the IDE cable wouldn't reach to the HDD (leaving the HDD dangling.)

Is there some mystical way to making this work? Am I doing/not doing something?

I would VERY GREATLY appreciate answers if you can provide them.
a b G Storage
October 15, 2009 12:31:53 PM

Is this a new drive or and old one you had laying around?
Could you tell if the drive was spinning up at boot?
Try installing it in another computer to verify it's good.
m
0
l
a b G Storage
October 15, 2009 12:41:56 PM

Make sure both power and data cables are connected.
Try a different data cable.
In the bios, make sure that IDE2 channel is enabled.
Some older computers had problems running both SATA and IDE.
m
0
l
Related resources
a c 127 G Storage
October 15, 2009 1:20:09 PM

If you connect it as being the single device on the PATA cable - it should work regardless of jumper setting. So try again; how exactly do you know if its being detected? During POST you should slee something like:

primary master: DVD drive
primary slave: none detected
secondary master: HDD blabla
secondary slave: none detected
SATA1:
SATA2:
SATA3:
SATA4:


etc.
m
0
l
a c 342 G Storage
October 15, 2009 1:37:21 PM

Well, I agree what you did should have worked, with one small change. Your first attempt was to connect as the Master on IDE2, but did not work. Three ideas to check there. One is, as evongugg said, check in BIOS that IDE2 is Enabled. It is possible that the IDE2 port or cable was faulty. And last idea, check the HDD jumper setting options. A few drives had different settings for Master with No Slave, and Master with Slave Present.

Then you tried connecting it as Slave on IDE1, still not working. In that situation, SOME optical drives cannot function as the Master. So, try both on IDE1 again, but make the HDD the Master on that channel, and connect it to the END connector. Then set the optical drive's jumpers to Slave and plug into middle connector. That MIGHT make a difference.
m
0
l
a c 127 G Storage
October 15, 2009 1:39:44 PM

Both jumper options should work if there is no other device on the cable, though. But i guess he should try this again because it should just work.
m
0
l
a b G Storage
October 15, 2009 3:37:29 PM

If it is a Western Digital drive try without any jumper for master/slave. I know older drives required no jumper if it was a single drive.
m
0
l
October 19, 2009 1:16:22 AM

Thanks for the responses guys! I haven't tried anything lately because I have been busy...but am going to work on it now.

Thought that I would answer some of your questions in case I don have problems later.


sturm
Quote:
Is this a new drive or and old one you had laying around?


It's an old drive that I had in my old PC.

Quote:
Could you tell if the drive was spinning up at boot?


I couldn't tell.

sub mesa
Quote:
So try again; how exactly do you know if its being detected?


It does not show up in the BIOS.

sturm
Quote:
If it is a Western Digital drive try without any jumper for master/slave. I know older drives required no jumper if it was a single drive.


It has jumper settings for master.

Sorry if I missed any...gonna give it another shot soon and will report back.
m
0
l
!