Sign in with
Sign up | Sign in
Your question

Help with vista 64 will not use more then 2gb of memory

Last response: in Memory
Share
Anonymous
a b } Memory
September 1, 2008 7:44:50 PM

Im running vista 64 and i have 4 gigs of memory, it shows up in the bios and the windows system page but does not show up in the task manager, ie its not using the other 2gigs is there a buggy update that i need to uninstall becuase it was working at one point and time i just happened to notice this recently.

Edit, Im runing an asus p5n-d an intell core 2 quad 2.4ghz and 2 2gb sticks of muskin

More about : vista 2gb memory

a b } Memory
September 1, 2008 8:03:32 PM

enable the option in the bios called Memory remap or similar.

EDIT, see it was working. Strange. Was the bios updated or reset any time?

I use 8 and it works fine.

so under Total you only see 2048?
Anonymous
a b } Memory
September 1, 2008 8:22:04 PM

yes this is correct 2045 rather iv ran every memory test i can think of /find iv tryed swaping sticks using one at a time to see if ones defective i switched channels from a to b and vista reconises that i have 4gb installed so does my bios it just wolnt use it all.
Related resources
a b } Memory
September 1, 2008 8:34:09 PM

Is the memory remap feature turned on in the bios if it has it.
Anonymous
a b } Memory
September 1, 2008 8:42:05 PM

you konw i looked and i cant even find one in the bios but it worked before, im thinking about just buying a new mobo i mean i could sware its vista because usualy the os wolnt even show you what your total installed physical memory is if the option isnt turned on.
a b } Memory
September 1, 2008 8:49:47 PM

After SP1 Vista would show all ram the bios sees and even show that to the user in the system properties. So now even vista 32 users get to see 4 gigs instead of 3.XX.

For the hell of it try to reset the bios and then go make sure your settings are normal to see if it helps any.
Anonymous
a b } Memory
September 1, 2008 8:59:40 PM

ok i reset the bios 100% and im still only reading 2045 it really makes no sence to me. im not using any thing in my regular pci slots so thers no reason for it to have it mapped.
September 1, 2008 9:10:26 PM

Quote:
ok i reset the bios 100% and im still only reading 2045 it really makes no sence to me. im not using any thing in my regular pci slots so thers no reason for it to have it mapped.



type msconfig in the run box. then go to boot.ini or sth like that. then choose advanced options. then uncheck Maxmem option. then restart your pc. then you will see all your memory. Let me know if that works.
Anonymous
a b } Memory
September 1, 2008 9:15:41 PM

dude your the man thank you sooo much it worked no idea how that got turned on in the first place but shes man i thought i was gonna have to get a new mobo thanks man
September 1, 2008 9:18:10 PM

Quote:
dude your the man thank you sooo much it worked no idea how that got turned on in the first place but shes man i thought i was gonna have to get a new mobo thanks man


You are very much welcome. I would recommend you turn on the max number of processors. just turn off the maxmem option.
Anonymous
a b } Memory
September 1, 2008 9:19:15 PM

ill do that thanks again
!