Sign in with
Sign up | Sign in
Your question
Solved

XP cannot change default program to start DVD

Last response: in Windows XP
Share
October 24, 2010 1:40:55 PM

I have XP MCE. My DVD drive defaults to using Media Center for playing DVDs. However, my Media Center player seems to be corrupted because there isn't a "Play DVD" option anymore.

I tried to change the default autoplay option to VLC, but the drive still defaults to Media Center.

I can play a DVD manually using VLC OK by right-clicking on the drive containing the movie.

Is there any way to resolve the problem without performing a Windows reinstall?
October 24, 2010 2:44:17 PM

Start/Settings/Control Panel/Add-Remove Programs/Add-Remove Windows Components/Un-Check 'Windows Media Player' to remove WMP. Play a DVD now and it will need to know what to play it with, select VLC.

Go back and re-check 'Windows Media Player' to re-install WMP and see if it either plays DVD's properly or not at all (automatically).

or....

Open DVD in Windows Explorer,
Go to VIDEO_TS folder, right-click on VIDEO_TS.IFO and select "Open With" and select VLC.

m
0
l
October 24, 2010 3:40:10 PM

My problem is with "Media Center" and not "Media Player". Media Center is part of the Operating XP MCE Operating System and I can't remove it.

Opening a DVD works fine from Explorer using VLC, but I really would like to stop the Media Center starting when I insert a DVD
m
0
l
Related resources

Best solution

October 25, 2010 2:54:14 AM

Disable the DVD drive autoplay using properties in Windows Explorer.

or,

Right-click the DVD drive, select Properties
Click the AutoPlay tab
Click the dropdown box and select DVD Movie
Click the "Select an action to perform"
Select "Play DVD movie using VideoLAN media player"
Click Apply
Click Ok.

Put in a DVD and see if it obeys.
You may have done this, but since there are a few ways to do a similar method, I put this in for redundancy.

You can download the Microsoft Autoplay Repair Wizard
HERE or Microsoft Windows XP PowerToys HERE.

Share
October 25, 2010 10:30:18 AM

My computer must have a serious problem, I have turned off autostart in my CD drive and still Media Center starts. I think it time to do a Windows reinstall. Thanks for you help
m
0
l
November 25, 2010 4:17:51 PM

Best answer selected by buwish.
m
0
l
!