Logitech EX110 Keyboard problems

Ok this might be a bit stupid topic but i have some problems with my Keyboard , F1 to F12 buttons dont seem to work , they worked before but they dont now. ( Its not a battery problem and my keyboard is in fine condition - its not broken / or sometin)
For example i cant use Alt+F4 and some other commands that include using F1-F12 buttons
Thanks for any help
4 answers Last reply
More about logitech ex110 keyboard problems
  1. Sounds a little like a broken keyboard to me... Unless there is any simple-by-accident-way to turn off those keys in Windows...
  2. I have a few of these keyboards at home, but for the life of me I can't remember if they have an F-Lock key (I have a different keyboard for myself). If there is, make sure it hasn't been pressed to disable the F key functions.
  3. i have a Logitech keyboard (forgot the model) and it has an F Mode key, when its on the F buttons second fuctions are active. e.g. F1 - F4 open word, excel, etc... but as i dont have them installed they do nothing. if you keyboard doesnt have an F mode button or similar try the setpoint drivers (or what ever they are called) should be able to disable it so that F keys work correctly.

    simple test would be to boot the computer up and press F8 on start up and if the start windows in safe mode prompt comes up then you will atleast know the keys are working and its just a software/setting problem. hope this helps
  4. Well i know that SetPoint can make the F1-F12 work but not in the way they worked before , as u mentioned F1-F4 u can open word excel or set it to do something else ( with SetPoint ) , but i cant get them to work on their default bindings
Ask a new question

Read More

Keyboards Keyboard Problems Logitech Components