Sign in with
Sign up | Sign in
Your question

The Witcher won't work, can't figure why.

Last response: in Windows 7
Share
September 1, 2011 4:40:13 AM

I've been playing The Witcher enhanced edition on my previous desktop. Now i've got a new desktop, and since The witcher is one of the best ganes I've ever played, i want to install it on my new system.
The installing itself wasn't much of a problem - I ran the setup.exe file with admin rights and it installed smoothly.
Sh*t started after that.
Neither the launcher (launcher.exe) nor the game itself (witcher.exe) won't work. the bad part is, there isn't the slightest clue why it won't work. when i try to run it, the cursor changes to "loading" - with therotating circle - for about half a second, and after that... nothing happens.
This is what I've already tried:
- run with admin rights
- run in compatibility mode (win xp sp3)
- reInstalling the game
- download and install latest tages-drivers
These "solutions" all failed. I also tried patching The Witcher to version 1.5, but TheWitcherPatch.1.5.exe won't work, too. When i try to run it, the Instalation Wizard claims that The Witcher isn't properly installed - which seems unlikely, I've tried re"installing at least 5 times.
the Windows website claims that The Witcher isn't compatible with Windows 7 x64, but several people on different forums claim they're running it smoothly on Windows 7 x64. One of them even runs it on the very same OS as i do, so it must be possible in some way. Does anybody have a clue as to why it won't run at my desktop?

Thanks in advance!

btw, here are my most relevant specs:
- OS: Windows 7 Ultimate x64
- CPU: intel core i7-2600K @ 3.40 GHz
- Motherboard: ASRock P76 extreme4
- RAM: 8GB
- display adapter: NVIDIA GeForce GTX 560 Ti

More about : witcher work figure

September 1, 2011 4:54:55 AM

Windows 7 can be very annoying when it comes to compatibility, I had the same thing happen to me with Fallout 3. Trust me, there's nothing you can do. I've tried everything. Sorry =P
m
0
l
!