Sign in with
Sign up | Sign in
Your question

Ext. HDD not seen after years working fine

Last response: in Storage
Share
October 20, 2009 5:37:13 AM

I need some help troubleshooting the My Book external HDD that all of a sudden is not seen by my Vista computer. The usb plug is in the computer and the other end in the HDD. The HDD is plugged in and the light is on.
I unplugged it and replugged it (power and data).
What do I try next friends?
October 20, 2009 7:44:57 AM

Have you tried plugging into a different usb port, or to another computer?

Another method is to remove hd inside your MyBook and connect it directly into your computer.
m
0
l
Related resources
October 21, 2009 5:33:55 AM

jobz000 said:
Have you tried plugging into a different usb port, or to another computer?

Another method is to remove hd inside your MyBook and connect it directly into your computer.


Yes, I moved the hd plug to a different USB port on the laptop. same problem
I will try connecting the MyBook to another computer to see if that makes any difference. I'd prefer not to have to remove the HD from its case, and all that.
But, I may have to.
Thanks
m
0
l
October 28, 2009 3:43:49 AM

jobz000 said:
Have you tried plugging into a different usb port, or to another computer?

Another method is to remove hd inside your MyBook and connect it directly into your computer.


It does not work on my other computer either, and I switched USB ports. It has a firewire port which I have not tried yet.

Thanks for your interest,
Richard
m
0
l
!