DVD Movie will not eject

Weird problem that I have where a dvd movie (in this case) Rain Man won't eject from my computer. Won't even load. Just has the green access light consistently on my drive but computer doesn't access it. What's weirder is that it only happens with a few dvd movies. Some work fine.

I of course can shut down the computer and get the disc out but that doesn't really fix my problem. I don't have nero or any other burning suite installed except BurnAware Home. I do have ANYDVD installed but I tried to disable that before putting in the disc and it still didn't load/won't eject.

running win 7 and the drive is the asus 2014lt

thanks!
2 answers Last reply
More about movie eject
  1. Do you notice any similarities between the disks that refuse to eject? Are they limited to a certain region or something?
  2. i tried it on both drives...i don't think it's a drive problem. i think certain movies are giving me issues....no idea why
Ask a new question

Read More

DVD Writers Movies Computer DVD Storage