Sign in with
Sign up | Sign in
Your question

Problem Updating BIOS

Last response: in Motherboards
Share
September 7, 2008 4:09:23 AM

Hello there. I recently build my first PC and the current BIOS does not seem to support my CPU. I am using a GA-x48-DS4 (rev. 1.3) motherboard from Gigabyte. I DEFINITELY got the right BIOS file from the Gigabyte website (I got F2 and my board came with F1). So I tried it first through Q-Flash and got the error: "BIOS ID Check Error." Then I tried AMIFLASH and got some error telling me that my BIOS cannot be flashed. Eventually I gave in and tried WinFlash v1.90 as the other version didn't even work for me, and the program froze at "Erasing DMI Data" but I closed the program and my computer is still on so I guess I am OK...anyway I do NOT have a floppy drive and I have been using a combination of USB Flash Drive and CD-ROM Drive to try the things before startup. I HAVE searched and googled for LITERALLY OVER 7 HOURS trying to solve my problem but I can't find anything. I do not see a switch to enable flashing in my BIOS, nor do I see one on my motherboard. I have tried deleting my CMOS (shorting the thing on the motherboard) and it didn't seem to affect my computer in any way...I will try that again if it comes up as a suggestion.

Please Help Me! Thanks!

More about : problem updating bios

a b V Motherboard
September 7, 2008 4:53:31 AM

when you did the bios you did remove the battery,and considering your situation,,,for at least 5min ???,,if you cannot flash the beast and you do not have a floppy,,consider RMA'ing the mobo,further playing around will only aggrevate the situation,some manufacturers can and will send you a replaceable bios chip for X$$,if the bios does not seem to support your cpu,,then what are you using for a cpu to do the bios with??ciao..:) 
September 7, 2008 6:01:39 AM

No. There are two pins right above the battery and I used a screwdriver to make a connection between them for about 5-6 seconds. That was supposed to short out the CMOS or something. I did exactly what it told me to in the manual. If the floppy drive is that big of a deal I can try to get one out of another computer. I really do not want to RMA.

And I think I used the wrong words when describing the situation. My CPU is "supported" but it is not being recognized completely. It is registering as a Pentium III but it is really a Core 2 Quad. My computer "works" but it is not working...*perfectly*. Even if the BIOS is not a problem, I want to be able to update it.
September 7, 2008 7:23:33 AM

Ok I have fixed my problem. For any of you out there who get this SAME PROBLEM! Here is how I solved it:
Used Award WinFlash and updated my BIOS's Main Block. It would not touch the DMI Block as it froze at "Erasing DMI Block." After that, your BIOS is mostly changed but if you NEED to fix the Boot and/or DMI Blocks, you can then set the BIOS setting to turn off the protection. I seem to have found mine only after I updated partly. Cheers!
!