Sign in with
Sign up | Sign in
Your question

ECS mb won't post in new build. Help!

Last response: in Motherboards
Share
September 8, 2008 12:41:59 AM

"Sure, I'll build my own PC, why not? How hard could it be?" Famous last words, right? :sarcastic: 

Anyway, here are my stats:

Elitegroup A780GM-A motherboard
AMD Phenom X4 9950
Antec 300 case
4G Kingston DDR2 SDRAM (2G x 2)
500 power
...and a bunch of hard drives and DVD writers that don't seem to make a difference right now because I get the same symptoms whether they are connected or not.

Everything seems to power up okay. But I'm getting no picture out of the on-board VGA, and no beep when I power up. (The lack of beep isn't a surprise, because the case appears to have no speaker. Could that be right?)

As far as I can tell I've connceted everything where it is supposed to go, except for the case speaker. I've played around with the RAM in different slots, taken out and replaced the battery, tried a different monitor...no dice.

I left all the jumpers the way they were when I took the mobo out of the box. There are 3 3-pin jumpers for USB power controller, and all are set to VCC5 as opposed to 5VSB. But seeing as how I have no idea what those mean and I could find any info online, I'm not messing with them yet. :sarcastic: 

Please please please...help! Thanks.

More about : ecs post build

September 8, 2008 12:46:38 PM

Some cases may have a tiny speaker like this behind the front panel:

http://www.clearpc.ca/catalog/images/speaker.JPG

It can be hooked up to the SPEAKER pinout on the mobo.

As for the unknown jumpers, look them up in the manual in the layout section. It's got to be numbered & explained on the same or next page. Then in the next section the use will be explained.

Try each stick of ram in each slot.
September 8, 2008 11:48:32 PM

Still no luck. Tried every configuration of RAM I could think of, and even tried 1G (2 x 500M) left over from my old computer, but I'm still getting no picture. Even weirder, I scavenged a speaker from an old case (my new one indeed has no speaker) and the mb won't beep. It's like the thing is in a coma, only sign of life is the case and CPU fans.

I also tried clearing the CMOS. Still nothing.

Oh BTW, I made an error earlier: The RAM isn't Kingston. I asked for Kingston, but the guy at the shop was out of stock, so I bought Super Talent instead.
Related resources
September 9, 2008 10:57:57 AM

Super Talent is better for overclocking unless Kingston still uses Micron chips.

Try clearing cmos for 10 mins to overnight just in case. If no luck, rma the mobo & ram.
September 10, 2008 10:04:20 PM

Let the CMOS clear overnight, and even tried taking out and reinstalling the CPU and heat sink. No dice.

Guess I've got a bad mb. What a drag. Thanks for your help, hopefully my next mb install will be smooth sailing.
a c 435 V Motherboard
September 11, 2008 6:19:00 AM

I'd say the problem is the power supply or the cpu. Some boards won't post with newer phenoms. You may need to flash the bios or try a different board.
September 12, 2008 4:41:16 PM

Hey, this is interesting. I may have figured out why it's not working.
According to this article I found, the Phenom 9750 and 9850 require a 790 chipset on the mobo. I assume this applies to my Phenom 9950 as well:

http://technologyexpert.blogspot.com/2008/05/amds-pheno...

But according to the specs, my mobo has a 780G chipset:

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Would this explain why I can't get the mobo to post?

I assumed this CPU would work with this mobo because newegg offered them both in a discounted package deal, but now I'm wondering if they goofed.


September 13, 2008 3:34:14 PM

I thought I did, newegg was selling em both together as a package. Guess I'll have to be more careful than I thought.
September 15, 2008 10:24:13 PM

the ECS Blackseries motherboards dont support 125watt+ CPU

no newegg is not selling them as combo, they are selling the biostar and foxccon that do work with that cpu based on the 780gx chipset
!